Jump to content

[Solved] Help with registry. How to add runonce command for default user?


stsaerox
 Share

Recommended Posts

If I enter a command for each user created to run from runonce what I should do?

If I use wim registry editor and load "users\default\ntuser.dat"

and add my command to:

HKEY_LOCAL_MACHINE\WIM_Default\Software\Microsoft\Windows\CurrentVersion\RunOnce

Will it run every time a user is created?

I Know that I could test but I'm in hurry to reinstall windows 7 in 3 Pc home network before my trip there ends.... And I'm not that familiar with 7. That is something I would have done in the same case for XP.

Also I cannot figure how does the changes been saved? If I close registry editor and save the image will these just be saved?

Link to comment
Share on other sites

If I enter a command for each user created to run from runonce what I should do?

If I use wim registry editor and load "users\default\ntuser.dat"

and add my command to:

HKEY_LOCAL_MACHINE\WIM_Default\Software\Microsoft\Windows\CurrentVersion\RunOnce

1. Will it run every time a user is created?

I Know that I could test but I'm in hurry to reinstall windows 7 in 3 Pc home network before my trip there ends.... And I'm not that familiar with 7. That is something I would have done in the same case for XP.

2. Also I cannot figure how does the changes been saved? If I close registry editor and save the image will these just be saved?

1. Yes.

2. Yes

Link to comment
Share on other sites

Why this registry file won't run then ?


Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce]
"TITLE"="Setting Windows and applications"
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce\096]
"1"="C:\\ProgramData\\RegSets\\applyREg.bat"

I've tried to run manually the batch file and runs ok. But I need to run this every time a user is created. Regsets folders contains .reg files with HKCU content, from each tweak is made and program setting which will run every time a user is created to provide currently suggested default settings...

Edited by stsaerox
Link to comment
Share on other sites

I've Found a funny solution at last. I've created in:

%systemdrive%\users\DEFAULT\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup

A file "RunREG.bat" which contains:


@echo OFF
echo Setting default windows and applications settings
for %%a in (%allusersprofile%\RegSets\*.reg) do regedit /S "%%a"
del "%userprofile%\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup\RunREG.bat"
pause

As you may already understand (just explaining for newbies) when a new user is created the personal folder will be copied from the default user containing the RunREG.bat which will run all registry files in the "%allusersprofile%\RegSets\" and delete itself!!! That means that windows won't find again the same file to run again and again. It is like a custom runonce.

So next time I only have to add this on DVD root: Sources.rar

I was searching all day and got sick of it.. I've tested one or two methods but most of I could not understand.

Here are some of my findings. Solutions that may work also for anyone searching.

http://www.symantec....ofile-user-wind

http://www.mombu.com...75259-last.html

The last two may contain a proper solution but I got really tired of it.... and I could not understand.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Similar Content

    • By Martin Mortensen
      Hello,
       
      I'm having some trouble with the Win Toolkit Run Once Installer, not running after the installation.
       
      The system32\WinToolkit_RunOnce_Log reports the following:
      Version: 1.4.38.10Description: -----------------STARTING--------------Version: 1.4.38.10Description: IsSystem: TrueIsAdministrator: TrueVersion: 1.4.38.10Description: WriteValue:HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce | !1WinToolkit=WinToolkitRunOnce.exe | StringVersion: 1.4.38.10Description: Running as system. Aborting...If I start the WinToolkitRunOnce.exe manually everything runs without problems.
       
      Any help is much appreciated
       
      Regards,
      Martin
    • By Legolash2o
      Can everyone who receives the NSIS error please try the latest test build and report back please. I think it would be best to have one pinned topic to investigate this issue.
       
      Thanks. 
    • By Alexandre
      Dear friends I'm very excited about the RunOnceEx will work.
      I do not know if I'm talking nonsense. but after the installation is complete. The RunOnce screen appears and while installing the system restarts and after the Logoff back to reinstall it again.
      The following attachment image of the moment.
      http://imageshack.us/photo/my-images/600/bugrunonce.jpg/
×
×
  • Create New...