Jump to content

Bye Bye v1.4.0, Hello v1.5.0


Recommended Posts

Beta test 7 released.

*^FIX: Hopefully no more hanging when compressing images

*^FIX: AIO > Files would not work properly if user put C:\ in save to path

*^FIX: McRip servers now working

*^FIX: Silent Installer should now work on Windows 8

*^FIX: AIO > Files could did not work properly without file extensions

*^FIX: Could not change Unattended serial

*^FIX: Fixed form showing transparent on startup

*^FIX: Fixed TransparencyAll settings and set forced minimum of 40%

*^FIX: WIM Registry Editor did not load default key

*^FIX: Statusbar flickered when adding updates in AIO Integrator

*^FIX: Options column in AIO Integrator was not the correct size

*^FIX: Fixed user from being able to open multiple AIO Integrators

*^FIX: Fixed user from being able to open multiple Component Removers

*^FIX: Fixed user from being able to open multiple WIM Registry Editors

*^Improved Win Toolkit startup time!

*^Improved AIO Integrator LDR update integration

*^Added more screen resolutions for logon background tweak

*^Logon Background tweak will automatically new screen resolutions

*^More start menu options in AIO > Tweaks

*^KUC updates now available via Update Catalog

*^Showing Components in Component Remover is faster

P.S. I wish someone said that the loading list part in Component Remover took ages!!!!! I actually thought it had hanged when I first loaded it :P

Link to comment
Share on other sites

For some reason those 6 files get corrupted when they are download :/

UPDATE 1: I think it's McRips Win 7 server (http://hotfix2.cesidian.info), the Win8 server works fine.

UPDATE 2: I've got it working. McRip has been changing his server settings but i've added some code to the download request so his server knows it Win Toolkit download the files.

I can't really be annoyed with him as I definitely appreciate his hard work!

Link to comment
Share on other sites

THANKS I tried b9 and it does download the files but the 2 readme files are deleted on re-scan. I downloaded them directly and placed them in the proper folders and tried again. The toolkit actually didn't show them to be downloaded but deleted them again


Link to comment
Share on other sites

Ran beta 7 last night, everything worked fine for me. Component removals, tweaks, silent installers, the whole nine (mind you, I don't use the McRip updates, just the ones I manually add from WUD). Also loving the new start menu options! Good stuff Legolas. By the way, is it just you working on this project? You're a beast!

And hmmm, wasn't sure where to report this since there doesn't seem to be a sub forum for bugs but, I think there might be something with the Sound Theme component removal. Both times I had it checked off, I got some kind of component installation error when installing windows. Might be worth looking into (happened to me on as well).

Anyway, thanks a lot! Keep it up. This is a remarkable piece of software you have going.

Edited by feet
Link to comment
Share on other sites

yeah it's just me doing the coding, always has been. The correct place to post bugs is just to make a new post in the main Win Toolkit forum.

Is that sound theme removal via All-In-One Integrator or Component Removal tool? What was the error?

UPDATE: v12 released, my battery is going to die in a min too :P

Link to comment
Share on other sites

If you wanted feedback on this, I think that you can let other users enjoy the many improvements you've done so far in the beta, and release a new stable build soon. Maybe tommorow, as i'll also do some more tests and see if everything is ok with the latest beta. And maybe then, after a stable release, other beta-related code refactoring...

Once again, for me it's ok only with the beta channel 99% of the time, I was ''asking'' from the cautious users perspective. :)

Link to comment
Share on other sites

v19 odd behavior on update selection. I actually had to run this with a few different methods to make sense of it. I ran the check it found a single "additionals" update but toolkit had no option buttons to do anything... I decided to put a check in the update and then the download button appeared...

I deleted a few of my other "additionals" I had already downloaded re-ran the toolkit and it showed the updates but no buttons... I checked 1 and the button appeared and stayed visible even if I unchecked the update.

I then deleted some regular updates from my folder and the toolkit showed additional unchecked, recommended checked and the download button was visible.

Not sure if this is by design but thought I should point it out.

And can't resist saying DAMN this work is AWESOME!!!!

I have an image but it's too big to post

Link to comment
Share on other sites

Hi Lego

Tested t31 with an aio x86/x64 image of Win7 SP1 French.

- Host PC: Win7 Sp1 X64 | Core i5 | 8 GB of RAM | 128GB SSD

- Integrated about 90+ Updates for each arch (all in CAB format), AddOns, SFX, and selected some tweaks.

- Two passes: first one for X86 and the second for X64.

X86 images: (Home Premium + Professional, others removed)

- WinToolkit is very slow at loading updates.

- Flagged KB2533552 and KB971033 as incompatible. Is this normal for the second one ?

- Integration time: ~ 20 mins

X64 images: (Home Premium + Professional, others removed)

- WinToolkit is very slow at loading updates.

- Not flagged KB971033 this time (i have removed KB2533552 before running this pass because i knew it won't integrate)

- Integration time: ~ 30 mins

Tested the 32 bits Pro image In VirtualBox 4.2.4:

- Same issue as reported in this thread: WinToolkit Installer is launched at T-13, resulting in some SFX not installed:

- VS runtimes 2005/2008 (2010 got installed, odd as it is from the same sfx)

- Winrar 32 bit, a custom made SFX, is not integrated (Winrar 64 is on the image)

- All updates seems integrated. KB971033 and KB2533552 are proposed on MS Update.

Not tested 64 bits.

Here is the logs files: WinToolkit_beta.zip

Link to comment
Share on other sites

Hi mooms,

the problem for SFX-Installer starting on T-13 is the update KB2592687: it needs an installed KB2574819!

Both updates are together in your .INI






After the integration the Updates are not yet installed, they are marked as "Install pending".

You must put KB2592687 in the tab Silent-Installer-SFX and it will work, as I described in the other thread (Post #23), and it will work; VS Runtimes and WinRAR too!

Regards, Thiersee

Edited by Thiersee
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...