Jump to content

[SOLVED] Can't run Win Toolkit - error "Stopped working"


Recommended Posts


I can't run Win Toolkit on my Win 7 x64. Just have error "Stopped working".


Stopped working

Podpis problemu:

Nazwa zdarzenia problemu: APPCRASH

Application Name: WinToolkit.exe

Application Version:

Application Timestamp: 50803043

Fault Module Name: KERNELBASE.dll

Fault Module Version: 6.1.7601.17932

Fault Module Timestamp: 503285c2

Exception Code: e0434f4d

Exception Offset: 000000000000caed

Wersja systemu operacyjnego: 6.1.7601.

Identyfikator ustawień regionalnych: 1045

I clean my pc from Framework, install Framework 4.5 and still have this problem. Please help. Beta version Win Toolkit also do not works.

Edited by LittleCow
Link to comment
Share on other sites

Well, it says exception code Exception Code e0434f4d can be related to CLR, but afaik, WinToolkit uses .NET Framework 3.5, which is built-in into Windows 7.

MSDN forums http://social.msdn.microsoft.com/Forums/en/netfxsetup/thread/87a83f8a-263c-40ff-b768-e371b0a2125e

and http://blogs.msdn.com/b/astebner/archive/2007/03/26/how-to-repair-the-net-framework-2-0-and-3-0-on-windows-vista.aspx

say the best way to try and repair .NET Framework 3.5 in Windows 7 is to do sfc /scannow

Hope that helps.

Link to comment
Share on other sites

Windows has been installed from iso downloaded from MSDN. Program file is not corrupted - I downloaded it from this page and from mediafire and still do not works. I remember that older versions works in the past... But today is just "Stopped working" error.

Link to comment
Share on other sites

Older than what?

There are probably several of us that have older versions, but...

Which version is the last one that worked for you? For so many of the later versions to be broken for you, and only you it seems, it is probably NOT Win Toolkit, but rather something else on your end, either in the software or OS you are using, or the way you are using them, or something else that is running at the same time, or ...

Cheers and Regards

Link to comment
Share on other sites

Yes I could post an older version, but Lego specifically said he would rather we didn't.

Since June 1, 2012 there have been MANY versions of Win Toolkit released:

There have been 56 official releases. (I have 37 of them - they were sometimes updated so rapidly I couldn't keep up)

And this does not count all the Test releases - I have 21 of them and I know I missed some - nor does it count the 38 versions of the 1.5 series released in the last six weeks - I only have 14 of those, again I couldn't keep up.

And this has all been in the last six months! And only over five months for the 1.4 series since it has not been updated since October 20. And yet I don't remember anyone ever saying that they had the problem you are describing with any of them. If anyone else was having your problem, or Lego agrees that there were any changes that had anything to do with .NET to justify trying an older version, or Lego gives specific authorization for me to make those versions available to you, or you could give a specific date that you know it worked and I could give you a link to a single version that was available at that time, or ...

Bottom line I would feel more comfortable if you could please provide additional info and justification besides "It's not working now and I know a previous version used to work sometime in the past." Also, IF an older version was provided, they all had errors or shortcomings of some kind, or else they wouldn't have been updated, so it might not do you any good besides proving that there is or is not an issue with the later versions that is making itself known for some reason in your system.

Cheers and Regards

EDIT: LOL We cross posted. I'm glad you solved your problem. That it wasn't anything to do with Win Toolkit is only a minor part of the reason I'm glad. :)

I guess when you said:

Other programs that need framework just works :(

those "Other programs" must not have needed .NET 3.5.

EDIT 2: Now that you mentioned this, I think this was something that Lego did change a while back. I believe earlier versions only required .NET 2.0. Perhaps Lego could add a check for .NET 3.5 and display a better error message if it's missing than "Stopped working". I'm sorry it took this long to get resolved, but thank you for bringing it to our attention in case others have this same problem.

Edited by bphlpt
Link to comment
Share on other sites

I'm running v1.50 t38 on dotNet 4.5. Not a sign of dotNet 3.5 on this m/c.

After I said that (net4.5 slim removed all previous versions from the installed (and update) lists) I found a sub folder in C:Windows containing files from v1.0.3705, v1.1.4322, v2.0.50727, v3.0, v3.5 and v4.0.30319 so I'm now not so sure!!!

Link to comment
Share on other sites

@ElmerBeFuddled, .NET 3.5, and earlier, are part of Win 7, not a separate addon or install. Updates, when necessary, should also be included automatically by WU/MU without user intervention. So unless you do something specific yourself they should already be installed and active, I believe. .NET 4.0 is a separate install, and .NET 4.5, if used, should completely replace, or include, 4.0 and only 4.0. Other .NET frameworks will not be affected. As to why you still see the . folder, I haven't researched this so I'm guessing here, but I'm assuming that when 4.5 replaces 4.0 it either (1) continues to update 4.0 like 3.5 continued to update 3.0 and 2.0, or (2) puts hardlinks in the 4.0 folder, actually using the 4.5 files. The reason for doing either of these would be to handle poorly written software that checks for the availability of .NET by looking for specific files in specific folders. Bottom line, as a user, once you install 4.5 you don't have to worry anymore about updates for 4.0, you won't be offered them or see them as installed.

@sp0ilesbrat, AFAIK all mention of any .NET greater than 3.5 regards to Win Toolkit has been by a user, not by the author Legolash2o. If any change is put in place to affect the use of Win Toolkit on XP I'm sure it will be announced and probably discussed in advance.

Cheers and Regards

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...