Jump to content

Getting started extravaganza - Documented


Recommended Posts

Hey guys I figured with as much head bashing as I've done in the past few days I may as well try to document this at the very least for myself and hopefully it will be useful to someone else when they start.  I know that as you learn new things it can sometimes be difficult to remember exactly how your mind looked at things before you understood them so I want to get started before I'm too far disconnected from where I started.  As always I would appreciate advice.



Goals: 1 ) Integrate

                  a ) Windows Updates

                  b ) Drivers

                  c ) Software - Adobe Air, Flash, etc. (McRipSF)

                  d ) Programs/Apps/Games

            2 ) Remove things I don't use, want or need - ideally trimmed as much as possible for me, realistically stability > size and then refine as I go

            ) Basic Tweaks - start menu programs folder organizing, what appears in start menu, taskbar pinned programs, sys tray notifications, taskbar thumbnail preview hover time, assign directories to general libraries such as music, pictures, video etc. 

            ) Cosmetic Customization - Themes, custom theme, Rainmeter, advanced tweaks


This is slightly modified from the first thread I started and I should mention that part of the reason for starting this thread is to not clutter the first with information that is not related and to not bother compstuff's integration thread with my problems.  I will reserve the first few posts so that I can segment these accordingly and just update them so the useful information is easy to find and I'll let the rest of the posts just follow along as I go.


Link to comment
Share on other sites

The Beginning


(The last 2 paragraphs explain about where I am currently and what's still giving me problems - windows install error 0x80070570 and 404 error for hotfix.cesidian.info breaking the Update Catalog)


I'm going to do my best to try to start where I started but I've already started to lose some perspective on that just in a few days!  I've always wanted to do something like this but thought it would take a lot of time and programming skills so I didn't bother but considering when my computer screws up bad it usually ends up needing to be reformatted, I figured I should look into attempting this.  Originally I set out to integrate Windows Updates still thinking that adding anything beyond that was way beyond me.  I eventually ran across a program called RT 7 Lite which I wasted some time attempting to use. Most of my time was wasted by the program telling me to select a valid windows installation even though I had that same file work before. Anyway I won't get into that program much more because it wasn't working for me.  While messing with that program I read about other programs such as vLite and others which were similar to RT 7 Lite.  I also saw mention of the various Microsoft development tools but I didn't pay attention because I thought they were way beyond me, so I kept looking until I found Win Toolkit.


Up to that point the furthest I had gotten was trying to find individual's somewhat updated lists of Windows Updates that used Window's Updater or something like that.  The more up to date list that could be loaded into that program was on a site that I would have had to register for so I just used the less current list from the programs website.  As far as RT 7 Lite went, I eventually made it into the program a few times and thought I had integrated the updates I had download and even tried to slim down the installation but nothing stuck or worked.  This just means that when I got to Win Toolkit I was already familiar with the concept of theoretically having a current list that could be loaded into a program to download all of the updates which would then need to be integrated, probably using another program.  


I registered here and posted to find out if this program could do what I wanted and with my answer I got started.  Initially I downloaded Win Toolkit and checked out some of the tutorials.  At the time it looked like there was a built in Windows Updater called Update Catalog.  I was also referred in my first thread to compstuff's Integration thread which had an alternative to the Update Catalog. While checking that out I let the Update Catalog grab all of the Normal updates but not the Additional ones.  Once it was done I used the All In One Integrator in Win Toolkit and then the ISO Maker. 


I should also mention that somewhere along the way I downloaded and installed VMware Player.  I've never used it or anything like it but I had heard a bit about what it was.  I installed the ISO with integrated updates from the Update Catalog without any installation errors, my only issue was that running Windows Update showed I needed roughly 100 more updates for around 220mb more.  At this point I had read into compstuff's thread, browsed the link he provided to McRip's and Komm's Repositories. Mistakenly I downloaded McRip's McRipSF thinking it was the Windows Updates but figured that out when I looked at the file list.  I then checked out Komm's site and realized that was for the Window's Updates so I downloaded KUC W7 Update Checker


This was a bit confusing for a while because there were all sorts of little things that kept screwing me up.  I opened Komm's page on Getting Started and How to integrate updates into a DVD image. When I loaded KUC for the first time I understood that I needed to create the packages.txt file myself and assumed it would be done through the command prompt.  Since there were two options, one /online and one /offline I had to figure out what that meant and figured out I needed the /offline instruction to work on a copy of the install file and not the one currently running on my computer.  I struggled with getting the different syntax correct but got it figured out using the /? in the command prompt and google.  Eventually I got the packages.txt created after constantly screwing up the /image path being to the directory where the copy of the install.wim was or actually pointing to the file itself.  I also didn't pick up right away that putting >packages.txt was placing that file in the directory I was in under the command prompt


Once that was all sorted out I was able to run KUC. At first I selected everything as far as downloads went but didn't select the options check boxes like Komm had on his Getting started page.  The updates downloaded and the commandlettes were created which I navigated to through the command prompt and ran there instead of clicking on them in Windows Explorer.  


I forgot to mention that part of my problem with getting the packages.txt file to work was figuring out how to mount the install.wim file and figuring out that it needed to be mounted in the first place.


Anyway, it would appear that the updates integrated but when I made an ISO it wouldn't install correctly.  I spent some time trying various combinations and attempting to re-install with no luck.  Then I figured I would create a new packages.txt and check it to see if the updates had really integrated but they hadn't.  I still don't know exactly what would happen because if I screwed up making the packages.txt file, it would create very fast and have some error in the file.  If it worked correctly then the command prompt would take a few seconds to finish and drop back into the directory I was working out of.  


What didn't make sense to me was on the Integrate updates into a DVD page where it says run KUC /dvd-image-dir:c:\offline /up-dir:c:\wu /repo-dir:c:\wu\repo. I tried that in the  command prompt which spit out something about an unrecognized command.  laddnator's post #19 is what got things working as far as actually getting the updates to integrate. It didn't work at first because the program is NOT KUC updatechecker.exe, at least not the one I have; it's KUC W7 updatechecker.exe. If you can't tell, I'm not all that familiar with translating a common sense instruction into what technically needs to be done!  laddnator's post helped because I realized that I needed to put the full file name with extension and had to use quotes to get around the spaces in the name.  For some reason when doing it this way and clicking the commandlettes that were created, the updates actually did integrate.




I still have yet to get a good install though.  I've had bad updates, removed them, had one that wouldn't update so I even added it through DISM manually but KUC wouldn't recognize it.  I think it was KB2750841-x64. I read somewhere that if the install file or ISO is over 4gb it will fail with 0x80070570 which is the error I keep getting. After reading that I figured out how to use imagex to export just the Ultimate volume from my source ISO/extracted ISO files, compress it and cut it back into a copy of my source files which I then ran through KUC which gives me 1 bad update but no remove_old.cmd these past few times.  I'm probably going to try and figure out which one it is and go from there.


The other thing I should mention which I did mention in one of my posts in the other thread or in compstuff's thread was that I get a 404 error when trying to use the Update Catalog through Win Toolkit since yesterday.  I've checked the other computer on the router and it can't access hotfix.cesidian.info either.  I read online that it may be due to multiple connections coming from the same IP which might have been the case with the virtual machine running and the solution was to change the MAC address on the router to give a new IP and get off of the IP Band List as it was put but that didn't work.  I'm not sure if this started when I started using the virtual machine or if it had to do with resetting the router and modem last night because of some strong winds effecting our internet service knocking the connection out frequently.  I've also checked with some of the sites that tell you if a website is down or just having issues for you and they all came back saying it's just me. I can ping the site and I get the site's custom icon on the browser tab but that's it.


Ok that's enough for now.  I know it's a wall of text and I hope to come back later and clean things up and add some useful things in besides just bolding things.

Edited by MeltManBob
Link to comment
Share on other sites

Still attempting to get all updates integrated - KUC bad packages


I'm still working with the exported Windows 7 Ultimate 64 bit image off of the original ISO.  KUC still shows 4 updates as being bad.  When I check the Packages_out log I see these:


-2660075    install pending   Windows6.1-KB2660075-x64.msu          BAD                       A problem occurred ... remove and/or reinstall 2660075

-2660075    Not present        Windows6.1-KB2660075-x64.msu          BAD/IGNORE        A problem occurred .. you can't remove ... try reinstallation of 2660075

-2660075    Not present        Windows6.1-KB2660075-x64.msu          BAD/IGNORE        A problem occurred .. you can't remove ... try reinstallation of 2660075

-2660075    Not present        Windows6.1-KB2660075-x64.msu          BAD/IGNORE        A problem occurred .. you can't remove ... try reinstallation of 2660075

 2615701    install pending    Windows6.1-KB2615701-v2-x64.msu    OK/REMOVE         LDR version available. You can REMOVE this GDR version!

 2615701                               Windows6.1-KB2615701-v2-x64.msu    ADD                      Do not uninstall 2619234 after installation of 2615701; else you will NOT be able to logon in windows again!

 2660075                               Windows6.1-KB2660075-x64.msu         ADD

 2736782                               Windows6.1-KB2736782-v3-x64.msu    ADD


So after looking in the KUC download folder I can find everything except for the last one: 2736782 but luckily it's in the McRip folder I have.  I have now created a third folder and merged copies from both KUC and McRip.


Since KUC's commandlettes don't seem to be able to take care of these after numerous attempts I think it's time to try manually doing this through  DISM.  The plan will be to /commit to the mounted file since I haven't unmounted it while using KUC. Then I will remount it, get the packages.txt, check it for these files to see what is there or not, use the remove-package to get rid of 2660075 and 2615701, use the add-packages to add 2736782 and 2660075 then figure out how to install 2615701 in LDR mode. Once that is done I will unmount with the /commit, remount and pull the  packages.txt again and check.  Hopefully all will look right and I'll run it through KUC again to see if it passes.

Edited by MeltManBob
Link to comment
Share on other sites

Removal Attempts

First try was unsuccessful. Looking here to see about the syntax as I tried using the /remove-package, /packagepath and /packagename:windows6.1-kn2660075-x64.msu. The Microsoft link says take note of the package identity which from looking at the packages.txt is different and shorter than the filename which is what I used for the/packagename.

I should also mention that when I used the/packagename, I got back an error trying to open ... 0x80070057 and error 87. The first error is the same that I get when I've attempted to install windows using and integrated updates ISO.

Just tried it with the package identity of 2660075 as per the Microsoft link but still the same 0x80070057 error.

Looking at c:windows\logs\dism\dism.txt (any pointers appreciated - this is like trying to make sense of a dictionary when you're 2)

Encountered the option "packagename" with value "2660075"
Identity missing version. [hrESULT = 0x80070057 - E_INVALIDARG]
Failed to shred identity: 2660075 [hrESULT = 0x80070057 - E_INVALIDARG]

Basically it looks like it found the package but there was some missing piece of information for the program to specifically target whatever it needs to perform the operation. The package identity column in the packages_out.txt file doesn't show a version but there is a version column. I'm going to look back at the Microsoft link example to see how they meshed the identity and version into the command and try again.

Hurray! I'm a dip**** :)

So instead of trying to piece it together from different things, I just used the package identity from the packages.txt that I got from the /get-packages command. Just copied it verbatim and it worked. This is a good example of showing where my mind started at attempting a solution and my perspective then compared to my perspective after figuring it out. It seems stupid how I was going about it, but only because now I see how it needed to be done. I'll post back again if I run into more issues or when I'm done trying to clean up the bad packages.

packages.txt contained:
Package_3_for_KB2660075_BF~31bf3856ad364e35~amd64~~        Not present
Package_for_KB2660075_BF~31bf3856ad364e35~amd64~~            Not present
Package_for_KB2660075_SP1_BF~31bf3856ad364e35~amd64~~    Not present
Package_for_KB2660075~31bf3856ad364e35~amd64~~                   Install pending

I was able to successfully remove the last 3 through DISM but the first one returned "The specified package is not a valid Windows package error:0x800f0805"

I'm going to get rid of everything produced from KUC last time such as the commandlettes and .txt files, /commit the changes to the mounted image, pull the packages.txt again and run KUC but not the commandlettes, just so I can get the packages_out.txt and see if the bad packages went away. 

It worked, no bad packages. I did forget to add 2736782 which wasn't in my KUC download but was in McRip although there was a new version of KUC and this time it added 3 updates to the KUC download folder and when pointed to the merged folder it still showed 1 download needed.

I ran the commandlettes by right clicking them and running as admin. This fixed KB2615701 which I'm assuming it removed the GDR version and installed the LDR version. It now shows 2 bad packages (2660075 again!), 3 add (2660075, 2695426, 2800213) and 1 OK/Warning (2670838) (not compatible with at least Visio 2010).

I'm going to go back into DISM and remove the PITA 2660075 entries, /commit, add 2660075, 2695426, 2800213, /commit and recheck with KUC.
SCORE AGAIN!!!!!!!!!

I was able to remove the bad packages and added 2800213 but couldn't add 2695426 because it need 2695426-v2 which I didn't have until I re-ran KUC. When I re-ran KUC it downloaded the 2695426-v2 file and outputted the same warning about 2670838 and it needed to add 2660075 and the 2695426-v2. Since I've been having so much trouble with 2660075 and reading in the packages_out.txt that it needed to be the LDR version I looked around for how to do that. I found this thread (#2) which instead of doing what was written through the command prompt or whatever they used I just did it through windows explorer and WinRAR. Then I went into DISM and used the /add-package command and pointed to 2695426-v2 and the update.mum from the extracted 2660075.

Re-ran KUC again after doing the /add-package manually through DISM, it came back with 2 bad packages, both are 2660075. Looking in the packages.txt I see 2 entries for this update, both have the "bf" flag which from what I've gathered indicates it's an LDR package. One is KB2660075_SP1_BF and the other is KB2660075_BF. KUC only showed 1 package to add which is 2660075.  Now I'm starting to get confused.  Anyway I'll try the commandlettes and see if they can handle it, otherwise I'll use DISM.


The problem seems to be with 2660075.  I can get KUC to show no bad files but it needs to install 2660075 and then when it does I get 2 bad packages as mentioned earlier.  At this point I've been able to verify that it just goes back and forth, either everything else is fine but needs that package or as soon as it's installed I get bad packages.

Edited by MeltManBob
Link to comment
Share on other sites

I read somewhere that if the install file or ISO is over 4gb it will fail with 0x80070570 which is the error I keep getting. After reading that I figured out how to use imagex to export just the Ultimate volume from my source ISO/extracted ISO files, compress it and cut it back into a copy of my source files which I then ran through KUC which gives me 1 bad update but no remove_old.cmd these past few times.  I'm probably going to try and figure out which one it is and go from there.


You can try to use a bootorder file.

Read how to here:




Link to comment
Share on other sites



Ok so I've got it down to where I know I'm having problems with just KB2660075 but I'm not sure how to fix it.  I can have everything else good but that needs to install but when I install it, KUC says 2 packages of 2660075 had problems installing.  My point I guess is that it's repeatable for me and isolated but I don't know how to fix it.  I've tried manually adding it through DISM both normally and just the LDR version and each time KUC recognizes them as being bad. 


Maybe that MSU is bad and I need to re-download it? If that's the case then how does DISM say it installed it successfully? I'm not sure, maybe if it is the MSU, maybe that's what's been causing my installation errors.



Ran the commandlettes again. First I did the remove_old to get rid of the "bf" 2660075 packages but once it removed the "bf" one successfully, it couldn't find the SP1_bf.  I pulled the packages.txt file again and verified there were no entries for any 2660075's.  Then I used the copy_files_2_add and the update commandlettes and then checked to see if 2660075 had been added back in since it was one of the packages KUC needed to add but it wasn't there so I went ahead and used DISM to manually /add-package. Pulled the packages.txt again and this time there is only 1 entry for it and not a "bf" version.  


So I run KUC again which thankfully shows no bad packages and just 1 to remove and 1 to add but they are both 2660075!! When looking at the packages_out file it shows this:


2660075  Install Pending Update  3/7/2013 3:39 AM   2660075     Windows6.1-KB2660075-x64.msu   OK/REMOVE   LDR version available. You can REMOVE this GDR version!                                                                                                                                                         
2660075  Update                                                   BF_2660075     Windows6.1-KB2660075-x64.msu         ADD          Update is missing! 
So basically when KUC installs 2660075, I get bad packages but if I install it manually KUC recognizes it as a good package but that I should remove the GDR version and replace it with the LDR version.  When I've done that before I get bad packages!  Geez, this is a damn merry-go-round!! Oh well I'm going to give it a shot.
Edited by MeltManBob
Link to comment
Share on other sites

Confirmed, doesn't matter whether KUC or DISM installs the 2660075 package in LDR mode, it always comes back as a bad package so I will now try to get a fresh copy of it.




Confirmed that it still registers as bad packages even with a fresh download directly from Microsoft.  This is really starting to get on my nerves! The only thing left I can think of is remove the LDR packages since you get both the SP1_BF with the _BF and then reinstall the normal GDR 2660075 which didn't show up as bad, just came up for removal.  


I haven't even moved on to start researching what all the extra check boxes are for in KUC.  I know they correspond to more packages but most are acronyms which I have no idea what they stand for, would be nice to know!  Any help with 2660075 would be great!

Edited by MeltManBob
Link to comment
Share on other sites

Unless you are in the Samoa time zone, why don't you just leave that update out completely, at least for now.  Go ahead and proceed with the next step in your build plan.  You can always just use Windows Update on your running system to add that one update later.  In the meantime, someone else might post a solution for you.


Cheers and Regards

Link to comment
Share on other sites

Not sure what went right but I copied my extracted Windows 7 source folder onto a virtual machine, used Win Toolkit to integrate all of the updates that I got from KUC and then made an ISO using Win Toolkit.  It installed!! Only thing is it's showing 7 important updates for 260mb! Guess it's time to research all the extra check boxes in KUC and download the rest of what I need and get that into a working install to see what Windows Update says I need after that.

Link to comment
Share on other sites

KUC Additions


IE9 - I'm guessing obviously if you have Internet Explorer 9 or plan on installing it


IE10 - see IE9


RSAT - Remote Server Administration Tools - "enables IT administrators to manage roles and features that are installed on remote computers that are running Windows Server 2008 R2 with SP1 or Windows Server 2008 R2 (and, for some roles and features, Windows Server 2008 or Windows Server 2003) from a remote computer that is running Windows 7 or Windows 7 with SP1."


AD LDS - Active Directory Lightweight Directory Services - "...formerly known as Active Directory Application Mode (ADAM) - "provides flexible support for directory-enabled applications, without the dependencies that are required for Active Directory Domain Services (AD DS). AD LDS provides much of the same functionality as AD DS, but it does not require the deployment of domains or domain controllers."


VPC - Virtual PC - "Windows Virtual PC is the latest Microsoft virtualization technology. You can use it to run more than one operating system at the same time on one computer."


WIF Windows Identity Foundation - "...is a new extension to the Microsoft .NET Framework that makes it easy for developers to enable advanced identity capabilities in the .NET Framework applications."


WUA - Windows Update Agent - "A component originally introduced in the Windows 2000 Server SP3 operating system that enables a computer to operate as a client of an update server."




SystemReadiness - "The System Update Readiness Tool can help fix problems that might prevent Windows updates and service packs from installing."


WinHelp - "...is a Help program that has been included with Microsoft Windows versions starting with the Microsoft Windows 3.1 operating system. However, the Windows Help program has not had a major update for many releases and no longer meets Microsoft's standards. Therefore, starting with the release of Windows Vista and continuing in Windows 7, the Windows Help program will not ship as a feature of Windows."


Fmapi File Management API - "provides a way for developers to discover and restore deleted files from unencrypted volumes. FMAPI also provides the ability to use a password or recovery key file for the discovery and recovery of deleted files from Bitlocker encrypted volumes. Recovery of files from other types of encrypted volumes is not supported by FMAPI.  Note  FMAPI can only be used in the Windows Preinstallation Environment (WinPE) for Windows Vista, Windows Server 2008, and later. Applications that use FMAPI must license WinPE."


MSAgent - "Microsoft Agent is deprecated as of Windows 7, and may be unavailable in subsequent versions of Windows. Microsoft Agent is a set of software services that supports interactive characters within the Microsoft Windows display. Some examples of the Microsoft Agent characters are the Office Assistants. The characters included Clipit (the paper clip), The Dot (a shape-shifting and color-shifting smiley-faced red ball), Hoverbot (a robot), and The Genius (a caricature of Albert Einstein). The characters would interact with users by offering help with tasks currently being performed."


NTBackup - "The utility restores backups that are made on Windows XP and on Windows Server 2003 to computers that are running Windows 7 and Windows Server 2008 R2."


BrowserChoice - "You can use the Browser Choice update to select and install the web browser you want to use on your PC. Microsoft is providing the Browser Choice update to comply with a legal settlement with the European Commission. Microsoft is required to inform customers who currently use Internet Explorer as their default browser that there are other web browser choices available."


WindowsActivation Windows Activation Technologies helps you confirm that the copy of Windows 7 that is running on your computer is genuine. Additionally, Windows Activation Technologies helps protect against the risks of counterfeit software. Windows Activation Technologies in Windows 7 consists of activation and validation components that contain anti-piracy features.


ClientBPA  FCS Best Practices Analyzer Tool - "...is designed for administrators who want to determine the overall health of their Forefront computers and to diagnose current problems. The tool scans the configuration settings of the computer and reports issues that do not conform to the recommended best practices."


Management Framework - "Windows Management Framework 3.0 makes some updated management functionality available for installation on Windows 7 SP1, Windows Server 2008 R2 SP1, and Windows Server 2008 SP2. Windows Management Framework 3.0 contains Windows PowerShell 3.0, Windows Management Instrumentation (WMI), Windows Remote Management (WinRM), Management OData IIS Extension, and the Server Manager CIM Provider."


disable AMD CorePark. - "...enables the hotfix installer to selectively disable the Core Parking feature in Windows 7 or in Windows Server 2008 R2 if an AMD FX, AMD Opteron 4200 Series, or AMD Opteron 6200 Series processor is installed. Currently, the CPU Power Policies that are used by Windows 7 and Windows Server 2008 R2 are not optimized for the dual core AMD Bulldozer module architecture. This architecture is found on AMD FX series, AMD Opteron 4200 Series, and AMD Opteron 6200 Series processors. This can result in decreased system performance with multithreaded workloads in lightly-threaded environments."


Direct Access 2.0 - "...remote users can access corporate file shares, Web sites, and applications without connecting to a virtual private network ( VPN), as shown in Windows 7 DirectAccess User Experience. Further, DirectAccess separates intranet traffic from Internet traffic." "...can be used by computers running Windows 7 when connecting to internal corporate networks with DirectAccess in Windows Server 2012. It improves the DirectAccess connection experience, supports one-time password (OTP) authentication for DirectAccess users and helps organizations reduce the cost of supporting DirectAccess users."


RDP 8.0Remote Desktop Protocol 8.0 - "update that enables you to use the new Remote Desktop Services features. These features were introduced in Windows 8 and Windows Server 2012 R2. These features are now available for computers that are running Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 Service Pack 1 (SP1)."

Edited by MeltManBob
Link to comment
Share on other sites

KUC Feature Packages


IIS - Internet Information Services - formerly called Internet Information Server – is a web server software application and set of feature extension modules created by Microsoft for use with Microsoft Windows.[2] IIS 7.5 supports HTTPHTTPSFTPFTPSSMTP and NNTP. It is an integral part of the Windows Server family of products (and their client counterparts in the cases of Windows NT 4.0 andWindows 2000), as well as certain editions of Windows XPWindows Vista and Windows 7. IIS is not turned on by default when Windows is installed. The IIS Manager is accessed through the Microsoft Management Console or Administrative Tools in the Control Panel. IIS is the third most popular web server in the world.


MSMQMessage Queuing (MSMQ) technology enables applications running at different times to communicate across heterogeneous networks and systems that may be temporarily offline. Applications send messages to queues and read messages from queues.


NFS Microsoft® Services for Network File System (NFS) provides a file sharing solution for enterprises that have a mixed Windows and UNIX environment. With Microsoft Services for NFS, you can transfer files between computers running Microsoft Windows Server™ 2003 R2 and UNIX operating systems using the NFS protocol.


SNMP Simple Network Management Protocol (SNMP) is a popular protocol for network management. It is used for collecting information from, and configuring, network devices, such as servers, printers, hubs, switches, and routers on an Internet Protocol (IP) network.


SUA Subsystem for UNIX-based Applications (SUA), the evolution of the Interix subsystem that formerly shipped with Windows Services for UNIX 3.5, is a multi-user UNIX environment that operates on computers running Windows server-class operating systems. SUA and its accompanying utilities provide you with an environment that resembles UNIX-based operating systems. It also includes case-sensitive file names, job control, compilation tools, and the use of over 300 UNIX commands, utilities, and shell scripts. Because SUA is designed to run atop the Windows kernel, it offers true UNIX-based functionality without any emulation.


Media The N edition and the KN edition of the Windows 7 operating system do not include Windows Media Player or other Windows Media-related technologies, such as Windows Media Center and Windows DVD Maker. Therefore, you must install a separate media player in order to do any of the following


GroupP - is a feature of the Microsoft Windows NT family of operating systems that control the working environment of user accounts and computer accounts. Group Policy provides the centralized management and configuration of operating systems, applications, and users' settings in an Active Directory environment.


VMdriver The Virtual Machine Network Driver allows the Device emulator's OS (or even the Virtual PC OS, as the case may be) to emulate its own network connection. Because the physical network interface on the host machine is now "virtualized," you have a way to get two IP Addresses - one for the host PC, and one for the operating system that is running within the Device Emulator (or Virtual PC). Device Emulator users using the VMNet Driver can connect to the host machine over TCP or UDP as the alternative to the standard "Activesync over DMA" solution.


Cluster - 


Hyper-V - 


remoteFX - 


Embed - 


Driver - 


No Cat. - 

Edited by MeltManBob
Link to comment
Share on other sites

  • 10 months later...

So I had to replace this hand-me-down computer I graciously received from a friend, which could actually play games newer than Morrowind but had always acted weird attempting to hibernate/sleep. Which later mysteriously restarted every 4-24 with 8hr being the average. Then believing myself not knowledgable enough to detect a rootkit left over from the coolest infection from a piece of Russia-ware I ever saw (I really wanted that torrent lol), I  decided to kill two birds with one stone and do a rebuild of windows. But during that process I was too lazy to unplug my storage drive, and even tho I was like nah I won't choose the wrong drive after IDing the two, I f*n did it anyways and deleted the wrong partition. So I quickly went into BIOS but got sidetracked by setting InitDisplay option to peg mode and then she just refused to display anything at alll via hdmi/vga/dvi through onboard gfx but had no way to switch back. (known issue with rev 2.2 of said motherboard, but no resolution after clearing cmos via jumper or battery). So I bought a mobo+cpu combo along with an SSD this Jan and dropped it in my old tower along with pre-existing hardware. And it was Amazing. But Raid-0 by way of 2nd SSD would be more amazing (1'st re-install), then to restore a .net cluster-f* I just couldn't cope with (3rd install), and again after shaw cable had an outage in my building coincidentally the same night I was loading custom firmware to my router (wanted internet, try anything, so fourth install); its around this time I figure there must be a better way,

SP1 integration and the Microsoft Windows Update packages burnt to a dvdr/ or USB using my copy of windows 7 x64 certainly

couldn't be that difficult.... or ultimately time-consuming as it's been. I wanted to do a fresh install of win7 again with just the raid driver and chipset driver pre-loaded and was going to attempt making autoattend start file but some days of reading passed, and my list of wants grew, to include things like additional hotfixes and addons. Around this same time I became familiar with

an app called Windows Update Downloader (MSFN) and later updated .UL user-submitted files. I then found the digitalriver site and X17-59465.iso, more dead-ends, and a growing need to understand how to create the magic that would be a fully unattended

updated and modified windows 7-build. Because as an end-user who doesn't know about jargon like slipstreamed or VMware but tinkers where they naught belong, system failure is inevitable.. Somewhere along the line I managed to fix the complete mess of my last reinstall (only one that wasn't a fresh install - I lost my hive im not the user I should be or privileges were messed and still are, things don't install or uninstall and group policy was wonky), enough to the point where I actually get .net framework 4 to re-install via win update and windows to allow installs again and thus win toolkit. But then I've entered the period of doing very little, things get hairy, I didn't plan on reading so much and so after spending time on MSFN and other forums just. Reading. STUFF - dozens of little tabs launching per row for every launched-in-new-window off-site links I'm now here, at Wincert reading your posts about your first-time foray into the realm of what must-be to sys admins boring, and mundane routine. Like how I find preparing food at work.. meh. But those other staffers who I'm paired with during rushes, light up in delight making tzatziki and using the commercial lemon-wedger lol. It's going to give me some damn fine satisfaction and a major release of dopamine when I finally get this.


Basically I just wanted to say Thanks for documenting your process, it's much appreciated. I don't get very long at any time to read up on this stuff so it will definitely save me time when I do. Cheers, and much obliged! 

*and to Lego and wincert and its posters :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...