Jump to content

Remove WoW64


Recommended Posts

Hi everyone, this is my firt post in this great community.



My question is simple (or maybe not): It's possible to remove the WoW64 subsystem from Windows 7 x64 using Win Toolkit or any other tool? Google says to me that this is possible on Windows 2008 server, but nothing about Windows 7 x64. So: Anyone knows about this option?
Many thxs in advance.


Link to comment
Share on other sites

And by "all of the 32bit programs" that includes 32bit versions of runtimes, browsers, etc that all exist and are required for normal operation even if you are running a 64bit version of an OS.  Definitely not a very good idea.


Cheers and Regards

Link to comment
Share on other sites

yes, i know that all x86 programs rely on WoW64, but my idea is to completely remove the support of 32 bits programs under Windows 7. If all the programs that i need are x64: ¿Is possible to remove WoW64?
I say again: I don't need run 32 bits programs. I try to build a very specific distro of Windows 7 that only support x64 programs.


Link to comment
Share on other sites

I understand your question, but I don't know if it is possible, or if it would then function without error.  I also do not know of any tool that is able to help you to do this.  In your Google searches that said that it is possible to do this on Windows 2008 Server, how did they say that it was done?  I guess you could try the same process on Windows 7, since it is very similar to 2008.  Let us know what you find out.


Cheers and Regards

Link to comment
Share on other sites

You do realize that most 64 programs still rely on the 32bit subsystem?


I.E. Java, most browsers, most av's


This same issue came up when nlite started being able to remove the 16bit subsystem....


There are at best a dozen or so truly 64bit only programs (Ones that have NO 32bit files or dependencies.)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By eveafterdark
      Hello everyone,
      I was just wondering if anybody came across the problem I had today using wintoolkit and ADK 8.1 Preview.
      I have an x64 VAIO which runs Win7 SP1 x64 Ultimate, a pretty fresh install, nothing except for IE10, office 2013, 7 zip + a few required updates/hotfixes.
      Today I installed ADK 8.1 Preview which features the new DISM 6.3.9431.0. Installing netframework 4.5 (also a preview) was required to install ADK.
      I  installed  WinToolkit and tried to do some customizing on a win7 sp1 x64 ultimate (digital river disc).
      I mounted install.wim using cmd (by the way, very fast with amd64 dism)  and then went on to WinToolkit's  component remover. The component remover finds the already mounted image and after pressing "select" it tries to load  it. And here's where the problem is:
      Normally the whole process of getting the list of packages takes 3-4 minutes but here it started with "checking if the wim is mounted" (the message on the bar). This lasted around 20 minutes, meantime it gave me an error ("The exception unknown software exception 0x40000015 occurred in the application at location 0xfe94aa8e"). Some other time the application just didn't respond and crashed and generally during this process of "checking if the wim is mounted" I was unable to even open an explorer window.
      Anyway, this time after "checking if the wim is mounted" it went on to "getting/unhidding packages", all that stuff. It lasted another 15 minutes and finally got me the list.
      The list, however, consisted only of few things: themes, remove winsxs, remove upgrade folder, that stuff, no other packages listed.
      I have no idea why the component remover does "checking if the wim is mounted", and why it all takes so long and then the list is missing all the packages.
      If I mount the image directly via WinToolkit something like this never happens. Also, when I mount the image with e.g. gImageX and then go to Wintoolkit to process the image, everything is fine.
      I used to do a lot of mounting directly in Wintoolkit as well as mounting the image with command line and the go to wintoolkit. Never have had such a  problem before, though I used WAIK at that time.
      By the way, when I use the ADK 8.1 dism commandline, it works fine, it's fast. All the get-packages/features, mounting, anything I tried was OK.
      I don't know which version of dism is being used by Wintoolkit or wether it matters at all.
      Any idea what the problem may be? is it possible that the new dism is different or mounts the image in a different way? maybe it is the 4.5 framework?
  • Create New...