Jump to content
BusyElf

wintoolkit tweak "open cmd here" x64 possible redirection failure

Recommended Posts

I have run into problem : On my w7 x64 ultimate "Open CMD Here" folder shell-extension fails to recognize system32 folder (used for 64 bit console programs). I have integrated 64-bit version of nircmd (by NirSoft).

 

When starting cmd from start menu > run, it finds nircmd.exe, but when starting from shell-extension, it fails.

One that works, shows in title

"Administrator : Command Prompt"

and one that fails has in it's title

"Administrator: C:\Windows\system32\cmd.exe"

1. If this si a bug, please correct it in WinToolkit update

2. how can i fix this issue on currently installed modded windows ?

 

It's kind of funny that command prompt started from 64-bit folder fails to find other 64-bit commands/utilities  :g:

Share this post


Link to post
Share on other sites

I found what was cause of problem, i was using cmd shell extension supplied by WinToolkit tweak from Total Commander 32bit version.

 

Problem is that i would like to use TC 64bit but there a quite a few plugins i would miss.

 

TC uses internally TCMDX64.EXE to gain access to shell extensions for 64bit processes, and there are no menu items for starting command prompt.

 

I found a possible workaround using "C:\Windows\Sysnative" alias (or for more universal approach) "%SYSTEMROOT%\Sysnative" file system redirector.

 

Hm this is supposed to be a fault at TC's side (though, when looked at registry everything looks OK).

 

I hope anyone looking at this will drop a PM/mail  to Ghisler about this issue.

 

 

 

Does it make sense to work around this issue by creating shell extensions that explicitly call 32 and 64 bit versions of cmd ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By hkroiss
      Hi, since around 1.5 half years i am integrating Updates into our Windows Image at our Company. However i have noticed that even when all the latest Updates are integrated after installing the OS it shows a few ".NET Framework" Updates that couldn't be integrated (see Attachment). A year ago it were only around 10, now around 15. So its getting more and more, it hinders the usfulness of the Slipstreaming process a bit.
      Did anyone of you find a way to integrate this pesky ".NET" Updates into the Image?
      Thanks for the help.

    • By f483755
      ...since the home server(?) at http://testing.wintoolkit.co.uk/ is down, or acting weird, quite often. And it again. And it appears that no one else mirrors your 0.56MB application anywhere, ever. Currently, all your links are broken, and I've been hunting all over the internet for the last three hours for a way to find it. In fact, this is a big enough issue that the fourth of four Google results for "2.0.5860.25216.7z" is a pretty damn convincing, and extremely nasty malware trap: http://solari.victus-rpg.com/showthread.php?tid=84314 . I just spent the last 45 minutes wrestling control of my computer back from that beast. The only other v2.x one can find on the internet is at http://www.datafilehost.com/d/2b73ce8b, which was uploaded in another wincert.net thread a few months back when a similar thing was happening, but it is the older 2.0.5651.42757, which no longer runs due to a built-in expiration date.
      So, yeah. A mirror would be good; and in the mean time, anyone have a copy of 2.0.5860.25216.7z laying around?
      Thanks, your friend,
      Geoff (or, I guess, "f483755" today)
      Sunday 17th January 2011 2:18pm
    • By MorcCrafak
      Hello again :).
      I saw if i select All-in-One Disk Creator and i select any .wim file it shows me dialog with this:
      can someone help me? Thanks.
    • By Psy-Virus
      Hey there,
      I've just registered, because I haven't found an answer to the following question:
       
      If I integrate updates to an install.wim. with WinToolkit, do I really have to do it for all images "separately" ?
       
      Or can I only integrate them to the "Ultimate" image?
       
      I mean, the files that are used by the setup from the install.wim are the same for every version (home, home prem, usw...) aren't they?
       
      BTW: It's really an awesome tool!
       
      THX
      &
      Greetings
       
      Psy-Virus
    • By Kormann
      Hello guys,
       
      Do you know if I import a registry file through Tweaks if this is going to be added to all users?
       
      I'm building a Windows 7 SP1 Customized Image.
       
      I know for sure if I do it manually through the WIM Reg editor that its possible.
      If this was possible through the Tweaks section at AIO Integrator, instead of doing my tweaks everytime through the WIM Reg Editor I would just need load my tweaks preset.
       
      The code that I want to add:

       
      Windows Registry Editor Version 5.00; Add Network Connections to Network context menu[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\shell][HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\shell\Network Connections]@="@%SystemRoot%\\system32\\netshell.dll,-1200"[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\shell\Network Connections\command]@="rundll32.exe shell32.dll,Control_RunDLL ncpa.cpl,,0"Thanks in advance.
×
×
  • Create New...