Jump to content

Wintoolkit - Windows 8.1 Update Intregation


Recommended Posts

Hello everyone.


Pleasure to meet you all :)

I have this problem, basically I try to integrate drivers into Windows 8.1 Update 1 Pro Image and it takes ages (12 hours) to complete it.


Below are the image I'm using, My current OS etc.


SHA-1 of image: 89B63C548A3F6E34FF9098084247FAB7B6D2124D
Image name: en-gb_windows_8.1_professional_vl_with_update_x64_dvd_4050386.iso

System Spec:
Intel Core i5 4670 @ 3.4GHz
16GB 1600MHz RAM
2x120GB SSD in RAID0
MSI Z87-G43 Motherboard.


Windows 7 x64 


I use a custom DISM from Windows ADK.


I have also tried to integrate the drivers manually using DISM and it also takes so long. Why?



Thanks for help!

Link to comment
Share on other sites

Maybe. I'll just add a couple of things: DISM I use is located at: C:\Program Files (x86)\Windows Kits\8.0\Assessment and Deployment Kit\Deployment Tools\amd64\DISM\dism.exe


I have just done integration of drivers into a Windows 7 64bit ISO and it only took it 32 minutes!


Is there some compatibility issue here or Windows 8.1 just gives a problem for some unknown reason :P





I have also experimented with Priority settings in Wintoolkit options. The higher I put it on the Windows 7 image the faster it completed the work (minute or two earlier each step) but it does the opposite thing for Windows 8.1 image. The higher it goes the slower it works. 

Edited by Bartek Kolodziejczyk
Link to comment
Share on other sites


Amazing stuff! - It worked.


Looks like the outdated DISM has problem with newer images. 


Legolash, if you read this post, any way you could address this issue?

Link to comment
Share on other sites

I guess, similar to how Win Toolkit checks for any AV running upon launch, it could find the latest version of DISM installed and then offer to DL the latest version the host OS can support if there is a later version available?  I don't know if that is possible or not, and that assumes that the latest version is just as capable as the Win7 version when used for building Win7 builds.


Cheers and Regards

Link to comment
Share on other sites

I don't think that will work
it's similar to if you try to use Dism from another system in second partition:

Error: 0x80090006An error occurred. DISM could not be initialized in the local folder.Ensure that DISM is installed correctly and that all of the binaries are present
Link to comment
Share on other sites

But you might could copy DISM from the mounted image to the host system and run it from there, even if you copied it to a temporary location that you later deleted?  But I don't know if simply copying it would work compared to having it officially installed.


Cheers and Regards

Link to comment
Share on other sites



As we are talking about speed, i do have a dism.exe in my x64 directory its a bit smaller.. but would it be faster as default wintoolkit picks the 32bit version.

Downloading updates again as we speak, for vista though as wintoolkit works perfect for slipstreaming vista, vlite i have to do each mount seperate wintoolkit does not.


So will see if it will speed up the progress..


Btw i am so stupid.. my iso has sp2 included so what did i do ?

Well.. the updates included sp1 and sp2 of course they failed, and where added to silent install messing up my build :P

Only just noticed now..


So going to retry building without those 2 files :P.

Btw if i disabled auto add to silent install the iso worked but missed a few updates so.. not a big problem just about 50 compared so how many it needed before..


Though wintoolkit does not support the language files to cab, but there is a seperate tool for that.



Found another problem why my mounting etc became slow..

Seems my 1tb hdd is up for replacement.. when downloading updates sudden corruption..

After running a quick repair update downloading went fast and correct. so need to buy a new one :P.

Edited by ThuGie
Link to comment
Share on other sites

Wouldn't you be able to use the latest dism.exe for all the previous images?


Like for Windows XP/Vista Legolash has made a download available for Dism, you could possibly include one to the latest release.



All of the actual 64-bit files are located in the System32 folder. SysWOW64 contains 32-bit libraries for compability for emulation of 32-bit programs. At least what I think it is.

Link to comment
Share on other sites

I don't think thats the case,

Cause i recall it showing dism.exe *32

And right now it is not doing so.


Though for some reason it is using C:\Windows\WinSxS\amd64_microsoft-windows-d..ervicing-management_31bf3856ad364e35_6.3.9600.17031_none_4f9af566e17dbc2c

Really not sure why as i assigned a different directory to wintoolkit.


Still busy intergrating language packs. for some reason language packs take ages!

And i do not see any speed improvement at the least.


cpu = 0% over all 8 cores. and hdd is 100% of course not my ssd.. so for me it seems my hdd is the limiting factor :(.

Memory = 34% over all 8gb (full system usage not wintoolkit nor dism)

But i think it would be a shame to do this on my ssd..



Before i forget,

I have only tried this on Vista and Windows 7, windows 8 i do not have, i do have 8.1 32/64

But have not yet tried, for XP i don't think it would work.


Edit.. Well thats odd language intergration into vista 32 bit worked fine, sp2 btw.

But for 64bit sp2 as well it will fail. pretty much instant and add them to silent install.

Edited by ThuGie
Link to comment
Share on other sites

  • 4 weeks later...

Can I slipstream already downloaded Update 1 files (KB2919442, KB2919355, KB2932046, KB2937592, KB2938439, KB2934018) into the Windows 8.1 Enterprise x64 ISO using Win Toolkit v1.4.43?


Does Win Toolkit v1.4.43 requires WADK and will download separately?


Is it portable or need to be installed in the system before use?

Link to comment
Share on other sites

So I will not need WADK if I'm using Windows 8.1 Enterprise x64. However, I will need to download all updates again to slipstream into the ISO, and the standalone installation of all updates downloaded from Microsoft Download Centre cannot be used with Win Toolkit v1.4.43.


I have downloaded "Win Toolkit v1.4.43.1" and did not get the portable edition of the program.

Edited by Khandelia
Link to comment
Share on other sites

I slipstreamed windows 8.1 Core,Pro last week.

I simply downloaded the language packs i wanted did those first, installed the iso on virtualbox,

Then i used windowspatchloader to download all current updates, i slipstreamed those, installed the new iso.

Repeated this until i had 3 packs of updates. only had 2 updates left defender and other protection file.

Then i made i a .esd file took ages 100% cpu and 100% ram lol..


I also got windows 7 to use .esd saves ton of space :P.

Link to comment
Share on other sites

  • 2 weeks later...


I'm glad to find the portable edition of Win Toolkit and have used for the first time to Integrate Windows 8.1 Update 1 into the Windows 8.1 Enterprise x64 ISO.

I don't know whether or not the program saves Presets file into the Boot.Wim and Install.Wim as well as saves into the folder where ISO has extracted and "C:\WinToolkit\Last Sessions", which doesn't make a sense to save it into the ISO extracted folder or in WIM.

Therefore, please consider to avoid integration of this file into the Windows through WinToolkit.


Edited by Khandelia
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...