Jump to content

[Solved] Runonce Installer Bug (Restart installation after finishing)


wela
 Share

Recommended Posts

I used 1.4.4.2 to build install source with win7 pro.
AiO went fine, build iso too.
Installing in VM no Problems, till reaching the runonce installation. There is a strange
behavior finishing the installation.
Last file is 947821-v33.
After finishing these installation a little message window appear with a status bar and the
runonce installer restart the Installation.
I canceld and the system boot into desktop.
Wu no Probelms, all Files seems correct installed.
Attached session.ini.

Test_14_42.zip

Link to comment
Share on other sites

  • Replies 62
  • Created
  • Last Reply

Top Posters In This Topic

 

Did you want it to restart?

No. Why should i want it? It is not necessary.

 

Update:

I just finished a installation based on v14389. All fine.

Edited by wela
Link to comment
Share on other sites

  • 1 month later...

Hi

Used 14.44.3. Same issue as above described. After finishing all silent installer (the last is kb947821-v33) message windows shown shortly like "scanning for files", "scanning folders", "removing duplikates" and after that the Runonce installer start again installing all silent installer files.

 

Again, with 14.38.9 no Problem.

 

Is there a Runonce.log? Found it - attached. Also attached Runonce log from 1.4.38.9 installation.

 

 

Wintoolkit_runonce_log.rar

WTK_runonce_log_v14389.rar

Edited by wela
Link to comment
Share on other sites

Hi Lego

 

Thanks for fixing.

 

I am sorry but the Runonce installer give me a  message I don´t understand. Cause i do nothing (See Pic_1).

After clicking "ja" (yes) the second message appears (see Pic_2). It says "That Runonce did not function in right order. Close the Program."

After clicking "Close Program" the system starts to desktop.

 

All Files installed. Sys is running well.

 

Runonce.log/config attached.

 

WTK_Runonce_Error_Pic_Log.rar

Link to comment
Share on other sites

1.4.45.1

 

:-( WinToolkit installed the files,

but after the Installation he bring a error! :-(

 

Pic1: without Keyboard input

Pic2: when I press yes from Pic1

 

Windows 7 x64 + x86, Windows SBS2011, Windows Server 2008R2, Windows 8.1U1, Windows Server 2012R2 U1 testet!!!

Edited by Cartman586
Link to comment
Share on other sites

Hi Lego,

 

last version I tested was 1.4.44.Test3, all was OK.

Today I tested 1.4.44.4 (NOT B!) and I got the same error like in post #9 (wela) and #11, #12 & #17 (Cartman586).

I tried now (just finished) 1.4.45.2: it seems the error has gone.

To the error it appears after the last silent-installer has finished; the only difference I noticed is: in 1.4.44.T3 (working) the RunOnce can be in background or not,

since 1.4.44.4 is only and always on top; is it OK?

 

Would be possible to get it again in background?

 

For all test: allways same ISO with same patches, same silent installers, same preset.

 

Thiersee

Link to comment
Share on other sites

Yeah I will set it in the background. At the moment i'm just trying to re-produce the bug as it's working fine for me when I run it normally.

 

If anyone wants to upload the image where the problem is happening, that would make it easier for me :D

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share




×
×
  • Create New...