Jump to content

Next Release Expectations + Important Information


Legolash2o
 Share

Recommended Posts

As you may have noticed. I have been working on v1.x this week and I've dedicated more time during next week too. Here is what to expect and the list may grow but my time is limited. Since there will be quite a few enhancements. I might as well call it v1.5.x :)

Please note: The latest test build is not available yet. The % shown is the completion progress of that specified item.
 

NOTICE: PLEASE READ

After the v1.5.x release. No more features will be added to Win Toolkit v1.x unless they are very very small or someone pays me to do it. All focus will then be on v2.x as my University degree and therefore my future depends on it. So I will only be willing to work on v1.x bug fixes. Sorry.

 

RELEASE PLAN

 

Sunday 7th :: Preperation [100%]

Monday 8th - Wednesday 10th :: Improving Existing Features [100%]

Existing features will be improved to make future changes and bug fixes easier. 

Thursday 11th - Saturday 20th :: New Features [70%]

I will attempt to go through the requests form and add features which I think I have time for.

 

Note: This period has been extended since the previous task took longer than expected.

 

Sunday 21st :: Public v1.5.x release

If all goes well. The general public will see a new version prompt.

 

NEW FEATURES AND IMPROVEMENTS

 

Unattended Creator [100%]

I've updated the GUI of the Unattended Creator and it now uses the new inputbox (below). The icon next to each item indicates where it is text input, select from a list, or just enabled/disabled, etc..

 

post-10183-0-34308800-1410383864_thumb.p

 

Unattended Creator- Serial Keys [100%]
The screen which prompts you to enter a serial key for your unattended setup has been improved greatly.
post-10183-0-30637600-1410383865_thumb.p

 

InputBox Upgrade [100%]

All the inputbox prompts which asked you to enter text have been updated and work a heck of a lot better. This gives me lots of new options. 

 

Old

vba_input_box.jpg

 

New

post-10183-0-24777700-1410383863_thumb.p

 

Silent Installers [100%]

  • A new button is available which lets you select a common program from a list. Once selected, its switch will automatically be added.
  • I've added a toggle on the Silent Installers + SFX tab which controls whether or not the current installers get deleted or not.

Updates [100%]
Update logging is now enabled by default and now has a timestamp on the filename. I've also fixed an issue where the log doesn't have an extension.

Driver extraction [100%]
I've decided to restore the way drivers files ending with an underscore (_) get extracted. There was issues where drivers, such as graphics drivers, could not get integrated. The old method works. It will now only use the new method (7z) if its not recognized. Hopefully this will improve driver integration by reduce the errors.

 

WIM image system upgrade [100%]

I've finally got round to finally upgrading how Win Toolkit store images in the memory but most importantly makes it so much easier for me to code. Previously Win Toolkit used to store a bunch of ListViewItem's in a list so if you looked at a wim image it would look like.:

ListViewItem.Text = Image NameListViewItem.SubItems[1].Text = Image Description....ListViewItem.SubItems[6].Text = WIM file location....ListViewItem.SubItems[10].Text = ????

Point is if I need to fix something or do anything at all relating to images. I had to find out which subitem stored the wim file location (6) or what subitem stored the DisplayName. This was originally done years ago before I knew how to make custom objects. Now it is like:

selectedImage.NameselectedImage.DescriptionselectedImage.LocationselectedImage.MountPathselectedImage.DisplayNameselectedImage.Index

As you can probably tell. This makes thing A LOT easier for me in the long run. I also discovered a few bugs which I managed to fix. Just implementing this alone took 2 full days which is why there was not a release last night.

 

NOTE: This may have introduced some bugs. Although they would be easy to fix.

 

Temp Directory [30%]
Tomorrow I will be going through every existence of how the temp directory works and will be completely revamping it. 

 

UPDATE: Win Toolkit now keeps track of all the temp files and folders it creates and the process being ran. To help me manage this I decided to create a new screen which shows you.

 

Note: It is nowhere near finished. It can only be accessed by me at the moment as it is buggy. Threading issue.

 

post-10183-0-71620600-1410383550_thumb.p

 

 

Win Toolkit Cleanup [0%]
On Win Toolkit exit. A new screen will appear displaying the cleanup progress. This will be much better than the current method which just says it in the title bar. This will allow you to see where it struggles and where it gets stuck.

 

USER REQUESTS

MSP Extraction [100%] 
I will be adding the request which allows a you to select what language you need to be extracted.

ISO Maker [100%]
The ISO Maker has had a re-design which includes being able to select a custom date. I've just got a few suggestions to take care of and then that is done.
 

BUG FIXES

Error Logs [10%]
I will be going through a lot of error logs. Fixing as many things as possible.

Bug Reports [10%]
I will be going through as many bug reports on the forum. So please post as many bugs as possible and update your current bug reports with any new news.

 

CHANGELOG

NEW: Add common application switches
NEW: Replace unattended serial key box
NEW: ISO Maker customize date options
FIX: Unattended password value stayed
FIX: Internet Explorer did not always move to the top

FIX: Fixed default theme settings on themepack integration

FIX: Mini dumps tweaks
FIX: MSI files did not always get installed in RunOnce
FIX: CAB files did not always get installed in RunOnce
FIX: Restore old method of driver extraction
FIX: install.ini will no longer write if < 10KB is available.
Added RunOnce idle timeout option 
WIM Manager > Set Product Key now uses new key screen
Revamped WIM image handling
MSP support for RunOnce
Improved Unattended Creator GUI
Added more silent installer common programs
Updated sample install.ini
Option to keep mount folder after image has been dismounted
Edited by Legolash2o
Link to comment
Share on other sites

Hi Lego,

 

I just tested 1.5.0.7 on a VM x64:

 

1) In the ISO-Maker I would prefer if the box to show the CMD-Windows is checked as default.

2) Why AdobeReader disappeared from the Silent-Switches-List?

3) For .MSP-files no switches are added (Adobe Reader patches are MSP-files, /passive /norestart  works).

4) What does it mean the option "Delete old installers"? Where are they deleted from?

5) Silent-Switches-List: it would be better to have the switches liste as here (post #3) (my opinion!)

 

6) New switch: CDBurnerXP: /NOCANDY /VERYSILENT /SUPPRESSMSGBOXES /NORESTART /SP-

 

Thiersee

Link to comment
Share on other sites

Hi Lego,

 

I just tested 1.5.0.7 on a VM x64:

 

1) In the ISO-Maker I would prefer if the box to show the CMD-Windows is checked as default.

2) Why AdobeReader disappeared from the Silent-Switches-List?

3) For .MSP-files no switches are added (Adobe Reader patches are MSP-files, /passive /norestart  works).

4) What does it mean the option "Delete old installers"? Where are they deleted from?

5) Silent-Switches-List: it would be better to have the switches liste as here (post #3) (my opinion!)

 

6) New switch: CDBurnerXP: /NOCANDY /VERYSILENT /SUPPRESSMSGBOXES /NORESTART /SP-

 

Thiersee

 

1) Done.

2) I didn't add it. I was given two different switches and wanted to see the difference. I've now added it.

3) Done.

4) I've improved the description. Basically it will delete the WinToolkit_Apps folder and the registry settings for the RunOnce. It will make the install as if no silent installers are present.

5) Done.

6) Added.

Link to comment
Share on other sites

Ok, so you have time to proof another issue ;).

 

RunOnce seems to have problems with .MSP-Installers (in my case for AdobeReader);

it has been installed, anyway I should see some install boxes (/passive): nothing and in comparison with a manual installation, with the same switches, to quick.

And at the end skype did not install (exe-installer); I'll try now with the Skype-MSI.

 

Thiersee

 

Edit:

 

I'm back and can confirm .MSP-patch-installer is causing the problem.

I put the AdobeReader-Patch at the end of the RunOnce-List and saw, RunOnce was not waiting for the installation-end;

windows-setup was already building-up the desktop, .MSP-Patch-Installer was still installing.

 

setup.ini:

#Silent Installs


dotNetFx452_Full_LDR_x86_x64intl_Slim::/y /sfxlang:1031;NO;81,01 MB;E:\ServicePacks-Install\Win_7\Windows_7_Toolkit\Ricktendo\dotNetFx452_Full_LDR_x86_x64intl_Slim.exe;Always Installed
msxml_4_SP3::/passive /norestart;NO;2,25 MB;E:\ServicePacks-Install\Win_7\Updates-September\msxml_4_SP3.msi;Always Installed
msxml4-KB2758694-deu_x64::/quiet /norestart;NO;1,98 MB;E:\ServicePacks-Install\Win_7\Updates-September\msxml4-KB2758694-deu_x64.exe;Always Installed
PaintDotNet_x64::/passive /norestart;NO;25,69 MB;E:\Allgemein CD2\Grafik-Photo-Video\PaintDotNetMsi_4.0.3\PaintDotNet_x64.msi;Always Installed
ClassicShellSetup64_4_1_0::/passive /norestart;NO;4,52 MB;E:\ServicePacks-Install\Win_7\ClassicShell\ClassicShellSetup64_4_1_0.msi;Always Installed
AdbeRdr11007_de_DE::/sPB /rs;NO;71,67 MB;E:\Allgemein CD3\Adobe-PDF\AdbeRdr11007_de_DE.exe;Always Installed
cdbxp_setup_4.5.4.5000_x64::/NOCANDY /VERYSILENT /SUPPRESSMSGBOXES /NORESTART /SP-;NO;5,64 MB;E:\Allgemein CD1\CD\CD-Record\cdbxp_setup_4.5.4.5000_x64.exe;Always Installed
SkypeSetup_6.20.0.104::INSTALLLEVEL=10 STARTSKYPE=FALSE ALLUSERS=1 TRANSFORMS=:RemoveStartup.mst /qr;NO;25,68 MB;E:\Allgemein CD5\Telefon\I-Net-Telefon\SkypeSetup_6.20.0.104.msi;Always Installed
AdbeRdrSecUpd11008::/passive /norestart;NO;2,31 MB;E:\Allgemein CD3\Adobe-PDF\AdbeRdrSecUpd11008.msp;Always Installed

Edited by Thiersee
Link to comment
Share on other sites

 

Does MSP use msiexec?

 

Apparantly, you can do this:

 

 

msiexec /i A:\Example.msi PATCH=msipatch.msp;msipatch2.msp /qb

 

Yes, I integrate it normally with a RAR-SFX and this setup

 

msiexec /p AdbeRdrSecUpd11008.msp REINSTALL=ALL REINSTALLMODE=omus /qn

 

With this RAR-SFX instead of example.msi /passive /norestart no issue.

Link to comment
Share on other sites

I will be adding the request which allows a you to select what language you need to be extracted.

 

I will be adding the request which allows a you to select what languageS you need to be extracted. - Please :)

Means you have 2 selector and the extractor filter for 2 languages at the same progress.

 

Driver extraction [100%]

 

Means that the request from here?:

http://www.wincert.net/forum/topic/12525-driver-installer-backuper/

Edited by BrokenZer0
Link to comment
Share on other sites

v1.5.0.8 has been released. I'm currently updating the first post to say what's been added/updated.

 

UPDATE: v1.5.0.9 released

No it says what it is in the description. All the user requests in the first post have a link to the post itself :)

Link to comment
Share on other sites

lego:

just used ver1.5.0.10 unattended

maybe it's me but I still cant can't my theme to default

and the user password is still enabled. that's with full name field blank and a name in the autologon name field. it makes the name an admin but its password protected. so if I do an install for a client and his computer sleeps, when awoken it needs a password. that should be eliminated..

thx

ron

Link to comment
Share on other sites

lego, I love TV's..

I just did a small test with v1510. no updates tweaks etc. I just added an office 2010 silent and the NFW 4.5.3 silent with new unattended.

now the default theme worked. remember it hasn't been working in my final updated tweaked installations.

and the unattended I got to work like this for no password. I leave both name fields blank (unchecked) but in the autologin name's user tab I add a username and display name (no passwords) and use administrator as default. doing it this way there is no password...ahh another 3 hrs of my life!

regards..

Link to comment
Share on other sites

Hi Lego,

 

1.5.0.9 & 1.5.0.10 does NOT integrate any updates (ALL with a black X)!

 

1.5.0.7 does it with no issues; exactly same .INI.

 

Thiersee

Thanks Thiersee. I knew there might have been some issues. They probably wont be hard to fix but the long term benefits of what I did easily outweigh the possible bugs.

 

I will fix it ASAP! (but after breakfast) :P

 

EDIT: Fixed the updates. Just checking tweaks.

EDIT 2: Tweaks seem fine :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...