Jump to content

[Solved] WinToolkitRunOnce.exe will not start


jigsaw5063
 Share

Recommended Posts

Hi
 
I have a problem with WinToolkitRunOnce.exe and that just will not start.
I do not want on my DVD folder 'WinToolkit_Apps', I want the folder 'Software' or similar.
WinToolkitRunOnce.exe start only if the folder 'WinToolkit_Apps'
If on the %DVD% not available Wintoolkit_Apps folder  then nothing is found post-25200-0-49455300-1413598562_thumb.p

I tried to edit the registry but without success, RunOnce will not start

[HKEY_LOCAL_MACHINE\SOFTWARE\WinToolkit]"00000|ChromeSetupX64"="%DVD%:\Software\ChromeSetupX64\ChromeSetupX64.exe*"

I also tried to set the file 'install.ini' but does not work, just will not run runonce

#Any line starting with a # are comments and will be ignored.

#Lets you specify the configuration of the installers
#InstallDir is where your apps are located.
#DriverDir is which directories to scan for inf files.
#Reboot makes RunOnce reboot Windows after completion.

#NOTE: INSTALLDIR will ALWAYS check the following directories even if not specified in the config section:
#INSTALLDIR=Sources\WinToolkit_Apps
#INSTALLDIR=WinToolkit_Apps


[Config]
INSTALLDIR=%DVD%:\Software
DRIVERDIR=Sources\Drivers

#Here are some other samples.
#INSTALLDIR=E:\Software
#DRIVERDIR=X:\MyDriverCollection

REBOOT=FALSE

#Things which will always get installed. Anything after * is a switch i.e. /S /Q /Silent
[Automatic]
#KBXXXXXX-x64=%DVD%:\WinToolkit_Apps\Windows6.1-KBXXXXXX-x64\Windows6.1-KBXXXXXX-x64.msu
#User will be asked to choose which of the following apps to install.

[Manual]
Google Chromex64=%DVD%:\Software\ChromeSetupX64\ChromeSetupX64.exe*

#Microsoft Office 2013=%DVD%:\WinToolkit_Apps\Office2013\Setup.exe*/configure %DVD%:\WinToolkit_Apps\Office2013\config.xml
#Example 1=%DVD%:\WinToolkit_Apps\ExampleProgram\Example.exe*/s


DVD 

post-25200-0-92203300-1413573290_thumb.p



one my WinToolkit_RunOnce_Log.log

Version: 1.5.2.9


18.10.2014 3:58:31 Description:
-----------------STARTING--------------



18.10.2014 3:58:31 Description: IsSystem: False
IsAdministrator: True
User: JIGSAW\dfd

18.10.2014 3:58:31 Description: Creating Shutdown Handle.

18.10.2014 3:58:31 Description: Loading...

18.10.2014 3:58:31 Description: Detecting Drives

18.10.2014 3:58:31 Description:
DRIVE SCAN
------------------------------

Drive: C:\, Media Type: Fixed, Size: 33283895296, Free: 19588681728, Name: , Initial: True
Drive: D:\, Media Type: Fixed, Size: 20847783936, Free: 6113918976, Name: , Initial: True
Drive: E:\, Media Type: Fixed, Size: 21731733504, Free: 21298372608, Name: Nova jedinica, Initial: True
------------------------------

18.10.2014 3:58:31 Description: Detecting Paths

18.10.2014 3:58:31 Description: Detecting Sources

18.10.2014 3:58:32 Description: INI Found: D:\sources\install.ini

18.10.2014 3:58:32 Description: Install Location Found: Setup D:\Software

18.10.2014 3:58:32 Description: ERROR INI P1: Google ChromexS
P2: %DVD%:\Software\ChromeSetupX64\ChromeSetupX64.exe
P3:

18.10.2014 3:58:32 Description: Detecting Drivers

18.10.2014 3:58:32 Description: x64: True

18.10.2014 3:58:32 Description: Removing Duplicates.

18.10.2014 3:58:32 Description: No Installations.

18.10.2014 3:58:42 Description: Starting

18.10.2014 3:58:42 Description: Manual: 0 | Driver: 0 | Auto: 0

18.10.2014 3:58:42 Description: InstallPaths: 1

18.10.2014 3:58:42 Description: Deleting dpinst.exe

18.10.2014 3:58:42 Description: Removing Shutdown Handle.


And to mention WinToolkit RunOnce.exe will not delete itself.
 

Heelp!
Thanks!

Edited by jigsaw5063
Link to comment
Share on other sites

When you say the folder was marked as hidden. Did you have it so all the files are marked as hidden too?

 

I accidentally left the code which tells it to delete itself commented. Just fixed that now.

 

EDIT: I've noticed you've put:

%DVD%:\Software\ChromeSetupX64\ChromeSetupX64.exe

It should be

%DVD%\Software\ChromeSetupX64\ChromeSetupX64.exe

WinToolkit should still work with that though. But worth trying.

Link to comment
Share on other sites

When you say the folder was marked as hidden. Did you have it so all the files are marked as hidden too?

 

I accidentally left the code which tells it to delete itself commented. Just fixed that now.

 

EDIT: I've noticed you've put:

%DVD%:\Software\ChromeSetupX64\ChromeSetupX64.exe

It should be

%DVD%\Software\ChromeSetupX64\ChromeSetupX64.exe

WinToolkit should still work with that though. But worth trying.

No, it not working, working only if on DVD  WinToolkit_Apps folder.

Why WinToolkitRunOnce.exe can't be itself deleted  after closing ?

Link to comment
Share on other sites

Oops I just noticed you have

%DVD%\Software\ChromeSetupX64\ChromeSetupX64.exe

Since you have specified D:\Software. it would become D:\Software\Software\.... so it needs to be

%DVD%\ChromeSetupX64\ChromeSetupX64.exe

 

 

Why WinToolkitRunOnce.exe can't be itself deleted  after closing ?

I forget to un-comment the line of code which told it to delete itself. The fix is in the latest version.

Link to comment
Share on other sites

  • 6 years later...
  • 3 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...