Jump to content

Default TimeZone


DougSchuess
 Share

Recommended Posts

Is there a way to set the sefault TimeZone with WTK?  I am thinking putting something like the following in SilentInstaller (RunOnce) via a command file that has been converted to an SFX::

 

DISM /image:<MountName> /Set-TimeZone:<TimeZoneName>

 

If my idea seems feasible, what MountName should be used?

DISM documentation says that any value contained in HKLM\Software\Microsoft\Windows NT\CurrentVersion\TimeZone can be used in <TimeZoneName>.

Link to comment
Share on other sites

Do it with Autounattend.xml and place it in the root of your Windows DVD. Example for German :

 

 

 

<?xml version="1.0" encoding="utf-8"?>
<!--Created by Win Toolkit v1.4.0.75-->
<unattend xmlns="urn:schemas-microsoft-com:unattend">
    
    <settings pass="windowsPE">
        <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State"xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <SetupUILanguage>
                <UILanguage>de-DE</UILanguage>
            </SetupUILanguage>
                <InputLocale>0407:00000407</InputLocale>
                <UserLocale>de-DE</UserLocale>
                <UILanguage>de-DE</UILanguage>
                <SystemLocale>de-DE</SystemLocale>
        </component>
      
        <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State"xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <SetupUILanguage>
                <UILanguage>de-DE</UILanguage>
            </SetupUILanguage>
                <InputLocale>0407:00000407</InputLocale>
                <UserLocale>de-DE</UserLocale>
                <UILanguage>de-DE</UILanguage>
                <SystemLocale>de-DE</SystemLocale>
        </component>
        </settings>
</unattend>
Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...