Jump to content

multiboot win 7/8.1/10 on one large usb stick


Chrysalis
 Share

Recommended Posts

Ok so I am not wanting to do a AIO image for one version of windows.

 

What I am trying to do is this on one usb stick.

 

Windows 7 Custom iso - success

Windows 8.1 Retail iso but no key needed to install (activate upgrade retail key post install) - fail

Windows 8.1 Enterprise iso, useful for 90 day evaluation use, automatic activation - fail

Windows 10 tech preview 9926 build iso - fail

Macrium reflect recovery iso - success

MEMtest86+ iso - success

 

Ok so I used yumi.

 

I did windows 7 using the installer options, so all the win7 files are on root of the stick also, this boots fine. For the other iso's the only way to add them without overwriting windows 7 is to add them as unlisted iso's, when booting I successfully load the installer fine, but they all bomb out after saying they cannot access a key file. I assume they trying to get the file from the root of the usb stick. I think is unattended, serial key or something like that. Macrium and memtest86+ load fine also. Is it possible to have different windows installers on one usb stick, if so how? Yumi gives different methods.

1 - windows installer method, this can only be used once, as repeated use will overwrite files as it tries to put in the root of the memory stick.

2 - unlisted iso via syslinux, this extracts the iso like the windows installer method, but into its own folder so no overwrite, so far so good right? except at the end of the process it gets an error and deletes the files to undo.

3 - unlisted iso via grub (what I did) this copies the iso to a folder on the usb stick and adds a grub menu entry to boot from it.

Edited by Chrysalis
Link to comment
Share on other sites

Ok so I did it again using easy2boot.

 

Works much better.

 

I can boot linux also.

 

Win7/8.1 retail/10 all boot.

 

Win 8.1 enterprise however throws up this error.

 

"windows cannot find the microsoft software license terms"

 

I used exfat tho as one of the iso's is over 4 gig, and I assumed since they all modern operating system's exfat be fine.

 

Is the error due to exfat?

 

The 8.1 enterprise iso is unmodified, no customisations to it, and I am testing on a real pc not VM, it has quad core intel with 16 gig of ram.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...