Jump to content

Help with "windows could not configure one or more system components" error, logs attached


Recommended Posts

Hi All,


I've been playing around with Win Toolkit for the last few days and keep hitting the same brick wall - I keep getting the error "windows could not configure one or more system components" after install.


I am using a windows 7 SP1 All Versions (including both x86 and x64 architectures all-in-one) as the source (which has been working fine to install all versions of Windows 7 over the last few years and has been very convenient to have all versions on one usb, just inconvenient to have hundreds of updates after a clean install!). I used the inbuilt updater to download and integrate all updates (select source, select all x86, integrate all updates, add dotnet4.5 addon, integrate some silent installs, repeat process for x64, rebuild iso and use usbprep to install on usb). I have so far made 7 different images excluding certain updates along the way, each taking about 4 hours to complete.


Strange thing is that if I try to install in a VM, I get through to choosing a username and the other setup options then it appears to 'hang' at the Win Toolkit additional programs installer which I'm not too worried about, I can remove the integrated apps that install at this stage and try again. Whenever I use the same source to install on a laptop though, it appears to be installing ok, reboots, comes back to the last stage of the install screen and gives me the "windows could not configure one or more system components" error. This problem happens with each Win Toolkit source I try . Going back to my original Win 7 SP1 All Versions USB installs ok though.


I then thought perhaps there was a problem with the All Versions install and tried to download an image from the links in Win Toolkit but get an error that the product key is not valid using the one supplied and if I try to use the product key from my laptop I get the error that Windows was preinstalled and can't be downloaded.


So, here are my questions:


1) IS it possible to create an "all-in-one" Windows 7 SP1 x86 & x64 USB using Win Toolkit?

2) Looking at the attached error logs from the laptop, is anyone able to point me in the right direction to fix my issue?




Thanks in advance!

Link to comment
Share on other sites

Thanks for the replies.


It appears to me the problem is with your .Net 4 install. (ngen service can not start).


I would try creating your image without .Net 4 included.  If that installs ok you know that is your problem.


Hope this helps in some way.




I used the .net 4.5 addon so I will try to recreate the installer without it. If I download all updates with the included update downloader, will dot net be included in the updates? Should I look up the KB's related to dot net and exclude them perhaps?


Did you create the a-i-o image yourself?


Can you guarantee the validity of your source?


I have been using the a-i-o for a few years now and quite honestly can't remember if I created it myself or was given an image from another technician, but it has worked flawlessly to install many machines over the years without issue.

Link to comment
Share on other sites

OK, so after a lengthy process of elimination, I seem to have gotten past the error during installation (I only integrated the updates in 'General', 'Hotfix' and 'Security', no additional optional updates and also removed dot net as an addon and am attempting to add it as a silent installer).


I have another question now though.... Is it possible to 'edit' or 'remove' Silent Installers after they have been integrated? After getting the updates integrated I added about 6 'Silent Installs' to my image. It appears that a switch on the 3rd or 4th installer may be incorrect and causes an error with this install, followed by a reboot and continuation to desktop skipping the remaining installers. I was hoping to 'edit' my silent installers to avoid having to rebuild my entire x86 and x64 images again (takes approx 4 hours for each!). If not, is there a .ini file or similar in the install directory where I can edit the switches?


Thanks in advance again!!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By abbodi1406
      The .NET Framework is a popular development platform for building apps for Windows, Windows Store, Windows Phone, Windows Server, and Windows Azure. The .NET Framework platform includes the C# and Visual Basic programming languages, the common language runtime, and an extensive class library. read more.
      Info: The .NET package will be slipstreamed as pre-installed
      OS: Windows 7 SP1
      - The addon will conflict with some Windows Updates (.NET 3.5 Family), so leave the addon's integration to the last.
      - Add main addon first before LangPack addon, to get ASP.NET service localization properly.
      - To function properly, .NET 4.7.x require D3DCompiler_47.dll component, which is found in either the current "Monthly Quality Rollup" or "update KB4019990". It is recommended to integrate it first, or you can install it later.
      .NET 4.8:
      .NET 4.7.2:
      Languages Codes Reference:
    • By mooms
      For international readers, here is an english thread: (you must be logged to MDL to see it).
      Cet Update Pack constitué d'un seul fichier, il permet de mettre à jour une installation "live" ou de faire une intégration dans une image wim de Windows 7 SP1 ou Server 2008 R2 , à la manière de WinToolkit, que ce soit en x86 ou en x64.
      La télémétrie est désactivée , et un patch pour installer les KB sur les CPU récents (Kaby Lake et + et Ryzen) est inclus.
      Exemple, avec cette commande, le pack va intégrer toutes les màj + IE11 localisé (détection de la langue automatique ) dans tous les index de l'image wim, puis optimiser cette dernière:
      UpdatePack7R2.exe /ie11 /Optimize /WimFile=C:\Win7AIO\sources\install.wim /Index=* Avec celle-ci, le pack va installer passivement les màj + IE11 localisé sur le système, puis redémarrer
      UpdatePack7R2.exe /ie11 /silent /reboot Il est possible de renommer le pack pour automatiser certaines actions:
      Un fil en anglais sur MDL qui en parle, avec liens de téléchargement et exemples:
      Page officielle avec liens de téléchargement (en Russe):
      Ce fichier téléchargera automatiquement la version la plus récente: https://update7.simplix.info/UpdatePack7R2.exe
    • By Tanzil Habib
      Hello, sir, today is September 1, 2020, 11:14 a.m. in Bangladesh. So I am trying to download Windows 7 ISO file, but when I click to download, It shows an error page where headline says "This program cannot display the webpage". I have added screenshots.
      My internet connection is fine but it's not working! Please give me a solution for that!
      Screenshot links in my Google drive:
      1. After selection: https://drive.google.com/file/d/1aChxjI8ugKA7XcU5_nxEabdBzRLUO3B0/view?usp=sharing
      2. The downloading page: https://drive.google.com/file/d/1zi4A-v9vBr1r0MT_fG6K4PrzUTyQKbej/view?usp=sharing
      3. The error: https://drive.google.com/file/d/1QMOmQ8A2leol1DeCy9Gvow6OPyeuWR4X/view?usp=sharing

    • By linkservis
      WinToolkit ver.
      Host/PC OS: Windows 10 (64-bit) v1909
      OS that is being modified: Windows 7 (32-bit) Ultimate
      I keep trying to integrate IE11 into this system but no luck, it bugs and shows the error like in attachment.
      I tried doing same on x64 version of W7Ultimate and it goes with no problem, configuration and updates are same (only 64bit version)

    • By Jhonny Silva
      "This file is currently unavailable. Please check again later."
  • Create New...