Jump to content

XP/W2k3 x86 on Modern Hardware

George King

Recommended Posts



#6644 Gelip ⇗ @diderius6
I just tested debugging with WinXP SP2 32-bit on other laptop IdeaPad S10e and working 🙂 I edited the second location of F8 03 in the kdcom.dll file offset C50. kdcom.dll EN is exactly same on WinXP SP2 and SP3 regardless of the language version of the system. The card in this laptop has a different I/O address than in the X220, so you need to put the same in the kdcom.dll file.


It is enough to change the I/O address COM1 3F8 in the kdcom.dll 64-bit 5.2.3790.1830 file in offset 1024 by changing F8 03 to the address of our card (I have 00 40)


I just change at 3 places in your nice NTLDR_dbg

3F8h ---> D010h

And Waaaooh,
my Startech Serial PCI-e card works with Windbg,
COM in Bios disabled, oh so much fun )

EDIT: This at 3 places modded ntldr_dbg build from XP SP1 Sources works also on my Startech Serial PCI-e card
for large NTFS harddisks with 2048 Sectors preceding partition 1 .


Edited by Dietmar
Link to comment
Share on other sites

3 hours ago, infuscomus said:


Yeah, ACPI errors are tough to fix, we usually just jump over the error in the driver, have you tried any of the 5048 versions to see if they work any better?

I'm curious, why that ADSL modem card?

Old sound/graphics cards I get since they're useful for retro games, but a modem?

I have tried all available versions of the acpi.sys driver on my board and only the two v6666 mentioned above work. All the others, including the 5048 versions, give the classic A5 BSOD.

Anyway, considering the many difficulties to install on this mobo an operating system different from the one imposed by the factory (and under very specific conditions), I think it is already a great achievement to be able to have a working XP even if not at 100% of the possibilities we were used to until now. Always a big thank to the wonderful work of genius guys.

If then also on this crazy board I could have a fully working USB3 function, it would be the best :)

About the modem, I simply need to set a single location with internet access on demand and not always on.

Link to comment
Share on other sites

Full acpi XP SP3 on Biostar z690A board with 12900k cpu.

Still a lot of problems but it can be done^^



EDIT: Only install of XP SP3 to nvme and run from nvme works nice until now.

No USB, no Sata but works Serial Mouse(!), PS/2 keyboard, sound, 3D graphic, Internet via TPLink card, Moorhuhn;))..

Geekbench2  is 28446  for the 12900k

compared to      19000  for the 8700k, means 50% faster

under XP SP3, running on nvme, here Plextor with freeldr from Reactos.


EDIT2: ALL USB2, 3, 3.1, 3.2 work with the original win8 USB driver, transported from @Mov AX, 0xDEAD 

from 5 May 2020, niccce:))).

This USB driver is without any Extender.



Edited by Dietmar
Link to comment
Share on other sites

2 hours ago, Dietmar said:

EDIT2: ALL USB2, 3, 3.1, 3.2 work with the original win8 USB driver, transported from @Mov AX, 0xDEAD 

from 5 May 2020, niccce:))).

This USB driver is without any Extender.


Hi Dietmar,
which acpi.sys are you using? Here also the USB driver from 5 May 2020 installs correctly but on reboot my B560 system hangs on the XP logo screen with the sliding bar stuck.
Can you also please confirm that USB driver from 5 May 2020 contains the following files?

UCX01000.SYS        340064116B210ADF78239F1C171A69A07325C601
usbd_w8.sys            6B26C1252D7CC00E9B6E4C46EE773DB03DEF4B90
USBHUB3.SYS         7EA99282C304A13889B092EEB9F295CE1B681094
USBXHCI.inf             8AA3652EA655E14EDFCC047B4A780CD9A428760C
USBXHCI.SYS          C6D35C456E5B011603FAE67472BF1A4AACF61B42
WDF01_W8.SYS     18D4788BBF520E0C2F3EF95CBDD26F03FE519670
WdfLdr8.sys             921913D31D9199D574D6FB77D077133002A1AFF9
WppRecorder.sys    AB0369D23C2A03A7C7D1769713770B3415761637

Edited by Andalu
Link to comment
Share on other sites

With the storport driver from Kai Schtrom I succeed to see the harddisks from nvme bootdevice. But when I make a one by one copy from the nvme boot device to the Sata disk,

compi tells at boot from the Sata disk:

"Missing MBR-helper."

This message I have never seen before. And it is so strange, because on this board

are 2 different Sata ports: One from Intel and one from Asmedia,

both give me this crazy message



EDIT: I solved this problem "Missing MBR-helper."

I forget, that I use freeldr via grub4dos on the Plextor nvme device. And the correction was easy: Just via RMPrepUSB I connect the harddisk via USB box and type there "install grub4dos". Now I can boot on the Biostar z690A board with the storport driver from Kai on any Sata connector.


EDIT: Crazy day, but now I have everything to run under XP.

All is on the Biostar z690A itself , only no network under XP.

For this I installed a small TP link card.

It is stable. Another advantage of this board is: You have 2 Bios chips, between you can switch. During SPI I was not able to read out the whole Bios chip, I think because of some crazy protection, as long as the Bios chip Winbond 25Q257JVEQ is soldered on the board.

It gives during read out via EEpromer Revelprog IS only 00000 everywhere. So I updated Bios chip 1 to newest Bios and the old Bios stays on Bios chip 2. The old Bios is more stable than the new one.

Edited by Dietmar
Link to comment
Share on other sites



The files are almost the same. Only USBXHCI.inf is different while in your package there are the files "USBXHCI.inOrif" and "USBXHCIUSBboot.iNixxnf" which I don't know what they are :)

The boot works now by disabling the XHCI Hand-off option in bios. Tomorrow I will try all my USB3 devices.

Good night ;)

Link to comment
Share on other sites


I tried the USB3 driver v6.2.9200.22099 (backported from Win8) with usbhub3.sys dated 23 June 2020. UAS devices are installed via the same driver and their proper USB speed is now correctly listed in USB Device Tree Viewer software.

The performance detected by CrystalDiskMark for USB3.2 Gen.2 and Gen.2x2 mass storage devices is also as expected (and better than what is achieved with the USB3.X xHCI driver v2.2).

No issues detected so far.

Edited by Andalu
Link to comment
Share on other sites

5 hours ago, Dietmar said:

The timertest still shows negativ values after few sec on the Biostar z690A board.

This means, that the timer problem still exists on Alderlake, brrr..

and needs halplusintelppm hack


PS: With this files the timerproblem is gone


Do you have same mod for x64 too?

Here are latest untouched x64 hal + intellppm



Link to comment
Share on other sites



I'm sure that with your skill you'll be able to overcome the forcing that Gigabyte has started to introduce in its bios.

I didn't have a good experience with the Gigabyte B560M-D3H bios. So much so that, exhausted by the headaches it gave me, I decided to return it when suddendly, after a normal restart, it didn't boot up anymore and get stuck on the gigabyte home screen. The boot no longer worked also with Win10. The CMOS clear didn't help.

I downgraded the bios from version F6 to F5 and booting worked on Win10 but it was not possible to keep the CSM on enabled which was automatically put on disabled at each reboot, so XP still did not work. Updating the bios to the latest version F7 would have meant no longer being able to downgrade, with unpredictable consequences for the XP installation.

I'm still wondering how it was possible that a working motherboard, regularly turned off in the evening, the next morning gives no sign of life when the power button is pressed. This time the CMOS clear helped (I have never performed so many CMOS clears as with this board).

I'm going to start staying away from Gigabyte motherboards (and I'm writing from a GA-H470 that works like a charm).

Edited by Andalu
Link to comment
Share on other sites

Here it is,

XP SP3 on the Gigabyte z690 ud ddr4 board with 12900k cpu.

Stable, PS/2 mouse and PS/2 keyboard work together at the PS/2 connector,

nice, stable, cheap.

Much more stable than the Biostar z690 board,

and cost only half😛.

But only last Bios F6 works for CSM and XP.

And no CD Rom as boot device is recogniced.

I tested this on 2 different boards, with all Bios versions,

with changing settings in Bios, with Plop, with grub4dos.

With another CD Rom drive, test all Sata ports.

Plop tells, no Int13 device can be found.

So the people from Gigabyte just kick out CD Rom as a boot device. Later you can see the CD Rom drive in XP, but not for boot.

Any Bios for this board is a nightmare.

But the board is rock stable under XP SP3 and no Timer problem,

because the board uses from itself its hardware timer




Edited by Dietmar
Link to comment
Share on other sites

On 2/4/2022 at 5:39 AM, Dietmar said:

Looks, like Gigabyte enables full CSM support on this board

Gigabyte Z690 UD DDR4 (rev. 1.0)

with Bios F5.

"Add Legacy Game Compatibility Mode option"

I will test this board with 12900k cpu in next days for XP SP3 boot



Sorry to ask such a basic question.
How do you distinguish between "full CSM support" and "not full CSM support"?

Link to comment
Share on other sites

Just now I am installing XP SP3 on an Asrock z690 Extreme board

with Intel 12900k cpu and 32 Gbyte ram.

Until now, this is the best and most stable board for XP,



PS: I noticed a strange behavior of the Firefox or Basilisk browser

on all z690 boards. Firefox always crashes when closed.

This does not happen in Safe Mode F8. After some tests I noticed,

that is connected with the Nvidia Graphikdriver. No crash without Nvidia. Even I updated the Bios, this behavior stays.

I think it has to do, how the Firefox browser managed memory.

So it comes in conflict with the Nvidia driver.

With Internet Explorer or Chrome Browser all is ok.

PS: This is via USB3 boot.




Edited by Dietmar
Link to comment
Share on other sites


thanks for your tests on the boards with chipset Z690.

I have two requests:
- is there a possibility to install XP on a motherboard that has no PS/2 port? How to get past text mode setup?

- could you please upload somewhere the PEMaker 0.82 tool, because from the link http://blog.livedoor.jp/blackwingcat/archives/1313117.html I always get the Bad GateWay error?

Thanks ;)


P.S.: the Update Mini Tool is the one from MDL?

Edited by Andalu
Link to comment
Share on other sites


Here ist the PEMaker082 tool


And yes, the Minitool is from MDL.

When you use the Ramsey XP SP3,

you only have to set "Live USB". Then you have at once USB mouse and keyboard.

Other way is, to use an XP that has already USB from an other compi with generic Sata driver from Kai Schtrom or @Mov AX, 0xDEAD


PS: And 3. (hard) way is to make use of an unattended install of XP via WINNT.SIF

for example




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...