Jump to content

I am looking for a PCIe card for WinXP debugging


Gelip
 Share

Recommended Posts

@Gelip

I did step by step exact what you wrote.

Does not work.

On second boot step of XP there is no connection to the PCIe slotcard on the Asrock z370 k6 board, no matter which (now I have 5 different cards) you use for this

Dietmar

PS: Sundos shows D000 & COM1

and an extra test confirm this with

debug

-d 40:0 confirms Com port on COM1 with 00 D0.

ย 

Link to comment
Share on other sites

@Dietmar

12 hours ago, Dietmar said:

On second boot step of XP there is no connection to the PCIe

What second boot? If you want to use the RS232 PCIe card under DOS you cannot restart the computer! The BIOS cannot configure the COM port on the PCIe card by itself. You have to do it manually by inserting the I/O address into memory, e.g. with debug -e 40:0 xx xx

Edited by Gelip
Link to comment
Share on other sites

@Gelip

I just notice, that normal serial Windbg does not work on new motherboards with z690 chipset: Not on the Biostar z690A and also not on the Gigabyte z690 ud ddr4 .

Crazy, because they have onboard serial COM and sundos shows COM1 port at 3f8h on both of them

Dietmar

Edited by Dietmar
Link to comment
Share on other sites

2 hours ago, Dietmar said:

Crazy, because they have onboard serial COM and sundos shows COM1 port at 3f8h on both of them

This is not crazy. If there are COM ports on the motherboard and they are enabled in the bios, sundos.exe detects these ports:

sundos_onboard.png.47b996e64b1006f9eedf56cc22e5de72.png

Link to comment
Share on other sites

@Dietmar

I have good news. So far, I have tested the SER5427A card with WinDbg + modified kdcom.dll in legacy bios only. Today I decided to check under UEFI (CSM disabled) and it does not work.

I noticed an important thing when the card driver is not installed in Windows. In UEFI mode, the lspci utility under WinXP shows that the I/O ports are disabled, while in legacy bios they are enabled:

legacy_bios.png.2128ce4d8ecc47cb845d4f433f0e4248.png

uefi_mode.png.47421d6e9429841ddaea2795639a1ea5.png

For WinDbg to run under UEFI, you need to enable ports under UEFI Shell and run WinXP without restarting from UEFI Shell:

mm 03000004 1 -pci
efi\boot\bootx64.efi

Maybe your motherboards disable I/O ports in legacy bios mode?

Check in WinXP with lspci that the I/O ports are enabled. If they are disabled, enable them in MS-DOS with the setpci utility and run WinXP with GRUB4DOS without restarting the computer:

setpci -s xx:xx.x command=1
grub.exe

Edited by Gelip
Link to comment
Share on other sites

@Gelip

My pic looks exact like your first, where you write, that Windbg works.

But does not work on Asrock z370 k6.

I set in boot.ini /baudrate=14400

in Windbg 115200

and I use the for D0 00 modded kdcom.dll.

I even try Windbg with setpci -s, same result.

20220216-171908.jpg

ย 

On the z690 boards, even with integrated COM port, serial debug does not work any longer but serial mouse works

Dietmar

ย 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...