Jump to content

Remove corrupted mounted image


Recommended Posts

Hi all,

I've been trying to remove a corrupted .wim image which mounting was faulty.

The story is: using WinToolkit 1.7.015, the .wim image in question was in the middle of the mounting process when the PC shut down due to a blackout. Once the electricity was restored, I tried to remount the image but WinToolkit returned an error: "the destination folder is not empty."

To remove the folder, so far I have tried:

  • To remove it directly from File Explorer with no luck: "You need administrator privileges."
  • To remove the folder from File Explorer having the PC in secure mode, but I got the same result.
  • Changing permissions using the properties window, etc. but it does not work either. Both in normal and secure modes.
  • Plugging in a LiveUSB with a Linux distro, but it never shows no option for deletion of such folder.
  • Removing the key from the Windows 10 registry, the problem persists.
  • Using WinToolkit 2.0.6992, in an attempt to overwrite the mounted image in order to unmount it after, but it returns the Unhandled Dispatcher Exception described above.


So, any help to remove that folder from my C:\ drive will be greatly appreciated.


Thank you in advance,


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...