Jump to content
Sign in to follow this  
Chac.a.l

[Help] nlite cab addon type...but using WPI on Xp

Recommended Posts

Hi!! Could some tell me how to use my cab addons previously for nlite but now i see a great option using WPI, i've used a tool that is for this meaning (addons2wpi by Nuno) but it seems not doing in a correct way.

I'd like all to know if WPI can "install" for example theme addons, and other stuff that ain't just "simple" .exe or .msi...

Thank you! (i've searched about this, and went to the official site of wpi, but as i'm a newbie, i have some dificulty to understand :unsure: )

Edited by Chac.a.l

Share this post


Link to post
Share on other sites
1. Have you already contacted Nuno Brito, the developer of addons2wpi?

2. see if this thread helps: [help] install "cab" via WPI

yep! i've talked to Nuno and he told me that his not very much into wpi (of it's total funcionalities) and that he didin't knew...

I've seen that post too... and it can fit as a explanation but it's more about Vista, because it seems that it doens't work very well with vista...

Could you or kel explain to me how to "convert" this theme nlite addon of Gorki to a WPI "language"?

The .ini

;Gorki
[general]
builddate=27/10/2007
description=IllumeCG Theme
language=Multilanguage
title=IllumeCG Themes
version=0.99a
website=http://spaceqcg.deviantart.com/art/IllumeCG-0-99a-65481358

[sysoc]
IllumeCG Theme=ocgen.dll,OcEntry,IllumeCG.inf,HIDE,7

[dosnet_files]
d1,IllumeCG.inf
d1,IllumeCG.cab

[txtsetup_files]
IllumeCG.inf = 100,,,,,,,20,0,0
IllumeCG.cab = 100,,,,,,_x,,3,3

[i386_compress]
rvmtemp\extracted\IllumeCG.inf

[HexEdit]
I386\uxtheme.dll|6.0.2900.2180|113178|83EC1C568D4DE4|33C0C9C2040090
I386\uxtheme.dll|6.0.2900.2523|104714|83EC1C568D4DE4|33C0C9C2040090
I386\uxtheme.dll|6.0.2900.2845|104746|83EC1C568D4DE4|33C0C9C2040090

The .inf

[DefaultInstall]
CopyFiles =Theme.Files,IllumeCG.MsStyle,Shell.Normal,Shell.Gray,Wall.Files

[IllumeCG Theme]
OptionDesc =IllumeCG"
Tip ="Theme"
Modes =0,1,2,3
CopyFiles =Theme.Files,IllumeCG.MsStyle,Shell.Normal,Shell.Gray,Wall.Files

[SourceDisksNames.x86]
1="IllumeCG Theme Files","IllumeCG.cab",,"i386"

[DestinationDirs]
Theme.Files =10,%THEME%
IllumeCG.MsStyle=10,%COMSST%
Shell.Normal =10,%NO%
Shell.Gray =10,%GR%
Wall.Files =10,%WALL%

[SourceDisksFiles]
Gray_ss.dll =1
NormalColor_ss.dll=1
IllumeCG.msstyles =1
IllumeCG.Theme =1
Vineyard.jpg =1

[Theme.Files]
IllumeCG.Theme

[IllumeCG.MsStyle]
IllumeCG.msstyles

[Shell.Normal]
Shellstyle.dll,NormalColor_ss.dll

[Shell.Gray]
Shellstyle.dll,Gray_ss.dll

[Wall.Files]
Vineyard.jpg

[Strings]
THEME="Resources\Themes"
COMSST="Resources\Themes\IllumeCG"
NO="Resources\Themes\IllumeCG\Shell\NormalColor"
GR="Resources\Themes\IllumeCG\Shell\Gray"
WALL="Web\Wallpaper"

Inside of the .cab are the files:

Gray_ss.dll

IllumeCG.msstyles

IllumeCG.Theme

NormalColor_ss.dll

Vineyard.jpg

All these 3 files (.ini , .inf and .cab) are compressed by .rar that serves as addon for nlite...

can someone help me?

Share this post


Link to post
Share on other sites

Ok.. i had seen that post before...and because the question was mentioned for vista i didn't tried the solution of that post...

I got to work around your post, where you say:

Well all you would have to do is put the *.cab files in a i386 folder, example "%wpipath%\Install\i386" (this stops it from asking where the files are) and use a command to launch the [DefaultInstall] section of the addons *.inf like this:

rundll32 advpack.dll,LaunchINFSection "%wpipath%\Install\InfFileNameHere.inf",,1

The ",,1" hides the CopyFiles progress bar making it fully silent

So what i did was, extract my addon (a theme addon made by gorki, that contains *.inf *ini and the *.cab) to the i386 folder that i've made inside of Install (WPI/Install/i386)

I've edited the *.inf under [DefalutInstall] deleted what ever was under there and pasted this: rundll32 advpack.dll,LaunchINFSection "%wpipath%\Install\i386\IllumeCG.inf",,1

Then went to the wpi config, on the Command 1 what i did (and not certain that's well) was put the link like this: "%wpipath%\Install\i386\IllumeCG.inf"

Is this correct? I don't think so... because i've done the .iso of this xp after and installed on VirtualPC, then it loaded automaticaly the WPI, and clicked to install the theme... but then what it does is open the *.inf and nothing more, it doesn't actualy install anything.

Could you tell me what's the problem? I may be in the config of wpi, i should link the .cab and not the .inf??

Thank for you attention!

Share this post


Link to post
Share on other sites

Step 1 and 2 were good but you don't have to edit the INF at all

Just extract the INF and CAB

Put the CAB in the i386 folder

Now when you config WPI just add this to the COMMAND box (change InfFileNameHere.inf with the name of your INF)

RUNDLL32 advpack.dll,LaunchINFSection "%wpipath%\Install\InfFileNameHere.inf",,1

Share this post


Link to post
Share on other sites
Step 1 and 2 were good but you don't have to edit the INF at all

Just extract the INF and CAB

Put the CAB in the i386 folder

Now when you config WPI just add this to the COMMAND box (change InfFileNameHere.inf with the name of your INF)

RUNDLL32 advpack.dll,LaunchINFSection "%wpipath%\Install\InfFileNameHere.inf",,1

Hum... ok! I'll try!

Thanks a lot for your atention! You have been doing a great job! Congrats!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...