Jump to content

Recommended Posts

Jonnyboy I must inform you. I tested latest installer v0.451 on clean xp sytem using virtual box with latest updates for xp,but I did not have mozila installed on that particular system so I can't check if bookmarks,themes,settings,etc went fine,however I manage to make clean silent installer that works fine. But I can't recognize how much is my OS messed up at the moment since I have this issue.

Anyway regarding your babbling,don't worry you did huge job with this one ever since you start and I'm shure others would agree with me,so don't you quit on me now :P ,take your time and result will be much positive.

Good luck and thanks! :)

Share this post


Link to post
Share on other sites
Jonnyboy I must inform you. I tested latest installer v0.451 on clean xp sytem using virtual box with latest updates for xp,but I did not have mozila installed on that particular system so I can't check if bookmarks,themes,settings,etc went fine,however I manage to make clean silent installer that works fine. But I can't recognize how much is my OS messed up at the moment since I have this issue.

Anyway regarding your babbling,don't worry you did huge job with this one ever since you start and I'm shure others would agree with me,so don't you quit on me now :P ,take your time and result will be much positive.

Good luck and thanks! :)

Thanks, I did go way to fast, not enough testing. I will do better in the futer.

What problems are you having with 0.451?

Share this post


Link to post
Share on other sites
What problems are you having with 0.451?

Actually I did not have any problems with 0.451 on virtual machine (created silent installer addon in Virtual box) but I can't do same thing on live system,I already mention my problems. But I would still like to save my data,cookies,settings,bookmarks,etc and I'm searching for alternative cause I don't won to do that manualy by transfering everyeach of them in virtual environment and make addon form there :unsure:

Share this post


Link to post
Share on other sites

I really think the only issue with your vbs/bat scripts is in the way it handles the variables and checks/clears previously set variables... I wish I knew just a little more than I do about .bat scripting... I would be happy to help you sort it out... but trying to figure out exactly how all the different scripts interact with each other is a little tough when I didn't write any of them... hehe... but I've been diggin' and doing some testing... and will do some more when I get some more free time... seriously though thanks for all the work you have put into this addon I truly believe it is one of the most useful there is, hands down!

Share this post


Link to post
Share on other sites
I really think the only issue with your vbs/bat scripts is in the way it handles the variables and checks/clears previously set variables... I wish I knew just a little more than I do about .bat scripting... I would be happy to help you sort it out... but trying to figure out exactly how all the different scripts interact with each other is a little tough when I didn't write any of them... hehe... but I've been diggin' and doing some testing... and will do some more when I get some more free time... seriously though thanks for all the work you have put into this addon I truly believe it is one of the most useful there is, hands down!

I can't find the errors with your build if you don't send me the logs. :D

Actually, send me the logs, the inf and uncab the cab file and send me the dir list.

Edited by Jonnyboy

Share this post


Link to post
Share on other sites
Actually I did not have any problems with 0.451 on virtual machine (created silent installer addon in Virtual box) but I can't do same thing on live system,I already mention my problems. But I would still like to save my data,cookies,settings,bookmarks,etc and I'm searching for alternative cause I don't won to do that manualy by transfering everyeach of them in virtual environment and make addon form there :unsure:

What problems are you having with your computer?

Share this post


Link to post
Share on other sites
What problems are you having with your computer?

actually I did not have any since I started making my mozila addon using your script,and then ONLY problem popped up? I can't make your script work! :crying_anim02: Instead of that I find out that it works fine on clean and fresh XP running on virtual machine.

Share this post


Link to post
Share on other sites
actually I did not have any since I started making my mozila addon using your script,and then ONLY problem popped up? I can't make your script work! :crying_anim02: Instead of that I find out that it works fine on clean and fresh XP running on virtual machine.

Ah!!

Use the link in the first post and install wsh 5.7

Share this post


Link to post
Share on other sites
Ah!!

Use the link in the first post and install wsh 5.7

I already tried and I got message that mine i never....bla bla

Share this post


Link to post
Share on other sites
I already tried and I got message that mine i never....bla bla

I have a small script that I would like you to test and see if works.. I'll post the link as soon as I get home. 30 min or so.

Try this, it doesn't do to much. But, if it works for you, then the script should work. I started working on this before my previous posts about starting over with VC++.

Test Script

Edited by Jonnyboy

Share this post


Link to post
Share on other sites

I keep getting this error with last 2 versions previous one work perfect but not last 2 for me

I have ran from desktop and c:\ drive any suggestion as to what i may be doing wrong :D

31403924xr3.jpg

Edited by Dave3737

Share this post


Link to post
Share on other sites
I have a small script that I would like you to test and see if works.. I'll post the link as soon as I get home. 30 min or so.

Try this, it doesn't do to much. But, if it works for you, then the script should work. I started working on this before my previous posts about starting over with VC++.

Test Script

First of all thanks for your effort and patience for assisting me. I was too tired last night so I tested your script this morning...

Here is the first screen shot. I also decide to proceed with steps. Manual navigate to ff.exe then choosing prefs.js file I get error saying: This is not PE file. It all ended just after that. :huh: Did you make typo mistake pref.js instead prefs.js ,maybe you also make typo in your script. I did not check? This is just my observation..not sure maybe it could point you to right direction so I'm letting you know :rolleyes:

Share this post


Link to post
Share on other sites
First of all thanks for your effort and patience for assisting me. I was too tired last night so I tested your script this morning...

Here is the first screen shot. I also decide to proceed with steps. Manual navigate to ff.exe then choosing prefs.js file I get error saying: This is not PE file. It all ended just after that. :huh: Did you make typo mistake pref.js instead prefs.js ,maybe you also make typo in your script. I did not check? This is just my observation..not sure maybe it could point you to right direction so I'm letting you know :rolleyes:

The first screenshot is the error that happens when vbscript doesn't properly download the index page. I was just testing to see how well vbscript could do that instead of wget. But, I can't find a way to validate the download with vbscript. I was going to replace that section with wget, wget can validate and continue until it completes.

The second screenshot was a typo.

At that point the script ended. All that should be there is a log folder with 2 files. One that shows all the variables cleared and the next that shows them set. Send them both to me, please.

But, the point of this test is to see if the script worked on your system. And it did!

***EDIT***

If any other users would like to test the script, I would appreciate it. If this works for folks, the I won't need to rewrite using C++. I really don't look forward to rewriting the part that creates the inf. That was difficult to say the least.

Edited by Jonnyboy

Share this post


Link to post
Share on other sites
happy to test... send it over!

:rolleyes: Look up a few posts

Use this one instead TEST

****EDIT****

New test script, please test. Thank you

Edited by Jonnyboy

Share this post


Link to post
Share on other sites
0.442 and 0.43 versions work fine but i still get "wbat.com error" with 0.451 and 0.452

Try the test script in a post a couple of link s up.

Share this post


Link to post
Share on other sites
0.452 is the test script, isn't it? Already tried it.

posted new version a couple hours ago. here It's just a test script.

I have already begin writing new version in VB

Share this post


Link to post
Share on other sites

On my Vistas it say: Cannot execute ....wbat.com. Why .com? This is old and not supported after Win98. Therefore i dont have control over addon creating. Unfortunately :-(

Share this post


Link to post
Share on other sites
On my Vistas it say: Cannot execute ....wbat.com. Why .com? This is old and not supported after Win98. Therefore i dont have control over addon creating. Unfortunately :-(

It works on my Vista machine - no problems. I am trying to move this VB.

I'll have the update to v0.43 as promised by tomorrow. It will not have the wbat.com in it, nor will it have runhiddenconsole. There won't be the options available as in v0.44-0.45. There will be no further updates to 0.45.

I began working on VB version last night. It's going to take some time to learn to and write the program.

Edited by Jonnyboy

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...