Jump to content

[Closed] XPtsp General discusions


bober
 Share

Recommended Posts

  • Replies 1.3k
  • Created
  • Last Reply

Top Posters In This Topic

I have been tried my new VistaXP patched by B13_GUI about a week,it work perfectly to me

Thanks your great work.

and here I got some problem when I trying to patch "logoff" and "shutdown" buttons with two long buttons,because I really like these two long buttons,but no luck to me ,the Windows top border,the windows title and three buttons at right upper corner (min,max,close) got some strange problem like below.

problempl0.th.jpg

so can you help me patching those two buttons to Luna.msstyles,

The long button is here

LONG BUTTONS

BTW can I have a suggestion

if possible patch these two long buttons and reduce "Logoff" "shutdown" letters in next release,it would make startmenu more like Vista,

Best wishes to you guys and keep up good working

sorry my english

Edited by bjfrog
Link to comment
Share on other sites

I have been tried my new VistaXP patched by B13_GUI about a week,it work perfectly to me

Thanks your great work.

and here I got some problem when I trying to patch "logoff" and "shutdown" buttons with two long buttons,because I really like these two long buttons,but no luck to me ,the Windows top border,the windows title and three buttons at right upper corner (min,max,close) got some strange problem like below.

problempl0.th.jpg

so can you help me patching those two buttons to Luna.msstyles,

The long button is here

The long button

BTW can I have a suggestion

if possible patch these two long buttons and reduce "Logoff" "shutdown" letters in next release,it would make startmenu more like Vista,

Best wishes to you guys and keep up good working

sorry my english

that is some strange problem. about the start menu logoff and turn of the computer buttons text;ill see what i can do....but i have to say,theyr are fine the way they are.

amnesia; what is am.checked.1.

Link to comment
Share on other sites

oh forgot to say this occur when I patched luna.msstyles with those two long buttons,because I like the long buttons with deleting the texts , and using reshacker and restorator ,they got the same problem.

so tying to find a solution...

Link to comment
Share on other sites

I used XPtsp 1.0.10b14 Batch and after installation new system I received this error, look at picture.

It is done by localized XPtsp. Do you know how to fix it?

can you be more specific.

Link to comment
Share on other sites

if I remember correctly the error message that Rud have is from logonui.exe.

@Rud: did U change the standard WinXP logonui.exe before U apply XPtsp?

Yes, I changed logonui.exe. I'll check it.

The error shows before login screen.

Edit:

There was an error in logonui.exe

Thanks

Edited by Rud
Link to comment
Share on other sites

xpnetdg.ex_ in the original source contains xpnetdiag.exe after XPtsp it contains xpnetdg.exe; it's no problem because in txtsetup.sif is renamed to xpnetdiag.exe

U can change it into this if U want. tested and working

:xpnetdg
set name=xpnetdg
set name1=xpnetdiag
set ext=exe
set big=XPNETDG
set com=EX_
if not exist "i386\%big%.%com%" set com=exe
if not exist "i386\%big%.%com%" goto xpsp1res
%xp% "i386\%big%.%com%" "%tmp%\%name1%.%ext%"
if exist "i386\%name%.%ext%" Del "i386\%name%.%ext%"
if exist "i386\%name1%.%ext%" Del "i386\%name1%.%ext%"
%rh% %ao% "%tmp%\%name1%.%ext%", "%tmp%\%name1%.%ext%", "%res%\%name%.%ext%.res",,,&echo patching %name%.%ext%
%pe% -c %tmp%\%name1%.%ext%
set com=EX_
%cab% /D CompressionType=LZX /D CompressionMemory=21 "%tmp%\%name1%.%ext%" "i386\%big%.%com%"

dvdplay.exe.res is not applied because it's in driver.cab

hmmapi.dll.mui.res and iexplore.exe.mui.res are not applied. Even U rename the resources to hmmapi.mui.res and iexplore.mui.res or u add a parameter "name1" (%rh% %ao% "%tmp%\%name%.%ext%", "%tmp%\%name%.%ext%", "%res%\%name%.%name1%.%ext%.res",,,&echo patching %name%.%ext%)

spcplui.dll.res is not applied because in XPtsp.bat refers to spcplui.exe, extension must be changed into dll

"spcplui.dll Backup.res" is not needed in the package

Edited by Kaylar
Link to comment
Share on other sites

lol about the .backup,lol guess i repacked it to quick.

ill have a look at the other files you mentioned that need editing.(will do this 2nite)

Edited by bober
Link to comment
Share on other sites

Hey, Bober. Got a question for ya.... If XPSP?RES.DLL files are modded, will language-specific stuff change? Or just bitmaps and icons? (Mind you, I haven't looked at the XPSP?RES.DLL.RES files)

Edited by dougiefresh
Link to comment
Share on other sites

Hey, Bober. Got a question for ya.... If XPSP?RES.DLL files are modded, will language-specific stuff change? Or just bitmaps and icons? (Mind you, I haven't looked at the XPSP?RES.DLL.RES files)

umm well appart from the normal ID ing of each object of the res to the correct lang code there is only one issue.

xpsp2res.dll.res has a dialog section which would need to be translated. but apaprt formt hat jsut changing the lang IDs of the said resoruces should do the trick.

also i fixed the problems mention by kaylar (thx) so ill be reuploading. i have also added to the nrie7 section :nrie7iexplorem (patching of iexplore.mui.res)

and iexplore.exe.mui.res was renamed to iexplore.mui.res

also plz note that dvdplay has ben moved to the sp* section and that XPNETDG.EX_ has a different internal name > xpnetdiag.exe

Link to comment
Share on other sites

I've written some code to look at TXTSETUP.SIF to see if there are other files that, when installed, take the same name. I tested the new code and it didn't change the related files.... Is there any way to change the language ID through ResHacker on the command-line? Or do we need seperate resource files for these files? (We will for XPSP2RES because of the translated text, I think)

Anyway, I'll try to get an updated version uploaded tomorrow 'cause I gotta look through the batch file again. I think I missed something.... not sure, though.

Link to comment
Share on other sites

heres a sample on how to batch change lang IDs;

Restorator.exe -open access.cpl.res -setLangID 0x040C -noBackup -save -exit

0x040C is for french ids. restorator is used as it can apply the id on all the objects at the same time in a res file versus reshacker which we need to specify each object .(id have to investigate but maybe we could switch to restorator to do the patching, i dunno how the command line would differ)

--rant-- :censored:

btw, remind me to never ever include the glass toast in xptsp, its driving me nuts its just a whorthless piece of garbage.i had bad experiances with it a while back, and some one said it would be a cool addition to xptsp or soemthing so i reinstalled it and now i remember why i hated it so much.

--rant over--

Edited by bober
Link to comment
Share on other sites

--rant-- censored.gif

btw, remind me to never ever include the glass toast in xptsp, its driving me nuts its just a whorthless piece of garbage.i had bad experiances with it a while back, and some one said it would be a cool addition to xptsp or soemthing so i reinstalled it and now i remember why i hated it so much.

--rant over--

Lol glad you feel better

great to see how much this project has evolved keep up the good work :P;)

Link to comment
Share on other sites

hehe thx

update time!

edit i just noticed a miss match of spcplui.dll.res between the manual patcher ansd the addon version.the addon version has the proper file.it dosent really matter .

Edited by bober
Link to comment
Share on other sites

hehe thx

update time!

edit i just noticed a miss match of spcplui.dll.res between the manual patcher ansd the addon version.the addon version has the proper file.it dosent really matter .

in :spcplui section at the end before the compression change set com=EX_ to set com=DL_

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share




×
×
  • Create New...