Jump to content

[Attention] Concerning all my (Kel) addons...


Recommended Posts

Apparently the way I produce my addons now is not liked or understood by the RyanVMintegrator!!!

So when using ANY current Package made by me YOU MUST USE nLite!

At least untill this gets righted.

For the curious ones:

I am now building my addons in vista and using TugZip. For some unknown reason RVMi does not like the result therefore causing final install errors.

The same is showing for ricktedo64's addons also...

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...

I'm sad to see a reaction like this from you Kel. :( I have had a really bad few months and lost my cousin in an auto accident. I haven't been coding the integrator for a while. I have latley been working on the next release as well. As for the errors... they are not caused by the integrator... but poorly made addons. I mean come on... how hard is it to re-compress addons using a compatable archiving program? I know there have been issues with the integrator and SP3... nLite went through the same trouble. Except my life became more important for a little while.

For someone who was supposed to be my friend... I sure feel let down. I mean... when you were going through a rough time did I not help you out?

Good news is the integrator is back under developement.. it also has a new developer who is onboard to help out. Many new plans on an upcomming release... but for now I am concentrating on any SP3 made issues. In the meantime 1.5.3 can easily be used with MrNxDmX's WBEM Fix addon.

For those having issues with kels addons... you should be able to just expand the addon and recompress it with winrar, 7zip, winzip or almost any other archiving utility. ;)

Link to comment
Share on other sites

You are welcome to do what you want kel. I wouldn't want to put a burden on you.

What Kel is saying is do you know of a cabinet (.CAB) maker that works in Vista?

I too have to use tugzip, unless using FGCBA to "/build" addons but most (if not all) my INF files are incompatible with FGCBA and throw up tons of errors

Off-Topic Comment(Click to Show)
And making it easier for addon makers is not bad, on the contrary

[Close]

BTW I know this, Kel's FTP does not support 7zip archives...I have tried getting him to mirror my addons before

Link to comment
Share on other sites

i know that when a person goes through a phase or some sort of stumble in life, it will get so hard to get back to what he was doing earlier even to an extend of getting very simple things done

but with a little help & directions it becomes a easy way back, considering this alone will help you understand each others position much better, hopefully

Edited by ENU_user
Link to comment
Share on other sites

I have looked into adding support to extract tugzip compressed cab files... but the effort it will take... and the un-needed tool I will have to compile into the integrator just to do this task is really not worth my time. The integrator has allways been fine extracting cab files with every other know method of cab compression... but for some reason tugzip has changed something that is not compatable. It doesn't seem right for me to change such a major part of the integrator to be compatable with such a small thing. Obviously tugzip is great for cabbing files for personal use... but for UpdatePacks and Addons I guess it is a bad idea. Can I ask why not use winrar or 7zip? Don't these usually provide a much better compression anyways? I personally stepped away from using cab compression on my addons as soon as the integrator and nLite gave support for zip, rar, and 7z because dealing with cab files are so tedious. ;)

Edited by Siginet
Link to comment
Share on other sites

The internal cab files can be done with tugzip fine. It is windows install that deals with them anyways. ;) As long as Windows can read the tugzip files it is fine. If the installs you made with nLite were fine using internal cab files made with tugzip then there isn't a problem. It's just for some reason the integrator does not like the way tugzip compresses cab files. :(

If I find a simple method for extracting cab files that is compatable with tugzip then I will add it. But only if it is a very small tool that I compile into the integrator.

I stupidly was trying Expand.exe... coded it completly into the integrator and thought it was ready for tugzip cab support... but I forgot that makecab and expand.exe do not support cab files with sub-folders correctly. :( Expand.exe would have been perfect too... because I wouldn't have to compile it into the integrator.

The integrator uses a custom 7zdn.exe file that was created for us. Which supports extracting of cab, 7z, rar, and zip files. It basically is like the original 7zip comand line file but without the compression portion. Since we don't need the compression routines.

I think... nLite used to use the 7zdn.exe file too. I could be wrong though.

Thanks for understanding Kel. :D

Link to comment
Share on other sites

  • 2 weeks later...

Problem solved.... if your want to use Kels addons, if you use the intergrator program that is...

1st use the interator for all your addons, then the last process, use Nlite.

This works for me, but lately I have been using Nllite for mostr of my works with Windblows XP.

Not to worry though Windows 7 the new OS will be out next year, either in January or June. to replace Vista.

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...