Jump to content

XPtsp GUI v3.0.0.26 - February 27, 2012


dougiefresh
 Share

  

46 members have voted

  1. 1. What language OS do you use XPtsp on?

    • English
      28
    • non-English
      12
    • Both English and non-English
      6

This poll is closed to new votes


Recommended Posts

UPDATE: I've found several files that may be uncompressed during integration of the res files and have corrected the code to use those files instead of the compressed version. Windows Setup prefers the uncompressed files over the compressed files for some reason, so the GUI code has been updated to reflect this situation.

I also noticed and have fixed a few fairly minor bugs in the Live Install process as well. Hopefully, the changes there will take care of the irritating problem with the XPtsp Repatcher. I've got to test those changes to make sure, though....

Link to comment
Share on other sites

What's Changed in v3.0.0.16:

Integration Changes:

- Moved source XPTSPCOM.INF detection code to Source Selection page.

- Added ability to patch "WMP10.CAB" in addition to "WMP11.CAB".

- Modified code so that uncompressed "SVCPACK.INF" is used if found.

- Modified code so that uncompressed "SYSOC.INF" is used if found.

- Modified code so that uncompressed "SMSS.EXE" is used if found.

- Modified code so that uncompressed "WBEMOC.INF" is used if found.

- Modified code so that uncompressed "XPtspCom.INF" is used if found.

Live Install Changes:

- Moved live XPTSPCOM.INF detection code to Installation Path page.

- Fixed issues dealing with wallpaper extraction for CAD2009 customization.

- When using batch with GUI, batch is no longer copied to Archive folder.

- Moved "XPtspCom.INF" from temp folder to INF folder to make Repatcher work.

- x64 Only: Fixed file replacement code to reduce the chances of screwing up the OS.

- Re-Enabled Repatcher to auto-run at Windows startup.

- Fixed issues with wallpaper conversion and replacement.

GUI Changes:

- ComSel code changed to look at "XPtspCom.INF" to see if file has been patched.

Control Panel Changes:

- Re-Enabled Repatcher functionality through Control Panel.

============================================================

A Few Notes:

- I don't know if SMSS.EXE can be compressed on the XP CD, however, the code was modified in the event that it found a compressed version of SMSS.EXE in there. It may not be necessary to check, however, I feel that the small increase in code is worth the effort just to make sure I haven't missed anything.

- Repatcher has been re-enabled for use at Windows startup, as well as through the Control Panel applet. It should behave now..... :thumbsup_anim:

- I'm pretty sure that the resources used to patch Windows Media Player 11 will work with Windows Media Player 10, so I've altered the code so that WMP10.CAB is patched using the same resources that WMP11.CAB is patched with.

- "Why tell anyone that XPTSPCOM.INF detection code has been moved?" Well, if the GUI SFX is run on an install that has XPtsp already integrated, it SHOULD enable the GUI to decide with files need updating to the current appearance (assuming that it was patched using an earlier version of the resources). Previously, it was not capable of correctly figuring out if the files were patched or not.

- "Why tell anyone about the reduction of chances screwing up the x64 OS?" Well, this might only occur in the event that another program (aka Windows Update) has requested file movements at next reboot AND somehow the GUI is still able to patch your system. There is a slight chance that the previous paths might be screwed up, because at the end of the patching cycle, the SYSTEM32 references are changed to SYSWOW32 and SYSNATIVE references are changed to SYSTEM32 in order to make sure the files get moved to the proper folders. This was done because the XPtsp GUI is a 32-bit application and can't properly access SYSTEM32 without performing tricks to get around the Windows 64-bit redirection mechanism.

Link to comment
Share on other sites

  • 2 weeks later...

Bad news I'm afraid.

I just tested 3.0.0.16 on XP Pro. If svcpack.inf is left uncompressed, xptsp successfully patches it, and then deletes it. :(

After the integration is complete, neither svcpack.in_ or svcpack.inf exist in %source%\i386\

:doh: I thought I fixed that! :censored: Okay, I'll look at it again.....

EDIT: Thank you for the bug report!

EDIT2: I thought the way I had coded it, the program could determine whether it was already uncompressed. If not, it could unpack it. Editing would then take place, then I could compress it to save space. Evidently the CABLITE.DLL disagrees with that assumption.... So my code change is to leave it uncompressed if that's the way I found it to start with.... I'm really sorry I missed that one....

Link to comment
Share on other sites

What's Changed in v3.0.0.17:

- Altered code so that uncompressed files are properly handled.

- Modified code so that uncompressed INF files are compressed after modding.

- Fixed ComSel code to look at correct section in "XPtspCom.INF".

- Removed some code that may have produced incorrect file repatches.

- After CPL makes change to TASKMGR.EXE, CPL GUI is redisplayed.

Link to comment
Share on other sites

I haven't tried any of the other themes except for green, but the wifi tray icon bug is still there. With "Excellent" signal strength, the "5 empty bars" icon is displayed. If I take the notebook away from the router, the icon changes to 4/5 bars then 3/5 bars. Once back in the same room as the router I get the 0/5 bars icon. :|

I'm sure we went over all this before, but I don't think it was ever resolve.

LOL, I'm running out of things to be nit-picky about! :D

Link to comment
Share on other sites

  • 1 month later...

Download link and topic title are displaying "XPtsp GUI v3.0.0.16"

Yes, strange. I have v3.0.0.17 (build date 17 Jan)

File: XPtsp_v3.0.0.17_GUI.exe

CRC-32: 98710103

MD4: ad7ba3533720c264ac7ce733b0021a3b

MD5: a1723194b39a319dbb129ec2239dd421

SHA-1: 896a0b65f16d00e8b53a060bc12c8d49d63bb8f9

The first post has links for v3.0.0.16 and yet the homepage (http://www.xptsp.com...p_Downloads.php) has a 'current' link for v3.0.0.9 (build date of 20 Feb 2011).

So I guess there's some version number wacky-ness going on here. :D

*Edit

Dougiefresh closed his support forums. Because his site appears to be broken and doesn't directly link to the current version, I'll link to it here.

The last good version was v3.0.0.17

Download: http://www.mediafire.com/file/e9aytda3909uo64/XPtsp_v3.0.0.17_GUI.7z

Edited by Mr_Smartepants
Link to comment
Share on other sites

I'm sorry about my late reply.... I've been really busy with work these last few weeks and haven't been able to have a life :confused02: I managed to delete the contents of our server and had to re-upload everything, which is why v3.0.0.17 isn't on there. As for the "version wackiness", I will take care of that shortly. I've uploaded v3.0.0.17 to the server, so the "latest GUI" link should work properly now :blink:

The reason that the xptsp.com forum has been closed is that we have been getting a lot of spam and it is really difficult to remove all the spam with the hours I've been working. I am working on a solution to the problem, however, it may not be ready for a while.....

Link to comment
Share on other sites

  • 4 weeks later...
  • 1 month later...
  • 1 month later...
  • 2 weeks later...

Hey doug do you include the 32 bit icon patch for taskmgr and regedit?

If you do you should also have a look at this other 32 bit fix for outlook express by Dubby

commod.png

Sorry about my lateness replying. I've been real busy with work lately and haven't been able to do much....

I did implement the taskmgr and regedit hex-editing in the XPtsp project.... That hex-edit is pretty cool!

EDIT: I thought I had..... I looked at the source code last night and evidentally I haven't.....

Edited by dougiefresh
Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...

I just wanted to let you know of a nagging bug with XPtsp GUI v3.0.0.18.

unledtiu.th.png

Selecting "Use Professional visual theme" on either Home or MCE sources does nothing. Both Home and MCE will use their own respective XPtsp themes regardless if that option is checked or not.

Edited by Mr_Smartepants
Link to comment
Share on other sites

  • 4 weeks later...

<tap tap tap> Testing...testing <tap tap> Is this thing on?

Hello?

Yup, the microphone is on. Work has picked up a bunch and I haven't been able to get online to do much of anything lately. I'm sorry the Task Manager report and visual theme report have gone unanswered. I'm going to try to rectify the issue soon.

I also haven't gotten any notifications on new postings from WinCert. Maybe a problem with the email program or my web server. I dunno.... haven't looked into it yet.

EDIT: I've modified my Wincert forum settings so that the email gets delivered to the right address.... :oops: so maybe I'll start getting mail again!

I've run a test of the patcher in XP Home and can't duplicate the report that checking the "Use XP Pro visual theme" doesn't work....

Link to comment
Share on other sites

  • 3 weeks later...

The Task Manager bug is a show-stopper for me. I don't know what other info I can give that will help you track it down.

yes we have discussed this problem for a long time and it seems there is no solution/ at the moment ...

Link to comment
Share on other sites

The Task Manager bug is a show-stopper for me. I don't know what other info I can give that will help you track it down.

yes we have discussed this problem for a long time and it seems there is no solution/ at the moment ...

I'm sorry. I didn't mean for the problem to go unresolved for so long. On what themes does this problem exist? Thanks!

Link to comment
Share on other sites

@Mr_Smartepants,

If you use the green batch with Xptsp Gui there are no task manager problems. Just tested in virtualbox on xp pro.

I only ever use the Green theme. Thanks for looking into it.

I just tested it on a fresh build and the bug is still there. I'll try the blue/neon theme as well as downloading the green theme files again.

Link to comment
Share on other sites

 Share

×
×
  • Create New...