Jump to content

XPtsp GUI v3.0.0.26 - February 27, 2012


dougiefresh
 Share

  

46 members have voted

  1. 1. What language OS do you use XPtsp on?

    • English
      28
    • non-English
      12
    • Both English and non-English
      6

This poll is closed to new votes


Recommended Posts

What's Changed in v1.4.5.6:

- Updated resources to pre-release batch v1.4.6.

- Updated modified 7zip SFX module to latest version.

- Updated Drive Space Indicator to latest version.

- Fixed cursor locations within new .theme files, moved into location if cursors are selected.

- Rebuilt UberIcon so that SFX kills running executable before installing.

- Renamed DrvSpace.exe to DriveSpace.exe to remedy "bug" in DSI installer causing hang.

- Added QTab and Visual Task Tips to the programs list that the GUI can install.

- Page 4 modified so that prior states are still active when going from Page 5 back to Page 4.

- Installation code modified so that all files getting patched get installed by the GUI.

- Installation code modified so that files not getting patched aren

Link to comment
Share on other sites

STATUS UPDATE: Be warned that uninstall isn't working correctly at this point! It didn't kill my VM, but it also didn't restore ANY of the backup files either.....

It also looks like the new code won't be ready before XPtsp batch v1.4.6 is official... sorry, guys!

Mar 22, 2009 UPDATE: Uninstall code appears to be complete and working.

Link to comment
Share on other sites

STATUS UPDATE: Since I am off work this entire week, I've been doing much work to try to eliminate every bug I can find. After MANY test installs and coming close to losing my hair, here is what's happened:

- Uninstall finally is working properly.

- Back-ups are made of the replaced (non-patched) files.

- UXTHEME.DLL and SFC_OS.DLL are finally patched correctly.

- User Account Pictures appear to be installed.

- Cursors are installed, however, cannot be made default at the moment.

- New Visual Theme is installed, however, cannot be made default if not already set.

- Bootscreen sometimes is installed, sometimes not. Can't figure out why....

- Task Manager pics are NOT correct. Some work needs to be done to correct these....

- Reboot option removed from "Integration Complete" page, as it doesn't make sense to have it there.

- "Invalid parameter" message given after reboot. Why? Dunno....

I am hoping to be able to release the GUI v1.4.6.0 within the next day or so. Please have patience. Also, the "differences" archive will be updated, as only the English.ini and XPtsp.exe files have changed. Thank you for your patience.

EDIT: Oh, I should note that the script consists of well over 2,500 lines (not counting external files). Because of the size of the script, it is becoming harder and harder to fix things, so your patience is much appreciated. Thanks again!

Link to comment
Share on other sites

STATUS UPDATE: Visual Style, Wallpaper and Screen saver now are installed correctly, and the changes are visible to the user once the computer is rebooted. Bootscreen issue has been solved, courtsey of moving the code to later in the installation. Red bootscreen has been added, no pics yet. Hoping to have a purple bootscreen in there as well.

Bober: I hope IE8 doesn't involve too much in the way of changes.... I haven't installed it yet, so I don't really know what kind of changes may be and/or are necessary to support in the project. But it would be cool! Let me know! Thanks!

Link to comment
Share on other sites

What's Changed in v1.4.6.0:

- Updated resources to un-official release batch v1.4.6.

- Added file location and description for new FTSRCH.DLL resource file.

- Included updated SFX for QTab.

- XPtsp.ini file has been removed from script, can be easily accessed in SFX.

- Fixed Task Manager screenshots, removing

Link to comment
Share on other sites

Hi i was attemptint to install the latest xptsp gui and i got this message (The selected folder does not contain the xp installation source files) when browsing for the xp source folder. ive nliteed my installation as well as integrated onepeice's post sp3 update pack. is there any soloution for this problem?

Thank you

Link to comment
Share on other sites

Mtek01: Well, the XP source folder must have SETUPP.INI and TXTSETUP.SIF present. I assume that the XP setup program requires both, so I check for both. Please check for both of these files in your source folder and let me know if they both are present.

In any case, I assume that it must be XP Home Edition if SECEDIT.EXE is not present in either compressed (ends with .EX_) or uncompressed form. If it is present, then the GUI checks for MEDIACTR.CAB and marks it XP Media Center if present. If not present, then it must be XP Professional. Some work goes into determining if it is OEM or Corp version.

I hope this provides enough information to diagnose the problem.

Mona: I've reuploaded the SFX to the WinCert server.

Link to comment
Share on other sites

Mtek01: Well, the XP source folder must have SETUPP.INI and TXTSETUP.SIF present. I assume that the XP setup program requires both, so I check for both. Please check for both of these files in your source folder and let me know if they both are present.

In any case, I assume that it must be XP Home Edition if SECEDIT.EXE is not present in either compressed (ends with .EX_) or uncompressed form. If it is present, then the GUI checks for MEDIACTR.CAB and marks it XP Media Center if present. If not present, then it must be XP Professional. Some work goes into determining if it is OEM or Corp version.

I hope this provides enough information to diagnose the problem.

Mona: I've reuploaded the SFX to the WinCert server.

Well it turns out its not vista compatible i tried it on another xp pc and it worked fine thanks for the help though

Edited by Mtek01
Link to comment
Share on other sites

Well i am also facing the same kind of problem as Mtek01 is facing.I have also nlited the xp by slipstreaming service pack 3 and if i want to integrate your Xptsp GUI v1.4.6.0 or any previous build iam getting the same error as (The selected folder does not contain the xp installation source files).I am running vista, i think under vista patching is not working.Please help me.

In my previous post i requested for adding ubericon effects, thanks for accepting my request and sorry for using all capslock in my previous request.

This time also i want to request you for some new features in your pack, as i love your pack and i wish that only if possible

please try to add Welcome Centre for xp like vista, Fast aero, Windows_7_Property_Dialog_4_XP_by_pri2sh.Once again please accept this request if possible, i think others will also love it :wub_anim: .

Thanks and keep going your awesome work. :thumbsup_anim:

Regards,

Manikant.

Link to comment
Share on other sites

I know that the patcher cannot be used for Live Install on Vista, however I wasn't aware of any difficulty until yesterday about Integration. Maybe it is time to upgrade to the latest version of AutoIt.....

Regarding Fast Aero, I like the way it looks on their forum. Haven't tried it yet, though. I will take a look at the others once links to them are supplied.

EDIT: I've tried it out. I'm gonna have to pass on Fast Aero. Now, if TrueTransparency would serve the same purpose, i might include that one (assuming I can get permission).

Link to comment
Share on other sites

Thanks for making this fantastic looking GUI version.

Can you kindly tell me if i am following the correct integration order:

1. [AddOn] Media Center 2005 (English)

2. [AddOn] Vista Media Center 2.3 (English)

3. XPtsp GUI v1.4.6.0

Is this the correct order?

Link to comment
Share on other sites

That sequence looks right. After all, you need the MEDIACTR.CAB in order to add the Vista MediaCenter add-on to it. Just make sure the XPtsp GUI doesn't integrate the MCE resources, as I don't know what will happen if that occurs.

Link to comment
Share on other sites

Does QTab work on anybody's computer? Because I can't seem to make QTab work on my computer, even with the .NET Framework 2.0 installed. I really tempted to pull the application from next release.

I've fixed the cursor registry entries, so that the correct cursors show up. I've also added a check for .NET Framework 2.0, so if any application needs it, the code is available. Currently, QTab requires .NET Framework v2.0 to function and is the only application to require it. Don't ask if I will include .NET Framework, because it won't happen.....

Link to comment
Share on other sites

For those people wanting the internal INF correction for v1.4.6.0, a download link has been added under "For Those On A Slow Connection". This 7zip file has XPtsp.exe with the corrected internal INF file. I deem this such a small update that it isn't worth re-uping the entire thing.

Download Link Removed by dougiefresh

Link to comment
Share on other sites

I personally haven't tested it to see if it works with Internet Explorer 8. I know of no situation where the GUI deletes files, but I'll test the integration code again to make sure. I'll also implement IE8 support.

Have you tested your XP source with IE8 integrated into it on a real system or VM? If not, please do so before reporting back. Because if your OS is missing files, the GUI can't patch what is not there.

Link to comment
Share on other sites

Have you tested your XP source with IE8 integrated into it on a real system or VM? If not, please do so before reporting back. Because if your OS is missing files, the GUI can't patch what is not there.

I have made a CD installation with all my Addons and ie8 and it installs fine on Virtual box, then I patched the whole set with the GUI and tried to install this on Virtual box and it shows these missing files.. that was the reason for my asking..

A nice evening

Link to comment
Share on other sites

Thanks for the feedback. I'll incorporate changes needed to support IE8. And I'll also look into the missing files thingy..... Hopefully, I'll have a solution sooner rather than later. Tell me, what IE8 addon are you using?

EDIT: It might also be helpful if you would list the files that are missing from the source folder.

Link to comment
Share on other sites

Does QTab work on anybody's computer? Because I can't seem to make QTab work on my computer, even with the .NET Framework 2.0 installed. I really tempted to pull the application from next release.

I've fixed the cursor registry entries, so that the correct cursors show up. I've also added a check for .NET Framework 2.0, so if any application needs it, the code is available. Currently, QTab requires .NET Framework v2.0 to function and is the only application to require it. Don't ask if I will include .NET Framework, because it won't happen.....

Maybe use Ricks Addon For This?

Link to comment
Share on other sites

 Share

×
×
  • Create New...