Jump to content
Legolash2o

Windows 7 Toolkit v1.0.2 FINAL

Recommended Posts

What else do you do, there must be something? What exactly did you do? :P

What windows you using?

Edited by Legolash2o

Share this post


Link to post
Share on other sites

Hey Lego,

nice to see you fixing things so quick!

Just found a bug in tweaks and options : The tweaks are applied to the current OS though not selected in OPTIONS. So I browsed the registry to clean up things and found GodMode in computer context menu, but the command is missing - only gives out an error (explorer.exe command not specified)

Keep on coding, best tool out there so far!

Share this post


Link to post
Share on other sites

I never used the tweaks before. First time this came to my attention was in 1.0.2-5, but was not sure if accidently the "test on current OS" option was set. So I decided to test on 1.0.2-9 again, only GodMode and Show All Icons in Taskbar tweak was activated so I can't say if some more are involved. GodMode was present in curr os but did not work (param missing...) and after a restart the notifications in taskbar were hidden, though this was set to show all before working with W7T.

What should "testing install tweaks on currnet OS" do? Simply apply them to current os?

Forgot to post I'm working on (and editing this one) Seven x64 Ultimate

Edit: The green progress in taskbar icon of W7T does not work, it hangs at the very beginning.

And I wonder why only showing the main window of W7T does lead to ~50% cpu usage ... but nothing to cry about.

I just tested again, now only Control Panel view was set to category -> curr os shows large icons now (not categorys), small icons is my default. Strange. As I said, usually I apply my own localized german tweaks by sfx addon.

Edited by chris.b

Share this post


Link to post
Share on other sites

When you did the control panel view tweak, was Current OS ticked or unticked?

You're not supposed to tick Current OS, that's just for me :P

Edited by Legolash2o

Share this post


Link to post
Share on other sites

v10 released with 'W7T Options' fix, added a notice to the Current OS tweak and changed it's description. Just to add... don't tick this option :P

Share this post


Link to post
Share on other sites

***********************************

WIM Manager (All-In-One Integrator)(frmWIMManager)

Unable to check for mounted images <-> this error shows up when i click on AIO

Exception: Object reference not set to an instance of an object.

***********************************

Edited by Sorin

Share this post


Link to post
Share on other sites

Open Regedit...

does if "HKEY_LOCAL_MACHINE\\SOFTWARE\\Microsoft\\WIMMount\\Mounted Images" exist?

Print screen please as well :)

Edited by Legolash2o

Share this post


Link to post
Share on other sites

Some news mostly towards TH-Tech.

The 'Change Setup Background' won't work for you because you have a different spwizimg.dll, if you right click on it > properties > details, it says it's original filename is 'spwizres.dll' you can probably fix this by replacing spwizimg.dll with another file on a working dvd.

EDIT: Hopefully build 13 will work for you.

Edited by Legolash2o

Share this post


Link to post
Share on other sites

Some news mostly towards TH-Tech.

The 'Change Setup Background' won't work for you because you have a different spwizimg.dll, if you right click on it > properties > details, it says it's original filename is 'spwizres.dll' you can probably fix this by replacing spwizimg.dll with another file on a working dvd.

EDIT: Hopefully build 13 will work for you.

Yep. tried that today. I'm just too busy with my work now.

Share this post


Link to post
Share on other sites

Hey Legolash2o,

i've been following you since a long time, firstly let me say a very BIG THANKS for creating a tool, that us IT administrators make our lifes easier,

i wanted to ask you a little something, when at the AIO integrator you try to integrate the unattended file created previously in the creator, it tells you "you must select at least 1 task to complete".

I only want to integrate the unattended file, i dont know if this was designed to be like this (maybe you require one variable of the other tabs to start the process).

Also, i read it somewhere on another post where a user requested the unattened file creator, that it had the autologon feature, but when the creator creates the unattend, it does not add the following needed lines:



<AutoLogon>
<Password>
<Value>mypassword</Value>
<PlainText>true</PlainText>
</Password>
<Username>Administrator</Username>
<LogonCount>2</LogonCount>
<Enabled>true</Enabled>
<Domain>WORKGROUP</Domain>
</AutoLogon>


Correct me if im wrong, but I think by what i remember from my old days with Vista/XP, that this part of the code is required if you use the following code:

<SkipUserOOBE>true</SkipUserOOBE>

Also, the Unattended creator does not have an "open" button if you like to edit an already created file, or one already integrated, is this by design?

Sorry for all the questions =P,

Thanks for your time an dedication!

Cheers

PS: sorry if my english is not perfect, also i can help you if you need some help with the unattended code ^_^.

Share this post


Link to post
Share on other sites

My Unattended files are created using WAIK, I will fix that issue when I get home however, if you use the WIM Manager to mount the image, and Apply Unattended button appears so you can do it that way also.

Have not read your message in full as I'm on my phone instead of laptop.

I do have not implemented to AutoLogon and open previous file features but you may request it in te Request forum.

Share this post


Link to post
Share on other sites

:manual: Can I get an error message that the driver for any off. It is annoying when you leave the machine to work overnight and only a few drivers have been made as to press ok to the error indication.

The whole night was wasted:)

It would be better if the program performed by the end of everything, without notification, and then you can try again error drivers.

Edited by TH-TECH

Share this post


Link to post
Share on other sites

I will make it so everything will go to the error log only but I can't do that until I get home from work :(

EDIT: Luckily i have bought my laptop to work and have removed all messages during AIO Interator, and everything will go into the error.log instead. I can't release right now because i've hooked my laptop to my phone internet and i need to save my bandwidth :)

Edited by Legolash2o

Share this post


Link to post
Share on other sites

I will make it so everything will go to the error log only but I can't do that until I get home from work :(

EDIT: Luckily i have bought my laptop to work and have removed all messages during AIO Interator, and everything will go into the error.log instead. I can't release right now because i've hooked my laptop to my phone internet and i need to save my bandwidth :)

No rush. We've already won the world championship ! :thumbsup_anim:

Share this post


Link to post
Share on other sites

Released, if the change setup background works then i may start work on v1.0.3 next week which will include W7T in other langauges, so the quicker the better :P

The rest of v1.0.2 will only be bug fixes.

Edited by Legolash2o

Share this post


Link to post
Share on other sites

just want to thank you for an awesome program that you created the only thing that i see is downloaded the newest build and ran the program and usb boot prep is missing from toolkit i have a blank space there can not figure out why that is can you please advice me in this issue thanks again for an awesome program

Share this post


Link to post
Share on other sites

There have been no comments by you in the XP Addons section for many days. Are you still going to make them compatible with W7Toolkit - after all you asked for addon locations?

Also, enjoy university; but don't study too hard and turn it into a grind.

Share this post


Link to post
Share on other sites

Released, if the change setup background works then i may start work on v1.0.3 next week which will include W7T in other langauges, so the quicker the better :P

The rest of v1.0.2 will only be bug fixes.

Although my English skills to be there ...

I believe that I am able to make Finnish language pack. I am involved. :worthy:

To test this tonight. Have you had time to fix the driver error. Can I leave my computer on my wife to annoy the integration of the drivers :blush:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...