Jump to content

Windows 7 Toolkit v1.3.0 ALPHA


Legolash2o
 Share

Recommended Posts

is there anyway to integrate my own sets of updates instead of using SoLoR updates?

As long as they are windows msu updates you can add them (except for KB2533552).

(What's wrong with SoLoR? they got most of the patches).

Edited by GieltjE
Link to comment
Share on other sites

Well, I thought W7T had frozen up again. It appeared to have stopped on an update. This is after I left it to run and I went to bed. To that end, this morning it only made it to update 5 out of 278. In the processes of stopping many unneeded services and programs (to get a cleaner process list), W7T began moving again. I do not think it was any of the processes as those were totally unrelated to W7T and what it does. Maybe the OS puts W7T into some kind of "sleep" mode? Is there a way that you can have the computer not go into a power saving mode while W7T is running?

Link to comment
Share on other sites

Well ... it took me a couple of round of integrations. I tried removing the "setupcomplete.cmd" and even tried integration a bit differently (IE9 first instead of last). There appears to be an update that gets integrated and wants to change something near the end of the installation. Attached is a screen shot. This screen appears right before the W7T run silent installers section.

Edit: Added a better screen shot of the "condition".

post-11322-0-36528500-1315711832.png

post-11322-0-86667500-1315762163_thumb.p

Edited by crashfly
Link to comment
Share on other sites

Made a few changes, quickly went through 140+ error logs and made a few changes/fixes. AIO-Tool will ask if you are sure to cancel when you click the "Cancel" button, also the AIO-Tool default size depends on the size of your screen. Also fixed the "caplock" misspelling above to include the missing 's'.

Didn't update the changelog as i can't remember everything that i have change since v46.

Link to comment
Share on other sites

Well ... it took me a couple of round of integrations. I tried removing the "setupcomplete.cmd" and even tried integration a bit differently (IE9 first instead of last). There appears to be an update that gets integrated and wants to change something near the end of the installation. Attached is a screen shot. This screen appears right before the W7T run silent installers section.

Whoever made that silent installer for .NET 4 should of added the /norestart or equivalent switch.

@crashfly - Can you verify whether it is the .NET 4 installer that is the culprit? I don't think it is, but if it is then I'll help get the word to Troubada/Trinket so he can resolve the issue, once you have verified the need.

Cheers and Regards

Edited by bphlpt
Link to comment
Share on other sites

@crashfly - Can you verify whether it is the .NET 4 installer that is the culprit? I don't think it is, but if it is then I'll help get the word to Troubada/Trinket so he can resolve the issue, once you have verified the need.

Cheers and Regards

I already let them know it was not the .net 4 installer. I only posted that image as it appears as the silent installers are starting. I cannot tell if the problem is from a driver installation (it may be that), or from an update. Unlike Windows XP, Windows 7 does not have a "clear" explanation of the install process (in other words, at time period xx, such and such happens).

Link to comment
Share on other sites

  • 2 weeks later...

w7toolkit 1.3.0.47 shows an error: "System couldn't find the file"

c:\users\ctn\desktop\packages.exe /p ...

When I hit the ok button, everything is ok. Is that an error?

Cheers.

I have had this problem occur too. It is usually random, but I often see it during the addons section. It is total random. Typically, starting over and performing the "run" again, I do not see the problem.

Link to comment
Share on other sites

I have integrated 10 win7toolkit addons and one rocco's unattended messenger 2011 to my win7 DVD succesfully.

Almost at the end of win7 installation a W7T Runonce (d:) captioned form waits me check or uncheck 4 addons.

They are malicius software remowal tool, Reaper's framework4, Reapers's adobe flash and adobe java.

when I hit the start button, installation instals 4 addons.

I don't want to interrup my installation. Any idea ?

Link to comment
Share on other sites

I have integrated 10 win7toolkit addons and one rocco's unattended messenger 2011 to my win7 DVD succesfully.

Almost at the end of win7 installation a W7T Runonce (d:) captioned form waits me check or uncheck 4 addons.

They are malicius software remowal tool, Reaper's framework4, Reapers's adobe flash and adobe java.

when I hit the start button, installation instals 4 addons.

I don't want to interrup my installation. Any idea ?

When integrated, did you have them set to "always run"? If not, you will get the question about select the installs you want to run.

Link to comment
Share on other sites

When integrated, did you have them set to "always run"? If not, you will get the question about select the installs you want to run.

Thanks answering.

I have "always install" options checked. I had an uttanded exe installer Roccos_WLMessenger_unattanded_15.4.3508.1109_tr.exe

When I deleted it from silent instals, no problem occured. I think that file causes the problem.

Regards.

Link to comment
Share on other sites

  • 3 weeks later...

Hey guys just letting you know i've fixed a problem with unattended causing a strange error when applying unattended. Will be in v49 smile.png

EDIT: Also fixed importing unattended files when it contains users.

----------------------

v49 released

*FIX: Error importing previous unattended files

*FIX: Error applying unattended when adding multiple users

*FIX: Object error during Component Removal

You will have to re-create your unattended file, you can however use the 'Import' feature in Unattended Creator.

Also, when adding msu to silent installers (AIO) you don't have to add a syntax i.e. /quiet /norestart as its done by default.

----------------------

v50 released.

*FIX: Multiple fixes to the RunOnce Installer

I've made quite a few enhancements to the RunOnce installer including getting it's RAM usage from 15MB to 3.5MB and fixed a few bugs.

*SoLoR Updates will show new updates at the top

*RunOnce Installer let's you change background and logo

Edited by Legolash2o
Link to comment
Share on other sites

i have made many aio disks, with updates, programs addon, tweaks.... all work great. i have found a bug (not serious) in 48 when i add silent installers sometimes dont add some of them. i continue to add programs. after i add the programs that missing and its ok. anyway, my opinion its ok for beta status. great tool!!! if you can add a remove option for themes (nobody use it, just keep the default theme)

Link to comment
Share on other sites

I'll have a look at that silent installer issue and i've added 3 things to the AIO component removal

Ease of Access Themes - Removes all East of Access Themes

Aero Theme - Removes just the Aero Theme

Non-Aero Themes - Removes all themes in the 'Themes' folder except Aero

I'm in the process of adding it into Component Removal tool as well. EDIT: Done.

Edited by Legolash2o
Link to comment
Share on other sites

i have made many aio disks, with updates, programs addon, tweaks.... all work great. i have found a bug (not serious) in 48 when i add silent installers sometimes dont add some of them. i continue to add programs. after i add the programs that missing and its ok. anyway, my opinion its ok for beta status. great tool!!! if you can add a remove option for themes (nobody use it, just keep the default theme)

Can this bug exist in your computer? After v50 the program seems to work pretty stable.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...