Jump to content

Integration issue (title fixed)


crashfly
 Share

Recommended Posts

According to Solar's hotfix information, Windows6.1-KB2533552-x64 is not integratable with the install source. If that is the case, how does one get that update automatically on the install without going to Windows updates?

I only ask this because I am a perfectionist. I have every other update applicable to a x64 source integrated and when checking the install, the above update (KB2533552) is still needed.

So, who can help me with this one?

Edit: After further investigation, this is not a problem with the KB2533552 update as previously mentioned with the old topic title ("How to integrate KB2533552?"). It appears to be an integration problem. Skip down a few posts to see details.

Edited by crashfly
Link to comment
Share on other sites

\sources\$oem$\$$\Setup\scripts\setupcomplete.cmd

That's how I install all the .NET 4 updates.

Oooooooo .... I like. Is there any more information on this "setupcomplete.cmd" option? That is, where can I learn all about it?

Link to comment
Share on other sites

I wrote about my setupcomplete.cmd here: http://forum.driverp...pic.php?id=5199

Adding it should be as simple as adding a line:

IF EXIST %SystemRoot%\SysWOW64 start /wait WUSA %CDROM%\updates\Windows6.1-KB2533552-x64.msu /quiet /norestart

IF NOT EXIST %SystemRoot%\SysWOW64 start /wait WUSA %CDROM%\updates\Windows6.1-KB2533552-x86.msu /quiet /norestart

But to be honest I haven't tried this.

A description of the .msu installation process using WUSA is here: http://support.microsoft.com/kb/934307

Edited by Mr_Smartepants
Link to comment
Share on other sites

I must thank you Mr_Smartepants. When you posted yesterday, that prompted me to lookup how to use the "setupcomplete.cmd" structure. Although I did not find your post, I was able to piece together how to do it from a few other posts. I will be testing it when I can get a "completed" image from 'Windows 7 Toolkit'. I am glad to know at least MS did not deviate *too* far from some of the same practices they had on XP.

Link to comment
Share on other sites

  • 2 weeks later...

So I have found couple of solutions... And I have edited my own updates.bat file and setupcomplete.cmd.

updates-x64.bat

@echo off
::Set Paths
:: Do NOT use trailing backslash in path (i.e. C:\mnt instead of C:\mnt\ )
:Path to mount folder
set mnt=h:\W7T.temp\Mount
:Path to source .wim
set src=h:\Windows.7.SP1.SK.test\sources
:Path to update packages
set updates=h:\Windows.7.add\updates-via-batch-file

cls
dism /Mount-Wim /WimFile:%src%\install.wim /index:4 /MountDir:%mnt%
dism /Image:%mnt% /Add-Package /PackagePath:%updates%
dism /Unmount-Wim /MountDir:%mnt% /commit
dism /Mount-Wim /WimFile:%src%\install.wim /index:3 /MountDir:%mnt%
dism /Image:%mnt% /Add-Package /PackagePath:%updates%
dism /Unmount-Wim /MountDir:%mnt% /commit
dism /Mount-Wim /WimFile:%src%\install.wim /index:2 /MountDir:%mnt%
dism /Image:%mnt% /Add-Package /PackagePath:%updates%
dism /Unmount-Wim /MountDir:%mnt% /commit
dism /Mount-Wim /WimFile:%src%\install.wim /index:1 /MountDir:%mnt%
dism /Image:%mnt% /Add-Package /PackagePath:%updates%
dism /Unmount-Wim /MountDir:%mnt% /commit
echo .........................................
echo Update integration complete
pause
exit

setupcomplete.cmd

@echo off
for %%i in (C D E F G H I J K L M N O P Q R S T U V W X Y Z) do if exist %%i:\sources\install.wim set CDROM=%%i:
echo Found CD-Rom as drive %CDROM%
::Begin hotfix install

:Defender Definitions
echo Installing Windows Defender Definition updates
IF EXIST %SystemRoot%\SysWOW64 start /wait %CDROM%\updates\WinDefUpdate\mpam-fex64.exe /Q

:Updates
echo Installing Updates
IF EXIST %SystemRoot%\SysWOW64 start /wait %CDROM%\updates\Windows6.1-KB2533552-x64.msu /quiet /norestart

:WPIW
::Begin WPIW
echo Starting Windows Post-Install Wizard
REG ADD "HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main" /V "Disable Script Debugger" /T "REG_SZ" /D "no" /F
REG ADD "HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main" /V "DisableScriptDebuggerIE" /T "REG_SZ" /D "no" /F
::Start %CDROM%\WPI\wpi.exe

::all processing finished, delete used files, and EXIT::
:CLEANUP
IF EXIST %windir%\Setup\scripts RD /S /Q %windir%\Setup\scripts >nul
DEL /F /Q %0% >nul
exit

Here is the deal. When I'm integrating updates with updates-x64.bat file, it shows me couple of errors in cmd. But then errors stops and it is mounting image, integrating updates etc....

Then, when I install Windows, after the regional settings window it shows "Windows is finishing installation" window and here it stuck... It seems to be loading something, but I is stuck on this window for a hour or two.. maybe longer.. After two hours I've turned it off, because I hasn't time for it...

Can someone help me with this?

Link to comment
Share on other sites

So here is dsim.log file. :)


http://www.armino.6f.sk/ftp/dism.log

And that error numbers.. So for example 3, 87, 50. This are top three of showed errors.

//EDIT

So I have got error 0x800f082e.

errorsl.png

Is it trying to say that update KB2533552 is not possible to integrate this way?

//EDIT Nevermind... I downloaded DSIM from here and it is OK. And Windows is installing well. :)

Edited by ArMinO
Link to comment
Share on other sites

Well, I still have a problem integrating this update (KB2533552). I have it set in the 'setupcomplete.cmd' file. It is the only item that gets installed there. After Win7 setup is done "Finalizing Setup", it throws up a dialog box to "restart now or later". This is the command used:

start /wait %windir%\system32\wusa.exe %CDROM%\apps\Windows6.1-KB2533552-x64.msu /quiet /norestart

It is *supposed* to be quiet when this update is installed. It does not appear to be. Any work-a-rounds for this issue?

Link to comment
Share on other sites

I don't see this when I install W7 from HD. My SetupComplete.cmd in \windows\setup\scripts\ runs using the runonceex process for the KB fix install. I'm only doing X86 though.


.
.
.
REG ADD %KEY%\150 /VE /D "Installing KB2533552 (no wim integration)" /f
REG ADD %KEY%\150 /V 1 /D "wusa Z:\$DXi\Addons\W7AUfor05\Windows6.1-KB2533552-x86.msu /quiet /norestart" /f

rundll32.exe c:\Windows\System32iernonce.dll,RunOnceExProcess
Exit

.

Edited by click-click
Link to comment
Share on other sites

As it turns out "Lurker", there is not an issue with that update. The problem appears to be with the update integration process itself (or some other variation there of). As it is, I must now figure out why the setup process waits until the end to display that message.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...