Jump to content
Sign in to follow this  
mooms

Bug with nLite [registry_addreg] ?

Recommended Posts

Hello

I use a entries_.ini file to add custom tweaks with nLite

(view http://www.nliteos.c...registry_addreg if you don't know what i'm talking about)

The problem lies in this line:

HKCU,"Software\Microsoft\Internet Explorer\SearchScopes\{1C5F694D-B965-4AEA-AF33-8906DFBC21E4}","URL",,"http://www.google.fr/search?hl=fr&q={searchTerms}+&meta="

Becomes this in hiveset.inf, HIVEDEF.INF and nlite.inf (also, why nLite add the keys to all these files? nlite.inf is enough....)

HKCU,"Software\Microsoft\Internet Explorer\SearchScopes\{1C5F694D-B965-4AEA-AF33-8906DFBC21E4}","URL",,"http://www.google.fr/search?hl=fr&q={searchTerms}

As you can see, nLite truncate the end,(+&meta=" ), resulting in an error at the text mode stage of the install:

mini_111004082215622243.png

If i manually edit nlite.inf to add my tweaks, everything works fine, but that's a hassle to do this at each integration.

So, is this a know bug or limitation of nLite?

Can i avoid that ?

Thanks.

Edited by mooms

Share this post


Link to post
Share on other sites

Thanks for the answer ricktendo64, that's also my guess.

I have finally made an addon with an inf file which does the addreg. Works well.

And that don't "pollute" all these inf files like nLite do when using [registry_addreg]

I really don't understand why nLite duplicate the entries in all those files when nlite.inf is enough to do the trick.

But i have a little cosmetic glitch caused by my inf addon:

it sow up in this window: (don't know the name in english, must be add/remove components)

111005051742641760.png

here is my addon:

http://www.mediafire...zjh6jso957ngqn3

Can you tell me why it shows up there ? i can't find the mistake in the addon....

Regards.

Edited by mooms

Share this post


Link to post
Share on other sites

Allright, so [Optional Components] must match the name in sysoc, got it.

I have updated the addon to clean sysoc and delete inf and pnf, files after install.

Could you tell me if i'm doing it right ?

here is the new addon:

http://www.mediafire.com/?7ap4z2j64ccvfse

Thanks Rick, have a good day !

Edited by mooms

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...