Jump to content

[Slim] .NET Framework 4 Full x86/x64 (1-10-2016)


ricktendo
 Share

Recommended Posts

Yes but it might take some skill

You may have to use InstEd to generate a new package code GUID for the second lang pack installers, they take on the last GUID from the last hotfix that was integrated into them...since I integrated the same hotfixes into both they have the same package code

5cf8e451cd.png

I followed yr instructions to build an with 2 Slimp LP (French and Hecrew). I tested it, as you can see on the imafe bellow .Net Framwork Client Profile HEB Language Pack was not installed.

In fact, I did generate a new package code GUID for the .Net Framwork Extended HEB Language Pack (KB971891) but NOT for the .Net Framwork Client Profile HEB Language Pack (KB2600211).

Will I have to generate a new package code GUID for the .Net Framwork Client Profile HEB Language Pack (KB2600211) too?

Regards

post-19145-0-67569400-1337087312_thumb.j

Link to comment
Share on other sites

  • 3 weeks later...

Rick... thanks for the update and I hope I'm not being a dope with this question but as much as I have searched I'm still not clear on whether or not to install the extended version... is there any performance degradation if I just install the full/extended? Could you shed some light on this? Thanks in advance...

Link to comment
Share on other sites

compstuff,

The .NET Framework 4 Client Profile does not include the following features:

* ASP.NET v4

* Advanced Windows Communication Foundation (WCF) functionality

* .NET Framework Data Provider for Oracle

* MSBuild for compiling

These features are added with the extended module. (full dotNET4)

There is NO performance degradation involved.

Edited by jaynbe
Link to comment
Share on other sites

Thanks... I had been leaving the extended out but now I am changing to adding the whole thing

compstuff,

The .NET Framework 4 Client Profile does not include the following features:

* ASP.NET v4

* Advanced Windows Communication Foundation (WCF) functionality

* .NET Framework Data Provider for Oracle

* MSBuild for compiling

These features are added with the extended module. (full dotNET4)

There is NO performance degradation involved.

Link to comment
Share on other sites

I don't think you need to integrate KB2468871 v2 stub if you integrate the latest hotfix KB2468871v2.msp to satisfy WU, unless hotfix KB2468871v2 is superseded by another hotfix.

Link to comment
Share on other sites

Integrating NDP40-KB2468871.msp will not satisfy WU because it checks for the entries the installed msp of KB2468871 would leave behind (just trust me on this)

BTW KB2468871 stub is not integrated, I integrate the original NDP40-KB2468871.msp to update the files and add my stub with the /update switch to install side X side with the msi's

Link to comment
Share on other sites

Hey there guys, I tried this package and I got an error message. I used this switch "dotNetFx40_Full_x86_x64_SlimSetup.exe" /y and I had to click Next button to start the setup and when the setup started, I get an error message. Anyone else seeing this. Maybe I am using the wrong switch, any thoughts?

Link to comment
Share on other sites

Hey there guys, I tried this package and I got an error message. I used this switch "dotNetFx40_Full_x86_x64_SlimSetup.exe" /y and I had to click Next button to start the setup and when the setup started, I get an error message. Anyone else seeing this. Maybe I am using the wrong switch, any thoughts?

Make sure to compare your MD5 to the one listed

Link to comment
Share on other sites

Hi I am installing this with the Win Toolkit latest version and I'm using the /y switch , and I have no issues installing, however after checking for updates with M$ I get KB 2656368 and KB2686827 testing on VM x86 so I would imagine I would be getting the same results with x64.

Also I tried using the silent install with /yim switch I believe but it hangs during the installation, I left it to do it's processing, however after 30 minutes I figured it didn't do anything.

Is anyone else missing the last 2 updates after doing an install ?

Thanks

Gary

Link to comment
Share on other sites

The switch I think you are referring to is /ain and no it does not hang, ngen is doing its thing...

I'm pretty sure you don't actually have the latest one, verify your file with the md5 checksum listed on the first post or right click the installer, choose 'properties', then the 'details' tab and see what 'product version' is listed...it should say "6.12.2012.1"(=June 12 2012 rev1)

Link to comment
Share on other sites

Ok thanks my version is 6.12.2012.1 , strange, I'll download it again and try it,

Oh my bad , the switch is /ain I left running for over a half hour or more, I don't recalling it taking that long to install, but I rather take care of the updates first though.

Thanks for the fast reply.

Gary

Link to comment
Share on other sites

Back from some time off ^_^

I see, new things to play with :P

What we miss now is just Rick's dual-arch installer for Adobe Flash (IE & FF) and DirectX June 2010 :beerchug: :rolleyes:

Keep up the GREAT work :prop:

Edited by felix3650
Link to comment
Share on other sites

  • 3 weeks later...

Thank you very much... :prop: I got error in installation (after integrated lp) with 7-zip Alpha 9.28 "Install method not supported", I uninstall 7-zip and install version stable 9.20, create slim pack again and work perfect...

Regards... ;-)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...