Jump to content

The Little Things


Eric666
 Share

Recommended Posts

Well, since you ask... :grin:

1) AIO Tool, Services tab, button 'Black Vipre's': if you hoover the mouse over it, it will show the tooltip for the Preset button.

2) Same tab, button Restore Default: the tooltip shows 'Unchecked', imo that should be 'Unchecks'

Regards, Eric666

Edited by Legolash2o
Link to comment
Share on other sites

AIO Tool, first screen. Button choices are Browse DVD and Browse WIM. That kind of implies that you can't browse your HD or USB.

Done: Changed them to Browse for DVD and Browse for WIM, also they both now have tooltips.

Edited by Legolash2o
Link to comment
Share on other sites

...and some more really minor stuff:

Toolkit Main window:

- Forum button: the text is not centered vertically

- Donate button: the icon is not centered vertically

- [Test Code] button visible

- Popular tab: Text in AIO and Solor buttons seems to deviate from the other buttons (bigger/ Bold) Done on purpose

- Tools tab: Text in buttons Addon Maker, Cab retriever, Capture image and LP converter is smaller

Regards, Eric666

And something I noticed: the tooltips for all buttons are shown instantaneously, some delay, say 500ms would be nice. [-> if needed, can be put in the requests thread]

Edited by Legolash2o
Link to comment
Share on other sites

Some component descriptions, the meaning or risks of which I currently can't grasp even with help from Google:

  • Mobile PC Client Components Basic / Premium
  • Printing Premium Tools
  • Windows (Sidebar) Killbits

I don't know what they are either :(

If you know what they do, perhaps you could write it down? And maybe someone could tell us what the Avalon effects do? :D

Also, in the Silent / SFX tab, moving installers up or down the queue is rather counter-intuitive. If you move the last installer in the 'Always' category upwards, it magically teleports to 'Prompt' category! Keep pressing the upwards button and you'll be thrown back to 'Always' category.

Edited by Legolash2o
Link to comment
Share on other sites

What do you recommend it say instead?

Sorry, was out for awhile.

Maybe say on the button and/or the tooltip WHAT you are browsing for rather than WHERE, since the box that opens will let you navigate anywhere on your system. ie "Browse for Folder" or "Browse for WIM" or whatever is more clear. Just a thought. Someone else might have better words to suggest.

Done: Check your original post, change to 'Browse for WIM' and 'Browse for DVD', i've also added tooltips.

Edited by Legolash2o
Link to comment
Share on other sites

If everyone would like to check their posts, EVERYTHING has been done so far. Keep them coming, i need more :P

Some component descriptions, the meaning or risks of which I currently can't grasp even with help from Google:

  • Mobile PC Client Components Basic / Premium
  • Printing Premium Tools
  • Windows (Sidebar) Killbits

If you know what they do, perhaps you could write it down? And maybe someone could tell us what the Avalon effects do? :D

I don't know them either, so someone can feel free to share what they are :P

Also, in the Silent / SFX tab, moving installers up or down the queue is rather counter-intuitive. If you move the last installer in the 'Always' category upwards, it magically teleports to 'Prompt' category! Keep pressing the upwards button and you'll be thrown back to 'Always' category.

Thanks, fixed!

------------------------------------------------------------------------------------------------

Hey guys, as a reward for helping i've managed to add something new to the component removal

Remove Speech Support and Natural Language, so far i've got it to remove:

x64: 890MB

x86: 590MB

Keep these mini-reports coming....

Edited by Legolash2o
Link to comment
Share on other sites

This one is maybe plain stupid, but when pressing the Check for W7T Updates button, while already having the latest version, everything flashes once, and that's it. A messagebox 'You already have the latest version' or something alike would be more clear imo.

Regards, Eric666

-----------------------------

Done, thanks.

Edited by Legolash2o
Link to comment
Share on other sites

There are at least two BIG things that I'd like in W7T before 1.3.0 comes out - sorry to be a llitle offtopic. :)

1. A working unnatended with the ability to Auto-Select Language, Locale, Keyboard Locale (as requested by Chares here back in may);

2. that ability to slipstream multilanguage drivers you've made me drool about last week :D

Also, adding some GREAT tweaks from here would be a BIG bonus also :D

Link to comment
Share on other sites

There are at least two BIG things that I'd like in W7T before 1.3.0 comes out - sorry to be a llitle offtopic. :)

1. A working unnatended with the ability to Auto-Select Language, Locale, Keyboard Locale (as requested by Chares here back in may);

2. that ability to slipstream multilanguage drivers you've made me drool about last week :D

Also, adding some GREAT tweaks from here would be a BIG bonus also :D

Wrong place, this is not for requests but for little things like some of the examples mentioned in the first post :P

Link to comment
Share on other sites

Another oddity: when I select Component Removal and then an Image to mount, the mounting shows a steady progress, np. However, when Getting Packages/Making visible etc is displayed, the W7T Taskbar icon just disappears. It only reappears after dismounting the image. This is using the latest v65.

Regards, Eric666

Link to comment
Share on other sites

In the options window for "Main" - although I haven't changed any settings it says - "All the new settings you have selected will not be saved" .

Disable the transparency by default as it shows other app's/window's text,making it look ...

And there are still mistakes on tooltips of "force unmount" & "gadgets".

Done.

Edited by Legolash2o
Link to comment
Share on other sites

Another oddity: when I select Component Removal and then an Image to mount, the mounting shows a steady progress, np. However, when Getting Packages/Making visible etc is displayed, the W7T Taskbar icon just disappears. It only reappears after dismounting the image. This is using the latest v65.

Regards, Eric666

I can't seem to reproduce this issue and i have no code which specifically requests the taskbar icon to disappear.

In the options window for "Main" - although I haven't changed any settings it says - "All the new settings you have selected will not be saved" .

Disable the transparency by default as it shows other app's/window's text,making it look ...

And there are still mistakes on tooltips of "force unmount" & "gadgets".

Done.

Done. Thanks.

Link to comment
Share on other sites

Lego,

It may have to do with my W7x64 Pro... or maybe the handover to dism for retrieving package info? Never mind, I'll check with newer version if the problem still occurs.

Regards, Eric666

Edit:

- After selecting an image, mounting starts, the taskbar icon flash off and on once

- After mounting reaches 100%, Making Packages Visible is shown. At this exact moment the taskbar icon disappears

- After closing Component Remover tool, I select Discard. It shows Discarding Image

- As soon as the progress for discarding is starting, the taskbar icon is shown again

I'll also check this evening on my Win7x32 HomeP machine

Edited by Eric666
Link to comment
Share on other sites

W7T Options -> Main

1) Choose what language W7T displays -> Choose which language W7T displays ??

2) The description for Check images starts with /check.. could be changed to Check instead.

Also this entry is the only one with a tooltip, but the tooltip shows exact same text as the description. So either the description could be shorter, using the tooltip for a more expansive explanation or the tooltip could be removed altogether.

3) Entry Auto Save and Unmount's description contains a few typos: seleted -> selected; save -> saves; unmount -> unmounts

Regards, Eric666

-----------------------------------

2) The tooltip is done automatically when the description does not fit on the page, this saves the user from scrolling to see what it says. It's done by default.

Edited by Legolash2o
Link to comment
Share on other sites

Lego,

It may have to do with my W7x64 Pro... or maybe the handover to dism for retrieving package info? Never mind, I'll check with newer version if the problem still occurs.

Regards, Eric666

Edit:

- After selecting an image, mounting starts, the taskbar icon flash off and on once

- After mounting reaches 100%, Making Packages Visible is shown. At this exact moment the taskbar icon disappears

- After closing Component Remover tool, I select Discard. It shows Discarding Image

- As soon as the progress for discarding is starting, the taskbar icon is shown again

I'll also check this evening on my Win7x32 HomeP machine

I can't see it, my computer is probably too fast :P or maybe it's just an XP issue. Let me know when you've tested it on your Win7 machine. Thanks.

W7T Options -> Main

1) Choose what language W7T displays -> Choose which language W7T displays ??

2) The description for Check images starts with /check.. could be changed to Check instead.

Also this entry is the only one with a tooltip, but the tooltip shows exact same text as the description. So either the description could be shorter, using the tooltip for a more expansive explanation or the tooltip could be removed altogether.

3) Entry Auto Save and Unmount's description contains a few typos: seleted -> selected; save -> saves; unmount -> unmounts

Regards, Eric666

-----------------------------------

2) The tooltip is done automatically when the description does not fit on the page, this saves the user from scrolling to see what it says. It's done by default.

Good work, thanks.

Link to comment
Share on other sites

I can't see it, my computer is probably too fast :P or maybe it's just an XP issue. Let me know when you've tested it on your Win7 machine. Thanks.

No XP here, current location W7 Pro x64, and @home W7 HomePremium x32. Might be a memory issue though, x64 machine has only 2Gb memory and is not the fastest on earth :g:

2) The tooltip is done automatically when the description does not fit on the page, this saves the user from scrolling to see what it says. It's done by default.

I see, seems like a good option anyway.

Good work, thanks.

Most welcome, just trying to push you to start working on 1.4.0 :icon_cool: I like the initiative, this kind of small enhancements give the application a finished look.

Keep up the good work!

Regards, Eric666

Link to comment
Share on other sites

You asked for grammar - well now you got it!

I think the language on the start screen is a bit inconsistent. On one button, AIO is used, while on the other All-In-One is spelled out. Maybe using All-In-One throughout would be better. Also, I would rename 'Create AIO Disk' to 'AIO (or All-In-One) Disk Creator' to fit in better with Maker, Manager, Editor etc.

Moving on to the Tweaks section, where the dragons be.

  • I propose losing the hyphens: Context-menu > Context Menu (both the category name and in every tweak); Start-up/Shutdown > Startup & Shutdown
  • Maybe remove 'Logon' and move items to 'Startup & Shutdown'? And maybe remove 'Firewall' and 'Windows Media Player' and move items to 'Misc'? I just don't see the point in having a separate category for 3 items - unless you have plans for adding items, ofcourse.
  • Also, double, single and no quotation marks are used all over the place - I propose changing them all to single.

'Context Menu' section.

  • I suspect 'God mode' and 'All tasks' are referring to the same thing, but I'm not certain as I cannot see their registry entries. If they are in fact the same, I suggest leaving only one - 'All Tasks' (as 'God Mode' is clearly arbitrary). Or if you want to be hip, name it 'W7T Mode'!
  • Can't be bothered: I know this thread is not for feature requests, so let's consider this as an upgrade to an existing feature. I suggest merging 'Admin Tools', 'Manage' and 'Services' into one neat cascading 'Administrative Tools' context menu.

  • I also suggest merging 'Take Ownership' for files/folders (see here).
  • Also, are 'Task Manager' and 'Programs & Features' added to Desktop or Computer menu or somewhere else? I suggest moving them to Desktop menu, if not already there.
  • Can't be bothered to remove, someone will complain there isn't one anyway: Is there really need for tooltips as all the items are quite self-explaining?

So in my mind the list should be as follows.

  • Add 'Copy To Folder...' to context menu
  • Add 'Move To Folder...' to context menu
  • Add 'Defragment' to Desktop context menu
  • Add 'Programs & Features' to Desktop context menu (make sure it actually uses Desktop!)
  • Add 'Task Manager' to Desktop context menu (make sure...)
  • Add 'Open CMD Here' to Folder context menu
  • Add 'Open Elevated CMD Here' to Folder context menu
  • Add 'Take Ownership' to File and Folder context menu
  • Add 'Unpack' to *.msi files context menu
  • Remove 'Add to Windows Media Player list' from context menu
  • Remove 'Print' from context menu
  • Remove 'Troubleshoot Compatibility' from context menu

Desktop:

  • First of all: remove the Avalon effects thingy. It turns out to be a tweak used to enable some half-baked eyecandy back in the days of Longhorn still being developed on top of XP codebase.
  • Maybe consider removing or at least hiding 'Disable Feedback Tool' for the time being. Surely nobody uses Windows 7 beta any more. Maybe enable it again when Windows 8 beta comes out.
  • Can't be bothered to remove, someone will complain there isn't one anyway: Here too, tooltips seem redundant.
  • Delay Aero Peek 500ms
  • Display Gadgets when UAC off
  • Large Taskbar previews
  • Small Taskbar icons
  • Unlock Taskbar
  • Combine buttons only when Taskbar is full
  • Remove Action Center icon
  • Show 'Computer' on Desktop
  • Show 'Control Panel' on Desktop
  • Show 'Network' on Desktop
  • Show User Folder on Desktop

Should I continue?

1) Choose what language W7T displays -> Choose which language W7T displays ??
How about simply 'Choose your language'? :) Edited by Legolash2o
Link to comment
Share on other sites

Lego,

I've checked all stuff I reported before and all has been fixed in v66, except for the

seleted -> selected in Options-> Main -> Auto Save and Unmount entry's description.

I've also tested the disappearing taskbar icon issue @home (Win7HomePremium x32) and I see the exact same behaviour as before. Your suspicion might be correct: this is not a fast machine, and the Package Retrieval from WIM takes some time, say a minute. If I recall correctly, you have 8 Gb and SSD on board, so you do not have to wait long. The reappearance of the icon at the exact same time as starting displaying the progress for discarding the image might be a window refresh of some sort? It is not a big deal, since in my case W7T can still be accessed using alt-tab.

Regards and keep up the good work, Eric666

Edited by Legolash2o
Link to comment
Share on other sites

...and yes! Works now without disappearing taskbar icon. I also see now colored progress for mounting (yellow) and unmounting (red) in the taskbar entry, which was not present before in v66. I like this progress visibility, since it allows one to switch to something else while waiting and still keep an eye on things.

Well done Lego!

Link to comment
Share on other sites

Meaning the disappearing taskbar icon? Frankly, I've not been mounting images for a month or so, since I was able to make an image which satisfied my needs (clean install of W7HPx32 on my laptop). So the problem could have been introduced some time ago. It's because of your Little Things request that I started testing more thoroughly again and noticed the icon issue, which was at least reproducible...

Regards, Eric666

PS Time to stop for me now, will check forum tomorrow

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...