Jump to content

Windows 7 Toolkit v1.3.0


Legolash2o
 Share

Recommended Posts

Hi, @Legolash2o

We know that Net Framework 4.0 is needed to make W7T work. Here is my qustion: Does W7T need both packs (Client + Extended packages) or is it sufficient only to have Client packages installed in the system?

Link to comment
Share on other sites

Which is already included in Win7. .NET 4.0 does not necessarily replace the previous versions of .NET, and the added features of .NET 4.0 are not needed for W7T.. So what you're really saying is:

"Don't remove .NET and expect W7T to work."

Correct? Or if you remove the existing .NET 2.0, 2.5, 3.0, and 3.5 BUT install .NET 4.0, if that is possible, will W7T work correctly?

Cheers and Regards

Edited by bphlpt
Link to comment
Share on other sites

All i know is that i've set W7T to work with .NET 2.0 :)

Not that I am complaining or anything, would it be possible to make it compatible with .net 3.5 or even 4.0? (If possible, just remove the .net 2.0 restriction?)

Link to comment
Share on other sites

I'm not sure if Legolash2o coded it to require 2.0 or 2.0 minimum. It depends if he checks for existence of/in a particular folder/reg key, or existence of a particular function. Besides, Win7 includes all versions of .NET except 4.0 already, and even in XP the standard installer for 3.5 includes 2.0 and 3.0. Are you one of those that removes parts of .NET that you don't think you will need, crashfly? if so, you could be a perfect person to tell us if W7T will work without .NET 2.0 installed. If you don't remove any parts of .NET, then I'm curious why you asked the question.

Cheers and Regards

Link to comment
Share on other sites

I'm not sure if Legolash2o coded it to require 2.0 or 2.0 minimum. It depends if he checks for existence of/in a particular folder/reg key, or existence of a particular function. Besides, Win7 includes all versions of .NET except 4.0 already, and even in XP the standard installer for 3.5 includes 2.0 and 3.0. Are you one of those that removes parts of .NET that you don't think you will need, crashfly? if so, you could be a perfect person to tell us if W7T will work without .NET 2.0 installed. If you don't remove any parts of .NET, then I'm curious why you asked the question.

Cheers and Regards

My reasoning behind the question was purely academic. In my opinion, I think it is a better program that can be written to support most any .net you have installed instead of specifically requiring a certain version. I have not gotten to the point where I removed the "lesser" version of .net, but I consider it if that would help contribute to the programs development.

Link to comment
Share on other sites

Hi, @Legolash2o

For adding what type of files can w7t "all in one" "files" be used? For example, can nlite and rvm addons, silent switchless addons or switchless installers be added from here?

What is "files" tab used for?

Link to comment
Share on other sites

Hi Legolash2o,

I have a question: what do the tweak "disable IPV6" do exactly ?

Because i have used it on my installation, and now my firewall (Outpost) keep asking me for tcpv6 connections on boot by "System" and it's the first time it did that.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...