Jump to content

"Setup cannot continue due to a corrupted installation file."


Recommended Posts

I tested it on virtual box and it always shows this result (when it goes to "installing updates"): post-34299-0-68233500-1334039330_thumb.j

I'd disabled the anti-virus software when I used AIO integrator.

Here is my last session:

2012-04-09_23-06-24_2012-04-09_23-06-24.ini

Maybe it is the problem of ISO maker? I haven't tried other installation methods (eg., WinNTSetup http://www.msfn.org/board/topic/149612-winntsetup-v21/)

Or maybe I integrated too many updates?

Thanks in advance.

Link to post
Share on other sites
  • 1 month later...

Same problem here. I integrated every update and removed pretty much every single package I could from Windows... likely one of those is the cause. It is a shame really, I want a completely lean stripped install of Windows 7 and Win Toolkit is the only tool that allows me to truely do so, but something appears to go wrong when such a drastic change to Windows is made. I cannot stand all of the fluff included with Windows 7 by default.

Link to post
Share on other sites

Thank you for the reply. My installation was never compiled to an ISO, for I directly copied the working folder to a bootable USB drive. I have a theory that perhaps I may have installed updates that were not applicable to my version of Windows (7 SP1 ULTIMATE), unless of course Win Toolkit checks for that and does not inject them?

By the way, I must add, Win Toolkit is a very nice program--thank you for taking the time to make it Legolash2o.

Edited by SvalinnAsgard
Link to post
Share on other sites

Thank you for the reply. My installation was never compiled to an ISO, for I directly copied the working folder to a bootable USB drive. I have a theory that perhaps I may have installed updates that were not applicable to my version of Windows (7 SP1 ULTIMATE), unless of course Win Toolkit checks for that and does not inject them?

By the way, I must add, Win Toolkit is a very nice program--thank you for taking the time to make it Legolash2o.

Please use IMGBURN for make iso file. Imgburn is the best program to make iso file without problem.

Link to post
Share on other sites

No need to make an ISO if one is using a bootable flash drive. The Win Toolkit documentation states that once the flash drive is made bootable, the source image can simply be copied as is, which is very nice I might add. I am giving Win Toolkit another try, does anyone have any suggestions about how to quickly download only the Windows updates your image needs?

Link to post
Share on other sites
  • 1 month later...

Hi,

I do have the same error when installing my new Vaio... Is there anybody, who solved it already? I tried it around 15 times, 15 times different contents included. Only the first image I did was installed OK, but I found later on that I forgot to include IE9 and that there was some incompatibility in the system due to my "enhancements" so it was not possible to install it later. So I rebuilt my Windows source and since that time I am not able to pass over this error. Interesting is, that ca. first 7 images I did with RT7lite, resulting in 1 good and 6 bad installations. Next ca. 7 images I tried with Win Toolkit and produced just erroneous installations. Everytime I used updates downloaded by WUD and Win 7 x64 with SP1 Enterprise version as a source (the legal one...), no LDR option.

The installation sources were done on the same PC as the target one is (Sony Vaio SVZ), but what I'm thinking about now, during writing this post, that there are only W7 Home Premium installed and lot of crapware on that notebook so if there's something incompatible...

Any hint?

Link to post
Share on other sites

Hi,

I gave up customizing windows 7 since there are too many updates to integrate. Instead, I customize win 8 RP, on another OS (I guess my original problem was related to my old OEM-full-of-bloatware win7, so I switch to another clean installed VHD native boot win7/win8 system to run WinToolkit), and it worked without any problem.

There are only 5~6 updates to integrate for win 8 RP, so it is REALLY fast.

Edited by testplayer
Link to post
Share on other sites

By the way, if you want to use UEFI boot, avoid the "USB/DVD download tool", since it will format your flash drive to NTFS, which cannot be recognized by the UEFI firmware environment. What I did is just formatting my flash drive to FAT32, and copy all files inside of the ISO or DVD root folder to the flash drive, and then UEFI firmware environment will recognize that FAT32 partition and look for \efi\boot\bootx64.efi, and that's it, no need to edit those awful boot sectors and set "active" partitions.

Link to post
Share on other sites

Hmmmm I never knew that and I work with Enterprise every day and with all my integrations

I need to post as a side note here a thought:

Why if you can afford a few thousand for the licensing of Enterprise windows are you customizing the crap out of it?

That actualy breaks your agreement with MS you made when you got your mak licensing.

Link to post
Share on other sites

I need to post as a side note here a thought:

Why if you can afford a few thousand for the licensing of Enterprise windows are you customizing the crap out of it?

That actualy breaks your agreement with MS you made when you got your mak licensing.

Well, I never use MAK activation. Instead, I got my windows 7 enterprise copy from my boss and used KMS activation server of my company.

Link to post
Share on other sites

That is the tool I use for all my work.. I am trying another one in the next few days because I seem to have a problem using USB drives larger than 8 GiG

Hey, I use Universal USB Installer for every single "system-installation-to-USB" work. Sure, it's focused on Linux distributions but at the bottom of your choices there are Windows Vista/7/8 Installer options. And the drive path is always formatted into FAT32.

Works for me. Give it a try and tell me what you think.

Link to post
Share on other sites
  • 2 weeks later...

Finally, the problem may be solved, if anybody can confirm: it might not be possible to modify "higher" Win version on "lower" Win version, ie. customize Ultimate installation on Home system. I tried to use the same files and config file and same installation of WinToolkit on different PCs with just Win7 Enterprise and everything worked flawlessly...

Link to post
Share on other sites
  • 3 years later...

its not due to updates integration, its due to component removal, when you remove files that the OS needs it will give you that error, I tested this with vmware and now it works without selecting any components to remove? weird thing about it is it should work even when you remove certain components.. I'm talking about the legend colour code ,red, green, yellow, what exactly do these mean? would be helpful to have a little legend up the top stating what the colours mean

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Similar Content

    • By hkroiss
      Hi, since around 1.5 half years i am integrating Updates into our Windows Image at our Company. However i have noticed that even when all the latest Updates are integrated after installing the OS it shows a few ".NET Framework" Updates that couldn't be integrated (see Attachment). A year ago it were only around 10, now around 15. So its getting more and more, it hinders the usfulness of the Slipstreaming process a bit.
      Did anyone of you find a way to integrate this pesky ".NET" Updates into the Image?
      Thanks for the help.

    • By jakson
      I want to integrate last upadates into Windows 7 SP1-U ISO and I have two doubts:
      1. Does KB3172605 (July 2016 update rollup) replace KB3156417 (May 2016 update rollup)?
      2. Integrate KB3170455 (update for Windows Print Spooler)? Supposedly it stops non-admin users from installing a network-printer :/
      What set of updates is the best to integrate (KB in exact order):
      KB3020369 kb3125574-v4 KB3168965 KB3172605
      KB3020369 kb3125574-v4 KB3156417 KB3168965 KB3172605
      KB3020369 kb3125574-v4 KB3156417 KB3168965 KB3170455 KB3172605
      ?
      KB short descritpion:
      KB3020369 April 2015 servicing stack update for Windows 7 and Windows Server 2008 R2
      KB3125574 Convenience rollup update for Windows 7 SP1 and Windows Server 2008 R2 SP1
      KB3156417 May 17 2016 update rollup for Windows 7 SP1 and Windows Server 2008 R2 SP1
      KB3168965 July 12 2016 Security Update for Windows Kernel-Mode Drivers
      KB3170455 July 12 2016 Security Update for Windows Print Spooler Components
      KB3172605 July 21 2016 update rollup for Windows 7 SP1 and Windows Server 2008 R2 SP1
       
    • By PsycH0Ooo
      Hello Everybody
       
      I have a Problem with the Updates i would like to intergrate some updates in my install.win but the Problem ist, that if i would like to intergrate the updates the mark are yellow and not green. On the state the say me install pending. If i install a Windows machine with the iso the updates are not installed but why ?
       
      Its a Windows 7 ISO.
      If i would like to intergrate the Updates with the Updates installer, and i add all updates that i would intergrate to my install.wim file it says Not compatible with 10240 : "and the source to my update"
      What did i make not correctly ?
       
      Best regards PsycH0Ooo
       

    • By Guppy
      Good evening everyone!
       
      I've been using WinToolkit since a lot of years to integrate updates in Windows Installations. Recently I redid my Win7 x64 Installation. I removed the ei.cfg and integrated all major "General" "Security" and "Hotfix" Updates. After integrating I created an ISO and started it in a virtual Machine. But upon booting it only says 
       
      CDBOOT: COULDN´T FIND BOOTMGR
       
      I don't know what the problem is, especially since my x86 Version started without any issues and in the past there was nothing comparable. Can you tell me what might have went wrong and how I can fix this? 
       
      Thank you for all suggestions in advance and have a nice day!
       
       
       
    • By glowdude
      Host OS: Windows 7 Ultimate x64
      Image OS: Windows 7 x64
      Windows ADK for 8.1 installed: Yes (I used this link http://www.microsoft.com/en-us/download/confirmation.aspx?id=39982)
       
      In WinToolkit v1.5.3.12, when I add the kb2603229, kb3035126, kb3035132 they show up and the program says they are integrated.
       
      But when I test the image, Windows updates says they are not integrated.
       
      They are integrated when I use the dism command in cmd.
×
×
  • Create New...