Jump to content

[AIO] Microsoft Visual B/C++/F#/J# Redistributable x86/x64


Recommended Posts

New version available :rtfm:

Visual C++ 2013 x86 12.0.30501

Visual C++ 2013 x64 12.0.30501

Only the setup wrapper is v30501, the msi version and file versions contained are v21005, you can view this by opening regedit and checking this key

Link to comment
Share on other sites

7z much better, can verify md5, size and date, better all ups be 7-zip



All that can be done with .exe also. Besides this is supposed to be a installer NOT a archive...

Kels, did you even bother to look inside the 7z? (don't kick yourself too hard now :P)

Explanation: I am not allowed to host EXE files on this donated FTP space

Link to comment
Share on other sites

extra are the older runtines you see listed under "Also Includes" spoiler

name            version/*-- Microsoft Visual Basic Runtimes -----------------------------------*/ comct232.ocx   picclp32.ocx*-- Microsoft Visual Basic Runtimes (16bit) ----------------------------*/vb40016.dll        <none>vbrun200.dll*-- Microsoft Visual Basic Virtual Machine -----------------------------*/msvbvm50.dll*-- Microsoft Visual C Runtimes ----------------------------------------*/atl70.dll        7.0.9975.0atl71.dll        7.10.6119.0mfc70.dll        7.0.9975.0mfc70chs.dll        7.0.9975.0mfc70cht.dll        7.0.9975.0mfc70deu.dll        7.0.9975.0mfc70enu.dll        7.0.9975.0mfc70esp.dll        7.0.9975.0mfc70fra.dll        7.0.9975.0mfc70ita.dll        7.0.9975.0mfc70jpn.dll        7.0.9975.0mfc70kor.dll        7.0.9975.0mfc70u.dll        7.0.9975.0mfc71.dll        7.10.6119.0mfc71chs.dll        7.10.6119.0mfc71cht.dll        7.10.6119.0mfc71deu.dll        7.10.6119.0mfc71enu.dll        7.10.6119.0mfc71esp.dll        7.10.6119.0mfc71fra.dll        7.10.6119.0mfc71ita.dll        7.10.6119.0mfc71jpn.dll        7.10.6119.0mfc71kor.dll        7.10.6119.0mfc71u.dll        7.10.6119.0msvci70.dll        7.0.9955.0msvcp70.dll        7.0.9466.0msvcp71.dll        7.10.6052.0msvcr70.dll        7.0.9981.0msvcr71.dll        7.10.7031.4msvcrt10.dll        <none>
Link to comment
Share on other sites

Hi Rick,


Will the exe inside the download file work as an addon in RyanVMI?


Or do I feed the 7z as downloaded to RyanVMI? I think it has to have the name "_Addon_" in there somewhere??


What type of exe is it?  I never saw that icon before.  Pretty cool.


Also, can I expand the exe (7z again), remove x64 folders, repack with 7z, rename to add "Addon" and finally ... then will it work as an addon in RyanVMI?



Edited by molecule
Link to comment
Share on other sites

thanks Rick!


I'm trying to make an Addon of the dotNET Framework 1.1.sp1 updates for Server 2003 sp2. It may seem off topic, but there's apparently an intersection between .NET 1.1sp1 and VC7 runtime dll.


Unlike the installers for .NET 2 and above, the installers for .net 1.1sp1 are old inf type-1 installers  DXUPAC packs them just fine, and they integrate.


I tried to install them from the command line. (It works for .net 2 and above, so why not try 1.1?) 1.1sp1 is included in the OnePiece AIO Final. For the command line, the update looks at my XP and says, No deal! These updates are for Server 03, and XP is the wrong system blah blah and stops.


So, I figured I'd try to bypass that by using DXUPAC and integrating them. (The msi type2 patches for .NETs 2 to 4 install straight into XP from the command line, with no problem reported and I checked the installs with the .Net Framework Setup Verification Utility.


In any case when I integrate a DXUPAC Addon using .NET 1.1sp1 updates for Server 03 (default update pack changed to addon in usual way, same as for system updates), the install gives me a red(X) message box -- Title="Aspnet_regiis.exe unable to locate component" and message "This application has failed to start because MSVCR71.DLL was not found. Re-initializing the application may fix this problem." Another msg box follows but it is ordinary, but not during an install, title="Advanced INF Install" msg=You must restart compute before settings take effect. Now? or Later? I choose later, and the install completes just fine.


MSVCR71.DLL is in your earlier Addon (Rick-YumiYao_VC78910_v215) but but the .NET1.1sp1 probably runs before the VC files get registered, or something (noob here just guessing)


In any case, when XP gives me a desktop, I run RegSvr32 MSVCR71.DLL, it finds the file i.e. reports the file was loaded, but that no entry point into the dll was found, so the file cannot be registered. I checked other XP systems adn they all reprot the same problem, but they also all work just fine.


Do you have any thouights on what might be happening?


I'm hoping to find a workaround to get the .NET 1.1sp1 updates for server 03 integrated into an XP source, or manually loaded into XP.. Getting MSVCR71.DLL registered might be a start?


Any thoughts appreciated!

Edited by molecule
Link to comment
Share on other sites

Hi Rick


I just stumbled on this KB for VB6sp6, from a search on mscomctl.ocx, which is needed by MSFN project for building a driver pack by IcemanND <link>




I scanned the old posts in this thread but didn't run across this patch ... it is needed?




=== EDIT ===


It you decide to include -- the following info might help


Running in VisualBasic6-KB896559-v1-ENU.exe on a new XPsp3 with OnePiece AIO and VB5sp6 apparently does not install two files = comctl32.ocx and mscomctl.ocx. As a result, the Driver Backup Utility v2183 by IcemanND reports missing files. When these two files are copied and registred by hand using regsvr32, then the Driver Backup Utility works.


Not sure what to make of this patch -- Should I keep it in my system?



Edited by molecule
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...