Jump to content

[AIO] Microsoft Visual B/C++/F#/J# Redistributable x86/x64


ricktendo
 Share

Recommended Posts

Ok, since this is the only solution, I trimmed your installer and your config.txt to the best of my abilities. The result - a passive installer, that requires no user interaction, and that installs everything except F# & J# (also removed them from the package, so it's also smaller in size) - if anyone's interested, you can find it here.

 

All the credits go to ricktendo, but I didn't wanted to repack his installer, the reason beeing that I can't use SFXMaker anymore for this. Again, please ricktendo, investigate this for the next version, this has never happened to me with any installer that I wanted to make silent with SFXMaker (it always worked with this installer also until ~ month ago / haven't tried it in the last month).

Link to comment
Share on other sites

  • 2 weeks later...

Hello there Guys, just wanted to ask if anyone has seen this issue, with this package. This started to happen with me when WinToolKit started to install the packages during the last steps of Windows Setup. Before the packages got installed after you login to windows and I never had any issues. Can you guys share your fix for this issue, thank you!

  

 

Click Here

 

Click Here

Link to comment
Share on other sites

I don't think any of the current important repacks from ricktendo (.net & this vc/b aio) are compatible with Win Toolkit anymore, at least when using switches in Win Toolkit AIO (under silent installers tab). It's either the new multilingual lines from the setup, or the new SFX. Going to test it this weekend / next week and come back with feedback. :)

 

@ ricktendo Visual Studio 2012 Update 2 is out. Probably some newer VC++ 2012 is also out... :)

Link to comment
Share on other sites

  • 2 weeks later...

I see that you've removed the language lines from the .inf. Now everything is ok with WinToolkit's runonce, it gets the silents switches and everything is installed as it's supposed. Great! :)

 

I didn't check other installers, only .net 4.5 slim and this one. Maybe other addons with language packs may still have this issue with Win Toolkit.

Link to comment
Share on other sites

Maybe I am mistaken, but some weeks ago I thought the config.txt included at the end some translation strings. Maybe I confused the default config.txt with the one from the tools (visualsiosfxmaker).

 

Either way, now the installer (and its silent switches) works / work great with Win Toolkit. SFXMaker 1.3.1 still doesn't, but this is not so important. :)

Link to comment
Share on other sites

I can confirm there is a trouble using Oracle VM and only Microsoft Visual C++ 2005 and C++ 2008 (x86) aren't installed.

BUT on my computer all are installed like I wish ! This is strange because on Windows 7 x64 all works fine on Oracle VM.

Using: Silent "No GUI" SFX alternative v2.9

Cheers and regards

post-23163-0-39809500-1367389032_thumb.g

post-23163-0-84603400-1367389049_thumb.g

Edited by myselfidem
Link to comment
Share on other sites

edit: "operator error"

 

I made it silent installer using   Visual AIO SFX Maker v5 and  Silent "No GUI" SFX alternative v2.9  and I am getting error in vmware. I tried it twice, same results. Any ideas?

Previous version worked OK with  VisualAIOsfxMaker3.8 and VisualAIOsfxMakerNoGUI2.9

 

I always use setupcomplete.cmd to integrate it.

 

btw. I used the VBCFJRedist_AIO_x86_x64.exe  with nothing removed.

 

zayThde.png

Edited by dareckibmw
Link to comment
Share on other sites

I made it silent installer using   Visual AIO SFX Maker v5 and  Silent "No GUI" SFX alternative v2.9  and I am getting error in vmware. I tried it twice, same results. Any ideas?

Previous version worked OK with  VisualAIOsfxMaker3.8 and VisualAIOsfxMakerNoGUI2.9

 

I always use setupcomplete.cmd to integrate it.

 

btw. I used the VBCFJRedist_AIO_x86_x64.exe  with nothing removed.

 

zayThde.png

 

 

In my tests, I saw that the KB2592687, when installed before the Redist package, causes conflict in installation of VC_RedistInstaller_McRip. To work around this, install the KB2592687 by WPI, after VC_RedistInstaller.

 

Do not know if this is your case.

Link to comment
Share on other sites

 

In my tests, I saw that the KB2592687, when installed before the Redist package, causes conflict in installation of VC_RedistInstaller_McRip. To work around this, install the KB2592687 by WPI, after VC_RedistInstaller.

 

Do not know if this is your case.

 

 

Nope, it isn't. I only use hotfixes that shows on WUAnd KB2592687 is being moved to silent section in wintoolkit by default, never have had any conflict with Rick's or anything.

I'll make another test with it tomorrow, who knows what will happen :)

 

 

Edited by dareckibmw
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...