Jump to content
Sign in to follow this  
Rafadecai

Ya no se puede poner en windows 7 tu theme por defecto por archivo de respuesta autounnatended.xml

Recommended Posts

Por alguna razon ya no se puede poner tu theme por defecto a traves de un archivo de respuesta ya no lo apoya.

 

Alguien tiene alguna idea de como hacerlo, se me ha ocurrido lo de renombar mi theme favorito a aero.theme tal como esta el theme que se pone por defecto al instalar el windows 7, no se si esto funcionaria.

Share this post


Link to post
Share on other sites

Ok ricktendo , si fuese un tema aero normal bastaria con renombrar el theme a Aero y el wall paper a img0 y se podria ese por defecto entonces asi no habria problemas me imagino ¿ estoy en lo correcto?.

Share this post


Link to post
Share on other sites

Si es un tema normal (uno con solo wallpaper y color especial) use esto en autounattend.xml (oobeSystem + Microsoft-Windows-Shell-Setup)

 

            <Themes>                <DefaultThemesOff>false</DefaultThemesOff>                <DesktopBackground>%WINDIR%\Web\Wallpaper\Sony\VAIO 09 img1 Wallpaper 1920x1080.jpg</DesktopBackground>                <ThemeName>VAIO</ThemeName>                <WindowColor>Frost</WindowColor>            </Themes>
Esto crea un oem.theme en una parte en %appdata%, talvez reemplazando esto fisicamente, con el que tiene los datos de tu tema especial soluciona tu problema

Pregunta: estas parchando a uxtheme?

P.D. parece que agregar un oem.theme resolvera el problema

http://www.windows-noob.com/forums/index.php?/topic/4722-deploy-windows-7-with-themes-and-aero-enabled/

http://www.myitforum.com/forums/OSD-How-to-set-Corp-backgroundscreensaver-m213992.aspx

Share this post


Link to post
Share on other sites

Si ya parchee uxtheme  este archivo de registro me podria servir para colocar todo por defecto

 

 

 

Windows Registry Editor Version 5.00; set "Brand" details[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\OEMInformation]@="""Manufacturer"="Gigabyte""Model"=-"Logo"="\\windows\\system32\\oobe\\info\\GIGABYTE_BADGE.bmp""SupportPhone"=-"SupportURL"="http://www.Gigabyte.com""SupportHours"=-[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Media Center\Start Menu]"OEMLogoUri"="file://c:\\windows\\system32\\oobe\\info\\GIGABYTE_MCE_LOGO.png"[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winsat\WindowsExperienceIndexOemInfo]"Logo"="\\windows\\system32\\oobe\\info\\GIGABYTE_BAR.bmp""HardwareUpgradeURL"="http://uk.gigabyte.com/support-downloads/support-downloads.aspx"; set "Brand" theme during installation[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Themes]"Drop Shadow"="FALSE""Flat Menus"="FALSE""SetupVersion"="10""InstallTheme"="%WINDIR%\\resources\\Themes\\$OEM$.theme""InstallVisualStyle"="%ResourceDir%\\Themes\\Aero\\Aero.msstyles"; display custom background logon-logoff image (make sure less than 256kb)[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\Background]"OEMBackground"=dword:00000001; display custom background logon-logoff image (apply to all themes)[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System]"UseOEMBackground"=dword:00000001 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...