Jump to content

Add en-GB Language and KB to Autounattend


ElmerBeFuddled
 Share

Recommended Posts

Hi, I'd like to add my User choice en-GB Language and en-GB Keyboard to the Autounattend.xml with W7T and skip this UI screen during install.

Is this at all possible, and if so how? I'll admit I haven't a clue, and what I've seen so far is confusing me! So any help much appreciated.

This is how it stands at the moment:

<!--?xml version="1.0" encoding="utf-8"?-->

<!--Created by Windows 7 Toolkit v1.3.0.91-->

<unattend xmlns="urn:schemas-microsoft-com:unattend">

<settings pass="windowsPE">

<component name="Microsoft-Windows-Setup" processorarchitecture="x86" publickeytoken="31bf3856ad364e35" language="neutral" versionscope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<userdata>

<accepteula>true</accepteula>

</userdata>

</component>

<component name="Microsoft-Windows-Setup" processorarchitecture="amd64" publickeytoken="31bf3856ad364e35" language="neutral" versionscope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<userdata>

<accepteula>true</accepteula>

</userdata>

</component>

</settings>

<settings pass="oobeSystem">

<component name="Microsoft-Windows-Shell-Setup" processorarchitecture="x86" publickeytoken="31bf3856ad364e35" language="neutral" versionscope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<oobe>

<hideeulapage>true</hideeulapage>

<hidewirelesssetupinoobe>true</hidewirelesssetupinoobe>

<networklocation>Home</networklocation>

<protectyourpc>3</protectyourpc>

</oobe>

<timezone>GMT Standard Time</timezone>

</component>

<component name="Microsoft-Windows-Shell-Setup" processorarchitecture="amd64" publickeytoken="31bf3856ad364e35" language="neutral" versionscope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<oobe>

<hideeulapage>true</hideeulapage>

<hidewirelesssetupinoobe>true</hidewirelesssetupinoobe>

<networklocation>Home</networklocation>

<protectyourpc>3</protectyourpc>

</oobe>

<timezone>GMT Standard Time</timezone>

</component>

</settings>

</unattend>

TIA for any help

Edited by ElmerBeFuddled
Link to comment
Share on other sites

I finally got this to work, after a few days of swearing, kicking the pc and spitting at my monitor! :ranting: :D

For anyone else who is going through this hell, these are the relevant parts that were needed:


<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="windowsPE">
<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SetupUILanguage>
<UILanguage>en-US</UILanguage>
</SetupUILanguage>
<InputLocale>0809:00000809</InputLocale>
<SystemLocale>en-GB</SystemLocale>
<UILanguage>en-US</UILanguage>
<UserLocale>en-GB</UserLocale>
</component>
<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SetupUILanguage>
<UILanguage>en-US</UILanguage>
</SetupUILanguage>
<InputLocale>0809:00000809</InputLocale>
<SystemLocale>en-GB</SystemLocale>
<UILanguage>en-US</UILanguage>
<UserLocale>en-GB</UserLocale>
</component>
</settings>
<settings pass="oobeSystem">
<component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<InputLocale>0809:00000809</InputLocale>
<SystemLocale>en-GB</SystemLocale>
<UILanguage>en-US</UILanguage>
<UserLocale>en-GB</UserLocale>
</component>
<component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<InputLocale>0809:00000809</InputLocale>
<SystemLocale>en-GB</SystemLocale>
<UILanguage>en-US</UILanguage>
<UserLocale>en-GB</UserLocale>
</component>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<TimeZone>GMT Standard Time</TimeZone>
</component>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<TimeZone>GMT Standard Time</TimeZone>
</component>
</settings>
</unattend>

Now to learn how / if I can skip the "enter key / activate" screens regardless of the version being installed.

Edited by ElmerBeFuddled
Link to comment
Share on other sites

  • 5 months later...

same for french installs, the UI is built in fr-FR not fr-CA, so fr-CA will always popup the window

<SetupUILanguage>

<UILanguage>fr-FR</UILanguage>

<WillShowUI>Never</WillShowUI>

</SetupUILanguage>

<InputLocale>0c0c:00001009</InputLocale> (Français Canada - Français Canada)

<SystemLocale>fr-CA</SystemLocale>

<UILanguage>fr-FR</UILanguage>

<UserLocale>fr-CA</UserLocale>

took me a while also :P

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...