Jump to content
Master.ZizO

nLite & onepieces Update Pack errors

Recommended Posts

Hey guys,

i Integrated onepiece's update pack to clean xp sp3 source

windows setup worked 100%

after using nLite to remove some files

windows setup in 39 min skips copying files method which is after Installing network

it turns on Installing start menu items after finishing Installing network

and after finishing setup , i didn't find iExplorer , or wmp11

and there was an error message "cannot find framedyn.dll"

this is my preset of nlite "Here"

need reply fast plz

Thanks...

Share this post


Link to post
Share on other sites

You are breaking it by removing things!

My guess is it is one or more of these:

Internet Connection Wizard
Internet Information Services (IIS)

Help and Support

Security Center
Tour

Indexing Service

Basically the update packs now add ALOT and nearly any removal can break them.

P.S. Never remove sevices just disable them.

Share this post


Link to post
Share on other sites

You are breaking it by removing things!

My guess is it is one or more of these:

Internet Connection Wizard
Internet Information Services (IIS)

Help and Support

Security Center
Tour

Indexing Service

Basically the update packs now add ALOT and nearly any removal can break them.

P.S. Never remove sevices just disable them.

Share this post


Link to post
Share on other sites

Huh thanks kels...

But it is not the problem, i remove them every time cuz there is no use for them

i found the problem now , i removed "NETFX20.cab ,NETFX20.INF"

when i put them back to the source it worked 100%

now i want to know why i can't remove them ? , i have netfx20 silent install 16 MB but the cab is 20 MB :P

the cd is 700 mb and 1 MB is impotrant for me :D

Share this post


Link to post
Share on other sites

You are supposed to MANUALLY remove the extra, unnecessary folders from it....

DOCS

DOTNETFX

SUPPORT

VALUEADD

I386\Lang

This frees up 159 megs. Wish to manually save more?

WIN9XUPG

WIN9XMIG

This frees up another 36.6 megs. All together that saves you @ 200 megs...

Share this post


Link to post
Share on other sites

I integrate SP3, Update Pack & Add-on Pack using RVM Integrator and then i trim using NLite.

I was having the same problem yesterday, but after few trial and error i found what cause the problem.

My two cents is:

Internet Information Services (IIS) cannot be removed, it should be install or use default setting at unattended page for IE & WMP Add-on to works. Another thing, leave all services components intact and use default setting at tweaks page for all services. Customize the services after the installation.

Hope it helps.

Share this post


Link to post
Share on other sites

and there was an error message "cannot find framedyn.dll"

read this http://www.ryanvm.net/forum/viewtopic.php?p=107769&sid=8e9dbfd0fb832020e0729f1a1d533144#107769

I think that happens because nLite not correctly understand cabbed (compressed) inf file large than 64k!!

all other addon with small cabbed inf file nLite intergrate correctly!

to make addon working with nLite make following:

- uncab (or uncompress) addon

- uncab <name_of_inf_file>.in_ to <name_of_inf_file>.inf (use cabtool or expand windows command)

- delete <name_of_inf_file>.in_

- repeat for each cabbed inf file

- add all to 7z addon (rar or cab)

Edited by AndreyPopov

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...