Jump to content

ERROR. Please check your internet connection.


Recommended Posts

I'm pretty sure that the server outage has somehow caused this issue for some users, but I don't understand yet how and why, and why I'm not affected...

Can you post a screenshot, so that I can see at which step it happens? And also let me know which file exactly you're requesting (version and language).

Link to post
Share on other sites

I believe I found the issue. In the aftermath of the server outage, I disabled insecure SSL/TSL protocols and ciphers. Most importantly, I had disabled TLS v. 1.0 and TLS v. 1.1, which are considered insecure. I've re-enabled both of them now.

However, everyone who has had the issue, very likely has a vulnerable Windows system.

To fix it, go to your system's internet security settings, and enable TLS v. 1.2. (You can leave versions 1.0 and 1.1 enabled, unless you need a super secure system.)

Otherwise, your passwords can be stolen by man-in-the-middle attacks.

You should also be able to use the downloader again now.

To be honest, it's quite shocking that so many users don't have TLS v. 1.2 enabled.

Link to post
Share on other sites
On 11/11/2018 at 12:23 AM, Jan Krohn said:

I believe I found the issue. In the aftermath of the server outage, I disabled insecure SSL/TSL protocols and ciphers. Most importantly, I had disabled TLS v. 1.0 and TLS v. 1.1, which are considered insecure. I've re-enabled both of them now.

However, everyone who has had the issue, very likely has a vulnerable Windows system.

To fix it, go to your system's internet security settings, and enable TLS v. 1.2. (You can leave versions 1.0 and 1.1 enabled, unless you need a super secure system.)

Otherwise, your passwords can be stolen by man-in-the-middle attacks.

You should also be able to use the downloader again now.

To be honest, it's quite shocking that so many users don't have TLS v. 1.2 enabled.

Your fix worked i can use tool now. But to add something i had tls 1.2 enabled as well as 1.1 and 1.0 and tool did not work with it.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...