Jump to content
bober

[Closed] XPtsp General discusions

Recommended Posts

Ok, here's the situation. My new computer components should be here tomorrow and I've got a lot to do to prepare for the change-out. So, I probably won't be around this thread for the next day or two.... I'll try to add the new option to the GUI tomorrow while I'm backing up everything, but I don't know if I'll succeed. Thought I'd let you know.

Mr_Smartepants: Of course it'll be optional.... I wouldn't dream of forcing it down people's throats!

Edited by dougiefresh

Share this post


Link to post
Share on other sites

I just got a weird error during txtsetup.

"Could not copy winntbbu.dll"

This was after using b13 batch.

b13 gui has it's own strange error.

I usually use RVMI to build my ISO but this time I thought I'd let the gui do it.

Before txtsetup even starts, I get a screen that says I haven't declared a PC type and has "Other" highlighted in the middle of the screen. Reproducible in virtualbox and real hw.

Building the iso with RVMI does not show this problem.

Other than that, the eye candy looks awesome! I can't wait to finally reformat my notebook once the bugs are cleared.

:)

Share this post


Link to post
Share on other sites

internetoptionsip7.th.gifthpix.gif

accesszz1.th.gif

http://depositfiles.com/files/8417077

mirrors: http://www.zippyshare.com/v/88654691/file.html

http://www.rapidspread.com/file.jsp?id=gmhetkdidk

updates:

access.cpl.res, accwiz.exe.res, appwiz.cpl.res, cliconfg.exe.res, fxscfgwz.dll.res, fxswzrd.dll.res, inetcpl.cpl.mui.res,

inetcpl.cpl.res, inetcplc.dll.res, migwiz.exe.res, ntmsmgr.dll.res, powercfg.cpl.res, smlogcfg.dll.res, webcheck.dll.res,

wiashext.dll.res, winchat.exe.res, wininet.dll.res, winmine.exe.res, wsecedit.dll.res, xpsp1res.dll.res, zipfldr.dll.res

- access.cpl added new bitmaps and changed dialogs

- inetcpl.cpl.mui (%WINDIR%\system32\en-US) added new bitmaps and changed dialogs

- powercfg.cpl added new bitmaps and changed dialogs

- new bitmaps in fxscfgwz.dll.res, fxswzrd.dll.res

- new avis in wiashext.dll.res

- new bitmap in xpsp1res.dll.res

- various bitmaps and icons fixes

credits and thanx to Jekson07 (http://forum.oszone.net/thread-117754-24.html)

Edited by amnesia

Share this post


Link to post
Share on other sites

thx for all the updates,but last link for new connect wiz is no good.ill wait b4 updating.ill prolly do it 2 morow

Share this post


Link to post
Share on other sites

I have made polish translation of resources but I do not know how can I prepare translated Setup program?

Share this post


Link to post
Share on other sites
Guest ALtF4

Amnesia, if you continue like that, ı will release new VISO next month :D

Thnaks for new bmps :)

Share this post


Link to post
Share on other sites
I have made polish translation of resources but I do not know how can I prepare translated Setup program?

you mean translate the batch file?

stimpy, i dont know if you have the time to make the other cpl dialog resoruces match withthe ones you modifyed from sysdm.cpl?cause manesia has updated a few and they dont match anymore.thx

Edited by bober

Share this post


Link to post
Share on other sites
stimpy, i dont know if you have the time to make the other cpl dialog resoruces match withthe ones you modifyed from sysdm.cpl?cause manesia has updated a few and they dont match anymore.thx

Here you go bober. I just got your request as I was off to bed! Things are crazy for me at the moment, so I'm not here muct at the moment. I'm hoping things will calm down for me soon.

http://rapidshare.com/files/150645674/latest.rar.html

I also included shell32.dll.res to fix the missing information in the copy/move/replace dialog box.

Tell me if I missed any.

Oh, and I also get the winntbbu missing error during text mode setup.

Edited by Stimpy

Share this post


Link to post
Share on other sites
Guest ALtF4

Try this code in .bat file for fixing error.

I used it on my VISO.

It works.

I edited it for you.

Dont add sth else, just replace it to your .bat file.

:winntbbu
title XPtsp script Progress 87%%%...
set name=winntbbu
set ext=dll
set big=WINNTBBU
set com=DL_
if not exist "i386\%big%.%com%" goto winntbbu2
%xp% "i386\%big%.%com%" "%tmp%\%name%.%ext%" >nul
%rh% %ao% "%tmp%\%name%.%ext%", "%tmp%\%name%.%ext%", "%res%\%name%.%ext%.res",,,&echo patching %name%.%ext%
%pe% -c %tmp%\%name%.%ext% >nul
%cab% /D CompressionType=LZX /D CompressionMemory=21 "%tmp%\%name%.%ext%" "i386\%big%.%com%" >nul
:winntbbu2
set name=winntbbu
set ext=dll
set big=WINNTBBU
set com=DLL
if not exist "i386\%big%.%com%" goto winntbba
%cp% /v /y "i386\%big%.%com%" "%tmp%\%name%.%ext%" >nul
%rh% %ao% "%tmp%\%name%.%ext%", "%tmp%\%name%.%ext%", "%res%\%name%.%ext%.res",,,&echo patching %name%.%ext%
%pe% -c %tmp%\%name%.%ext% >nul
%cp% /v /y "%tmp%\%name%.%ext%" "i386\%big%.%com%" >nul

Edited by ALtF4

Share this post


Link to post
Share on other sites

ok thx stimpy.

i wasint aware of any winntbbu troubles.

edit can anyone else confirm the winnt* problems?

Edited by bober

Share this post


Link to post
Share on other sites
Try this code in .bat file for fixing error.

Dont add sth else, just replace it to your .bat file.

So, you're adding :winntbbu and :winntbb2 sections, but that leave behind :winntbba which isn't indexed.

Or does :winntbba get replaced too?

Otherwise the code should look like this:


:winntbbu
title XPtsp script Progress 87%%%...
set name=winntbbu
set ext=dll
set big=WINNTBBU
set com=DL_
if not exist "i386\%big%.%com%" goto winntbbu2
%xp% "i386\%big%.%com%" "%tmp%\%name%.%ext%" >nul
%rh% %ao% "%tmp%\%name%.%ext%", "%tmp%\%name%.%ext%", "%res%\%name%.%ext%.res",,,&echo patching %name%.%ext%
%pe% -c %tmp%\%name%.%ext% >nul
%cab% /D CompressionType=LZX /D CompressionMemory=21 "%tmp%\%name%.%ext%" "i386\%big%.%com%" >nul
:winntbbu2
set name=winntbbu
set ext=dll
set big=WINNTBBU
set com=DLL
if not exist "i386\%big%.%com%" goto winntbba
%cp% /v /y "i386\%big%.%com%" "%tmp%\%name%.%ext%" >nul
%rh% %ao% "%tmp%\%name%.%ext%", "%tmp%\%name%.%ext%", "%res%\%name%.%ext%.res",,,&echo patching %name%.%ext%
%pe% -c %tmp%\%name%.%ext% >nul
%cp% /v /y "%tmp%\%name%.%ext%" "i386\%big%.%com%" >nul

Edited by Mr_Smartepants

Share this post


Link to post
Share on other sites
Guest ALtF4
So, you're adding :winntbbu and :winntbb2 sections, but that leave behind :winntbba which isn't indexed.

Or does :winntbba get replaced too?

Otherwise the code should look like this:

No, you wont replace winntbba.Just you will add that code between them.

Then ıt should look like:

:winntbbu
title XPtsp script Progress 87%%%...
set name=winntbbu
set ext=dll
set big=WINNTBBU
set com=DL_
if not exist "i386\%big%.%com%" goto winntbbu2
%xp% "i386\%big%.%com%" "%tmp%\%name%.%ext%" >nul
%rh% %ao% "%tmp%\%name%.%ext%", "%tmp%\%name%.%ext%", "%res%\%name%.%ext%.res",,,&echo patching %name%.%ext%
%pe% -c %tmp%\%name%.%ext% >nul
%cab% /D CompressionType=LZX /D CompressionMemory=21 "%tmp%\%name%.%ext%" "i386\%big%.%com%" >nul
:winntbbu2
set name=winntbbu
set ext=dll
set big=WINNTBBU
set com=DLL
if not exist "i386\%big%.%com%" goto winntbba
%cp% /v /y "i386\%big%.%com%" "%tmp%\%name%.%ext%" >nul
%rh% %ao% "%tmp%\%name%.%ext%", "%tmp%\%name%.%ext%", "%res%\%name%.%ext%.res",,,&echo patching %name%.%ext%
%pe% -c %tmp%\%name%.%ext% >nul
%cp% /v /y "%tmp%\%name%.%ext%" "i386\%big%.%com%" >nul

Note: bober if you want, you can send me your lastest XPtsp.bat file.Then ı can edit it for you and send back to you.

Edited by ALtF4

Share this post


Link to post
Share on other sites

i ahve no idea why u guys are having trouble.

the way i scripted the 4 winnt* file is like so:

if the cabbed file exists,then uncab it and copy it to temp and delte the cabbed file.

if it dosent exist,look for an uncabbed version and copy it to temp.

after patching copy over to i386 the uncabbed file.

so even if you have acabbed version an uncabbed one or even both as i have noticed this happens more than we think, the file in the end will be the patched one. i have tested this quite extensively and i cannot see why u guys are having trouble.

btw i wont be able to update xptsp with all the new resources as i have killed my main pc that has all the files.

Edited by bober

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...