Jump to content
YumeYao

[Release] .NET Framework Collection 20111019(1.1/2.0/3.5/4.0)

Recommended Posts

There were 2 new updates released this month between the 10-13 September 2013. ;)

 

KB2836941-v2 - Compatibility and Reliability Update.
KB2844285-v2 - Vulnerabilities in .NET Framework and Silverlight Could Allow Remote Code Execution.

Edited by SuperLOL

Share this post


Link to post
Share on other sites

Windows XP prompts me to install them since August with your latest .NET Frameworks Addon. :tumbleweed:

 

This month "user_hidden" has also update his .NET Frameworks addons and i tried them out and i don't get promoted to install any .NET Frameworks updates. :albert:

Edited by SuperLOL

Share this post


Link to post
Share on other sites

Updated dotNet Frameworks 09-2013

 

 

         Microsoft.Net_1.1SP1+3.5SP1_EN_AddOn_20130915.cab
 
MD5: 8B8AB13A362715E0ABFF5C35EC7EDB96 
Size: 38,20 MB
Url.: 
 
Incl. dNET1.1SP1 + 2.0SP2 + 3.0SP2 + 3.5SP1
Without dotNet1.1SP1 change " -ai" switch to " -ai1". 
 
 
         Microsoft.Net_Framework.5IO_EN_AddOn_20130915.cab
 
MD5: 9FA7C99DDE1708225E25C15C5C88DF89 
Size: 57,15 MB
Url.: 
 
Incl. dNET1.1SP1 + 3.5SP1 + 4.0 (Client Profile)
Without dotNet1.1SP1 change " -ai" switch to " -ai1".
 
Integrate VC++_Runtimes prior to .NET Frameworks
 

 

EDIT: updated 10-2013

Edited by jaynbe

Share this post


Link to post
Share on other sites

I try it out and the Windows XP Update Center will now only promote for .NET Framework 4 Client Profile.

 

Thanks for the feedback; 5AIO Addon will also install .NET4 Client

Share this post


Link to post
Share on other sites
Updated dotNet 10-2013 

 

MS13-082 Updates 

 

 

     Microsoft.Net_1.1SP1+3.5SP1_EN_AddOn_20131011.cab 

 

MD5: 67585E4FA09BB594B34977E494ACA726 

Size: 38,22 MB 

Url.:

 

Incl. dNET1.1SP1 + 2.0SP2 + 3.0SP2 + 3.5SP1 

Without dotNet1.1SP1 change " -ai" switch to " -ai1". 

 

 

     Microsoft.Net_Framework.5IO_EN_AddOn_20131011.cab 

 

MD5: C66E65BDB7872903DA610676B30EB9C6 

Size: 57,11 MB 

Url.:

 

Incl. dNET1.1SP1 + 3.5SP1 + 4.0 (Client Profile) 

Without dotNet1.1SP1 change " -ai" switch to " -ai1". 

 

 

Integrate VC++_Runtimes prior to .NET Frameworks 


 

 

EDIT: Updated 02-2014
Edited by jaynbe

Share this post


Link to post
Share on other sites

Hi, your release seems great, but I need some more information:

 

1- does this also contain all the 3.5 and 4.0 patches too?  --> dNET1.1SP1 + 3.5SP1 + 4.0 (Client Profile)

 

2- how did you obtain a pack so small? The standalone installers alone for 3.5+4.0 are about 300Mb! What did you remove?

 

3- I've never used a single Nlite addon so far: are these executed at RunOnceEx too? I have a custom multi-page RunOnceEx, do you know if this could break it?

Share this post


Link to post
Share on other sites

Have you read the first post of this topic? Most answers are there.

In short:
1 The installer is allways updated to the latest updates.
2 All non-XP-32bit data is removed and installer compressed.
3 By default the addon is run at T-13, but ROE compatible.

Edited by jaynbe

Share this post


Link to post
Share on other sites

Sorry, I checked the first page afterwards, but then I couldn't edit my post anymore! (it was blocked for approval) :lock:

 

About point3, if I understood correctly, I can then put your Microsoft.Net_Framework.5IO_EN_AddOn_20131011.cab in a custom folder on my iso and launch it whenever I want on ROE (after VC8+VC9+XPS).

 

Thanks for this, because updating+installing the netframe is a bloated mess. :weakbench:

Share this post


Link to post
Share on other sites

phaolo,

 

The addon is for direct integration with nLite or RVM Integrator.

 

Retrieve the installer by unpacking the Addon with 7zip and run it.
You'll have to first install the VC++ Runtimes; also available Addon.

Edited by jaynbe

Share this post


Link to post
Share on other sites

The link on ryanvm site for the required Xps is down, can you fix it or do you know where I can download it?

Edited by phaolo

Share this post


Link to post
Share on other sites
Updated dotNet 02-2014

 

MS14-009 Security Bulletin Updates

 

 

      Microsoft.Net_1.1SP1+3.5SP1_EN_AddOn_20140212.cab

 

MD5: 3A9585EE5421EDE6E8AA8FE21EBB6930 

Size: 38,22 MB


 

Incl. dNET1.1SP1 + 2.0SP2 + 3.0SP2 + 3.5SP1 

Without dotNet1.1SP1 change " -ai" switch to " -ai1". 

 

 

      Microsoft.Net_Framework.AIO_EN_AddOn_20140213.cab

 

MD5: E979E5FA71E773C153A5EC92F65F706E

Size: 61,34 MB  


 

Incl. dNET1.1SP1 + 3.5SP1 + 4.0(Full Extended) 

Without dotNet1.1SP1 change " -ai" switch to " -ai1". 

 

 

Integrate VC++_Runtimes prior to .NET Frameworks 


 

EDIT: corrected and reuploaded AIO Addon
Edited by jaynbe

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...