Jump to content

WTK Bug? - Windows 7 install fails, CD/DVD driver missing


Recommended Posts

Hi, i'm new here and tried to integrate all Windows 7 Updates into the latest Windows 7 ISO i downloaded recently.

When using the downloaded imgage after removal of the Ei.cfg i'm able to boot to the windows installation and select

the version i want to install.

Now i used WTK, downloaded all updates, used AIO to create the new image (without adding any driver)

and now Windows failes during install asking for a CD/DVD driver.

I reloaded the image into AOI and added all mass-storage drivers, selected the option - load USB drivers, but still

the install process is asking for the driver. (it fails if booting from DVD and USB Stick).


Question: If the Windows 7 ISO with SP1 on is allowing me to install without the need for any additional Driver and

than using this ISO as input for the AOI why is the new image which has all the new windows updates added, requires a CD/DVD driver ???  am i doeing something wrong or do i have to add all available drivers anyway ???


Thanks for help,     Fiete_b

Link to comment
Share on other sites

Is it a DOS message or Setup message ?

If it's a Setup message and you are trying to boot from a USB3-device - applying the USB3 drivers is not enough.

I just ran into it myself a week ago.


my Maximus Gene-V has 2 USB3 hubs:

-Booting from USB3 (INTEL) - driver fails

-Booting from USB3 (Asmedia) - working

.. even though the proper drivers are present - so i thought.


The Intel-USB3 needs a specific set with the proper USB-HUB.


Also make sure to check the "Include USB-Drivers in boot.wim" -> AIO-Integrator->Options->Drivers

Edited by nonspin
Link to comment
Share on other sites



windows is booting (loading Files), comes to the screen were you can select recovery options or install. I select install, respond to the

language, date and time , now setup is starting but a few seconds later a window pops up :

 please select the required driver. In a second window the message says:

   A required CD/DVD device driver is missing....


but no driver is shown ..

This is a setup message.


This happens if i use the USB Stick ( it's an Agfa USB V3.0 Stick) but also if i burn the image to a DVD,


If i copy the Windows 7 SP1 files  from the downloaded ISO image to the Stick, everything is working, same if burning the ISO to a DVD.

It alway fails if the image is created by WTK...


Any idea ???

Link to comment
Share on other sites

Let me confirm that it's a bug in WinToolkit. I've just created a new ISO from a saverd preset

using that latest version. Same symptoms as you.


It seems like it doesn't access the custom drivers at all - nor can you see the actual content of the

USB-Drive you're boooting from - seems like boot.wim overides and assigns the Drive to itself,

rather than using a new one.


I came across the ErrprCode 0xC8 .. dunno is it helps

Link to comment
Share on other sites

This might have been my fault.... In Basic AIO i selected the BOOT.WIM and added all Updates, but never ran the update integration to the install.wim

After spending many hours with this tool i used the install.wim, selected 3 images  and now the update integration takes 5 hours and all updates are added (green)... I'm currently running this process for the x64 environment.  The x86 environment finished last night and with that image i was able to start the windows installation process without the request for any driver..(from USB V3.0 stick and from a DVD !!!). I'll let you know if the x64 environment is running as well... :doh: ,  Fiete_b

Link to comment
Share on other sites

Yes, please let us know your results.  It would also be helpful if nonspin could confirm if this might be his situation as well, but I believe that he said he used an existing preset that worlked, or at least had worked before, with a previous version of WTK.
Cheers and Regards

Link to comment
Share on other sites

After spending many hours creating Windows 7 X86 and x64 environments  just adding all available updates 

to the install.wim  and boot.wim,  both environments get the CD/DVD Driver missing message.

Since this is the first time i'm using WTK i'm not sure if the steps i used are correct or WTK is failing.

The steps i used:

 1) download all updates for x64 and x86 environment storing it to separate directories:   updates\x64 and updates\x86

 2) Unload the ISO image to separate directories : win7srcx64 and win7srcx86 

 3) in Basic AOI browse for win7srcx86\sources   install.wim

    removed the starter, home basic and ultimate image

    -  selected both remaining images (home premium and professional), used option (no preset)

    -  added all updates and started the integration process.

    -  It took nearly 4 hours to complete, closed the window, opened basic aoi, browsed for the boot.wim,

       selected both images (pe and professional) added all updates and started the integration process.

       here are not all updates incuded, many show the black x (not inserted).

  after the image was ready, i created the ISO image, burned it to dvd and tested with the known  

  error (CD/DVD driver missing)

 The same procedure i used for the X64 environment.


I'm not sure (didn't find it documentd) if the integration step to the boot.wim is requqired and if that could be a problem ??


Any help will be appreciated...


Link to comment
Share on other sites

Ok, thanks for clarification... 

but... last night i created a new image, just selecting one image in install.wim (win7 prof), integrated all updates, created the ISO file, prepared the DVD and..... CD/DVD Driver missing pops up..... :ranting:

The BOOT.WIM wasn't touched... (used BASIC AOI only) 

   Anything else i could check ???  


Link to comment
Share on other sites

Please ignore my last update... 


I confused myself by using the wrong source directory.

For this test i created another source directory and now it works ...

The problem for sure was the integration of updates to the boot.wim .....


I'm happy now that all works as expected....


Thanks and best regards

Link to comment
Share on other sites

  • 2 weeks later...

Something is still not right, though.

I did a very simple integration job to narrow down the problem

job: W7x64 ENT + USB3



- en_windows_7_enterprise_with_sp1_x64_dvd_u_677651 (untouched)

- Intel® USB 3.0 eXtensible Host Controller:

- Asmedia_USB3_V11430_XPWin7 (official ASUS)


No errors during integration.


Asus Maximus-V Gene

Test1: Booting from Intel USB3

- Shows "CD/DVD Driver missing" aftrer LanguageSelection

- Selecting "Browse" shows all HDD's and X:Boot (boot.wim)

- The actual USB3 Drive is NOT present


Test2: Booting from ASMedia USB3

- same as above



Test3: Booting from Intel USB (normal non USB3)

- SUCCESS, but:

In Windows7 -> DeviceManager

the Interl-USB3 shows as "Unknown Device" even after pluggin a device to wake it up.

Now, applying the very same Drivers, which WTK has "successfully" integrated the USB Hub wakes up.

-> Manual Driver Installion via Device Manager (.inf)


I suspect, that WTK separates the "Intel® USB 3.0 eXtensible Host Controller"

from "Intel® USB 3.0 Root Hub" and stores one part in the boot.win - the other in install.wim.

That's the only logical explanation i can come up with.



Link to comment
Share on other sites

I think you should have a look here :




"This supplement is optional. If you do not need to modify the SP1 Boot.wim and Winre.wim files, you can continue to use the Windows 7 RTM tools, including WinPE 3.0, without installing this supplement."



I think this explains some other driver integrating issues too.


Last time i experimented i saw boot.wim is untouched. this i saw at the date boot.wim was last processed : 12.04.2011


Next i installed WAIK and this supplement. Then i tested. After test ended the date was actual one !!



By the way : Host Controller Drivers always must integrated BEFORE Hub Drivers !!!

Edited by Snow
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...