Jump to content

Troubleshooting advice needed for Win7 Install Failure Loops


Recommended Posts

I've used Win Toolkit/AIO Intergrator to create and successfully install updated 64-bit Win7 SP1 Pro in the past, but this time every single attempt has run into an infinite failed installation loop.  What I mean by that is that the installation will fail for some unknown reason late in the install process such that it tells you to restart and try again, except that the exact same failure occurrs every re-try attempt.

 

Naturally, I wasn't so nuts that I just kept on trying, but instead after each failure I removed yet another element from the AIO Integrator preset settings and rebuilding again from scratch (careful to erase the working install folder and then re-load it from the Microsoft Windows 7 64-bit SP1-U - Media Refresh edition ISO).

 

I've repeated this now SEVEN TIMES and the failure loops still continue! Obviously so, since I can find no meaningul indication of exactly what went wrong, so there's nothing left for me but random trial and error. Which is obviously not working!

 

So what I'm looking for is some guidance as to HOW to determine EXACTLY what went wrong with the install.  Looking at the only post-install failure log files that show some kind of error has been zero help because the error message(s) are hopelessly vague.

 

For instance, from the C:\Windows\Panther\UnattendGC directory, here is the contents of 'setuperr.log':

2015-04-13 02:59:54, Error [windeploy.exe] Setup.exe failed, returning exit code [0x1f]2015-04-13 02:59:54, Error [windeploy.exe] Failure occured during online installation.  Online installation cannot complete at this time.; hr = 0x800040052015-04-13 03:01:06, Error [windeploy.exe] Setup.exe failed, returning exit code [0x1f]2015-04-13 03:01:06, Error [windeploy.exe] Failure occured during online installation.  Online installation cannot complete at this time.; hr = 0x800040052015-04-13 03:02:11, Error [windeploy.exe] Setup.exe failed, returning exit code [0x1f]2015-04-13 03:02:11, Error [windeploy.exe] Failure occured during online installation.  Online installation cannot complete at this time.; hr = 0x800040052015-04-13 03:03:23, Error [windeploy.exe] Failure occured during online installation.  Online installation cannot complete at this time.; hr = 0x8007000a

How utterly useless! How am I supposed to know how to fix whatever it's complaining about?

 

What's worse, I don't even have any idea if that error message is at all relevant to what I'm trying to do!  For example, I did NOT want an unattended install. But maybe that's the default for AIO Integrator, I don't know.  Is it?

 

I've read a few posts concerning exit code [0x1f], but I couldn't decipher enough of the techospeak to learn anything at all useful to me at the level of Win Toolkit/AIO.  What the hell am I supposed to do about it?

 

Little help, please?

Edited by uheyh
Link to post
Share on other sites

What you need to do is start from scratch without the presets and carefully add only the updates and don't remove nothing from the components.

Test the result in a VM and if it is successful go further with your customization. Make sure to make a backup copy of the updated image if it works OK before procede to next level.

Load back the updated image and add your silent installs, add-ons and all you need to finish the image and test again in the VM.

Finally if all is well you can make all the tweeks you need in another step. Test again in VM.

Basically you need to make all this in small steps to see what brakes the install for you.

I do all of this in one step and don't have any problems. What I observed over the time that brakes the install is the incompatible drivers that are integrated so I avoid to add driverpacks as a bunch.

Hope this helps to pinpoint the problem.

Also make sure you are using the latest build of Wintoolkit and no other programs involved.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...