Jump to content
runningfool

Installed IE8, now I can't disable the menu bar?

Recommended Posts

so today i decided to install internet explorer 8 beta 1, which went fine. the only problem is that after installing it, IE8 refuses to let me disable the menu bar. going to "View-->Toolbars-->Menu Bar" and clicking it does nothing; the option isnt greyed out, i just cant uncheck it.

i undid every change i made in group policy editor, so my best guess is that the problem is rooted in some obscure registry setting. also, uninstalling IE8 and going back to IE7 does not solve the problem. this isnt a huge deal since i use firefox 3 and only open internet explorer on patch tuesday...but im obsessive about UI stuff like this so if anyone knows of a fix i would really appreciate the help.

Share this post


Link to post
Share on other sites

Hello there,

I know its late - but to help others aswell... and hopefully get help.

After weeks of research (I am now using IE8 final) my cause was of a group policy "Enable Classic Shell" in "Group Policy\Administrative Templates\Windows Components\Windows Explorer" was enabled.

This is a requirement for my domain (Windows Server 2003 & Windows XP SP3 clients), for security reasons.

Does anybody know ANY way to remove this pathetic menu bar from Internet Explorer.

I've tried everything I can see on the internet from importing a registry entry to reset all the toolbars and set the 'AlwaysShowMenus' value to 0.

I've tried using the Group Policy "Turn on the menu bar by default" (Set it to disabled).

No luck.

I've tried every registry entry I can think of.

I don't mind so much if the Windows Explorer menu bar is visible, as most of the items are greyed out on the menus.

Any help will be GREATLY appreciated.

Thanks.

Share this post


Link to post
Share on other sites

Thats the tweak I use to disable it in ie8 integration in my UpdatePack, same one as ie7

HKCU,"Software\Microsoft\Internet Explorer\Main","AlwaysShowMenus",0x10001,0

I dont know what this is for but you may want to look into it

HKLM,"SOFTWARE\Microsoft\Internet Explorer\UnattendBackup\ShowMenuBar","AlwaysShowMenus",0x10001,0

Share this post


Link to post
Share on other sites

Just tried what you said mate, both values are already set to 0.

I've just noticed - the 'ITBarLayout' key keeps changing back to a specific value when after I apply a reg script and restart Internet Explorer.

The registry script does change the ITBarLayout value.

Any more suggestions?

Thanks

Anybody have any suggestions?

Thanks

Share this post


Link to post
Share on other sites
Any more suggestions?

Thanks

Anybody have any suggestions?

Thanks

Post looks a bit outdated but nevertheless, try this tweak if you still have not got any solution. Works on VM , even after restart IE. (i.e. No Menu Bar)

NoIEMenuBar.reg

Share this post


Link to post
Share on other sites

Geej - I downloaded the noieMenuBar.reg and loaded it to my machine but I still get a menu bar. What do you think is happening? I'm running W7 premium.

Thanks,

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...