Jump to content
ricktendo

[Script] IntelliPoint/Type Pro v8.20.468

Recommended Posts

Hi rick. As someone asked a while back, any chance you could make something similar for Logitech SetPoint and iTouch? (Yeah I know, I've got an MX1000 laser mouse which uses SetPoint and an old reliable Elite keyboard that's not covered by the new SetPoint but requires iTouch.) I did a quick search of the forum and came up empty for anything like this that's been done before. If you know of someone else's work, please point me in the right direction, but I really like and respect the stuff you've put out over the years.

Thanks in advance for the help.

Cheers and Regards

Share this post


Link to post
Share on other sites

I have a personal SetPoint silent switch installer with updated vc runtimes for v4.80 but have not tried it with the latest setpoint v6 (this one needs to be connected to the web to dl the mouse bitmaps)

Share this post


Link to post
Share on other sites

I've always used the 4.80 version myself. I just noticed the new v6.0 a couple of weeks ago, but I haven't used it yet. Is your version fit to share, and would you mind? Have you ever used iTouch? Thanks in advance.

Cheers and Regards

Share this post


Link to post
Share on other sites

Many Thanks! If you decide the new version is worth doing an installer for, great, but I don't know if it really adds any capabilities 4.8 doesn't already have. I think it was mainly changed to make the download smaller by only downloading the pictures your particular installation required, rather than including all the pictures all the time. Anyway, if you make one please post.

iTouch was used by Logitech when it used to use separate packages like MS still does for it's keyboards and mice. As The Software Patch describes http://www.softwarepatch.com/utilities/itouch.html,

This download has the latest software and driver for the following Logitech keyboards including:

Cordless Access Duo

Cordless Elite Duo

Cordless Freedom

Cordless Freedom iTouch

Cordless Freedom Optical

Cordless Freedom Pro

Cordless Keyboard

Cordless Navigator Duo

Deluxe Access 104 Keyboard

Elite Keyboard

Internet Navigator Keyboard

Internet Navigator Keyboard

Logitech Access Keyboard

Logitech Cordless Access Keyboard

Logitech Cordless Comfort Duo

New in this update: support for the F-lock functions on the Elite keyboard, Cordless Navigator Duo, Access keyboard, Cordless Access Duo and Cordless Elite Duo. Plus an updated user interface that is easier and friendlier to use than previous versions.

Admittedly, this is an "older" package, last updated 3/30/2004, but hey, since Logitech chose not to include support for some of their older keyboard models in their newer software meant to conveniently support both keyboards and mice in one package, and it ain't broke, ... So I still use it. And XP came out in, what, 2001?

Anyway, in addition to The Software Patch and many other places this software can be downloaded from, the download page direct from Logitech is http://www.logitech.com/index.cfm/434/2992&cl=us,en?softwareid=643&osid=1&section=downloads, where you can choose your language version, including Spanish. The latest version is v2.22 build 289.

If you choose to make an installer for iTouch, I'ld appreciate it since it would save me a step when I do a fresh install, but no biggie either way.

Many Thanks again for this and all the great packages you've shared over the years.

Cheers and Regards

Edited by bphlpt

Share this post


Link to post
Share on other sites

Here is your iTouch installer: http://www.mediafire.com/?wt0ji2ijnog

BTW I got fed up with the SetPoint stuff long ago so I dont think I will try to figure out the new installer anytime soon, I started adding the INF drivers ONLY to my installs, no tastkbar stuff

Oh and SetPoint v6 is totally different from v4, has new program UI

Share this post


Link to post
Share on other sites

Oh Wow! Talk about Service! A thousand blessings upon you Sahib! Hope it was no trouble. One extremely minor question. I assume I need to change line 15 in setup.iss from

szDir=C:\Archivos de programa\Logitech

to

szDir=C:\Program Files\Logitech

Expanding it out and editing it is no problem. But if you don't mind a noob question, rather than me asking you to do it for me, would you mind just telling me what I need to do to get it compressed back up into an .exe complete with the right icon and everything? I'd assume it's just zipping it all up with either WinRAR or 7Zip specifying an SFX archive, but how to get the icon? I saw that WinRAR has an Advanced SFX Option to specify the file to get the icon from, but I didn't see a file in the package that had the one you used. Except the resulting .exe, of course. Any other options I need to pay attention to when I do this? Or maybe it would be better to use a command line? Sorry to be such a noob. Maybe there's a tutorial you can just point me to rather than spend any more time on this. I'd like to learn so I can contribute more and not always have to ask someone else to do things for me. :) Any other potential edits I might have missed?

I appreciate your thoughts about SetPoint. I'll have to consider that for both SetPoint and iTouch in the future. It might simplify things.

Many Thanks in advance.

Cheers and Regards

Edited by bphlpt

Share this post


Link to post
Share on other sites

A yea, sorry about that...BTW you can create your own personal setup.iss by running the installer with this switch (chose not to reboot)

PackageName.exe /r /sms /f1"c:\setup.iss"

Then you retrieve setup.iss from the C:\ directory and place it in with your installer, then this switch will work to install your app using the options recorded in the .iss file

PackageName.exe /s /sms

BTW some unpacked installshiled installers already come with a setup.iss file and there is no need to create your own

To re-create your own installer, use 7zip archive splitter to decompile the 7zip silent switch installer into 3 files (.txt, .sfx and .7z), you will have iTouch.txt (a.k.a. config.txt) with the install info and also the iThouch.sfx (a.k.a. 7zsd.sfx) with the icon, now you take the iTouch.7z expand it add your setup.iss and recompress it with 7zip

Now you put all 3 files in the same directory and you open a cmd prompt in that directory & execute this

copy /b iTouch.txt + iTouch.sfx + iTouch.7z iTouch.exe

This will merge all 3 files together into a .exe

Here is a vid you can watch on silent switch making

Share this post


Link to post
Share on other sites

Yeah, I know, I'm sure you're saying "Oh no, there's that idiot again"

First, again I want to thank you for all the file maintenance I put you through yesterday.

I got all the files and began playing. Immediately I had a problem. I took the iTouch.exe you so graciously made for me, split it with 7ZSplit.exe, looked inside iTouch.sfx with Resource Hacker and saw that indeed that the icon I wanted was inside but left the file as it was, then, after making NO changes to the 3 files, put them back together using the command line you provided - "copy /b iTouch.txt + iTouch.sfx + iTouch.7z iTouch.exe". While the result was the same size as the file you provided, no icon was available for the file and, of course the checksums didn't match. When I split my resulting file apart with 7ZSplit.exe, the iTouch.sfx was now a 0 size file. Just to make sure, I tried this same chain of events 3 times with the identical results each time. I'm sure I probably just did something stupid, but what? I'm confused.

Wait a minute - just for grins, before I sent this I tried the copy again, but this time changed the order slightly to this - "copy /b iTouch.sfx + iTouch.txt + iTouch.7z iTouch.exe", with the sfx first, and now it works! Icon is there and the checksums now match. Is the copy process that order dependent?

I'll be interested in your thoughts.

Cheers and Regards

Share this post


Link to post
Share on other sites

Not sure, been awhile since I have done it manually...usually I edit config.txt with installer name and switches, add my icon and version info to 7zsd.sfx, zip my installer files and use the drag&drop_on_me.bat thats in the SilentSwitchMaker.zip to build my silent switches

You may be correct, if you look inside the bat you will see the order you mentioned

@copy /b "%~dp17zSD.sfx" + "%~dp1config.txt" + %1 "%~dpn1.exe"

BTW if you added the new setup.iss to your .7z file the checksums should not match

Share this post


Link to post
Share on other sites

Thanks for confirming things. As I said, I just pulled things apart then put them right back together, with NO changes, to see if I had the steps correct before I tried to change ANYTHING. Thanks again for all your help.

Cheers and Regards

Share this post


Link to post
Share on other sites

Updated

Rick, Thanks again for all your work. I noticed on this installer that you can no longer simply run

the .msi to install. That's why you had to add the 'INSTALLGUID={8979881A-8E43-467f-B387-E37B914A0E53}'

to the command line.

My question is... How were you able to discover this command line secret? I have a few other programs

that I think this method may work for but I'm uncertain where to begin.

Share this post


Link to post
Share on other sites

Up

Hello Rick,

I see it's long time ago since any reply on this topic.

I've tried the download but Filesonic has stopped sharing the files. "All sharing functionality on FileSonic is now disabled."

Any change you can post the file elsewere?

I'd love to get a copy and use it in my unattended W7x64 setup.

Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...