Jump to content
mooms

Virtual CloneDrive 5.5.0.0

Recommended Posts

I did not get 7za.exe when extracting, however thought I understood it by now and wanted to write down the steps I took. So I went back to the original SFX from #1.

 

I used 7ZSplit (Install configuration+7z) and got SFX_VCD5470.txt + SFX_VCD5470.7z. I did not get 7zsd.sfx  :g:

 

I've done a lot of trial&error these last days and I can't recall how I got it when I first started with modification. It's really very confusing and I'm lost again :omg:

 

What am I missing now????

Share this post


Link to post
Share on other sites

I started with the RAR-Archive (post #21): unpack in a folder and splitted the contained SFX_VCD5470.exe;

 

7za.exe from post #17;

 

folder-structure like in my previous post;

 

vcd.reg changed for my purposes;

 

vcd.cfg edited (delete desktop-icon added)

 

vcd.cmd started

Share this post


Link to post
Share on other sites

Is the icon creation a standard behavior of your 7zsd.sfx or did you modify it?

 

Updated the SFX:

 

- The icon of Virtual CloneDrive is now used in the SFX.

- Deletion of the autostart of Daemon tray is now done in command line.

- Daemon tray is now killed after installation.

 

The 7zsd.sfx embedded in the rar archive (and used in the silent installer) is modified with Resource Hacker (only changed the icon).

I did not include all the binaries but obviously you need 7za.exe  and put the reg file, the installer & the certificate in the VCD sub-folder to re-create an other Silent installer.

 

Unlike this one,the sfx posted in the first page did not contain any reg file, the registry modification is done in command line:

;!@Install@!UTF-8!GUIMode="2"MiscFlags="4"RunProgram="hidcon:cmd /c certutil -addstore \"TrustedPublisher\" EB.cer"RunProgram="VCD5470.exe /S /noreboot"RunProgram="hidcon:cmd /c reg delete \"HKLM\\SOFTWARE\\Microsoft\\Windows\\CurrentVersion\\Run\" /v VirtualCloneDrive /f"RunProgram="hidcon:cmd /c taskkill /f /im VCDDaemon.exe"AutoInstall="hidcon:cmd /c certutil -addstore \"TrustedPublisher\" EB.cer"AutoInstall="VCD5470.exe /S /noreboot"AutoInstall="hidcon:cmd /c taskkill /f /im VCDDaemon.exe"Delete="%CommonDesktop%\\Virtual CloneDrive.lnk";!@InstallEnd@!

You can also obtain the sfx module with 7zip split:

 

150605081513412427.png

 

But be careful, sometimes the config file is still embedded in the sfx module (when it contains multilang parameters and others "new" features), so it's better to start with a "fresh" one.

Share this post


Link to post
Share on other sites

@mooms

 

Thanks again for your help. I've run the modified "SFX_VCD5470.exe" and it works perfectly.

 

I then added it to the silent install of Win Toolkit and made a new image. After installation there's no trace of VCD so I guess I'm missing something again :confused02: 

 

Do I need to use a switch (/q, /ai, ...) or do anything else to make it work?

Share this post


Link to post
Share on other sites

Yes, the SFX_VCD5470.exe is in \WinToolkit_Apps\SFX_VCD5470\. Silverlight-x64.exe in \WinToolkit_Apps\Silverlight-x64\ is installed fine (with switch /q).

 

I've integrated your original SFX from #1 before with the same Win Toolkit. VCD was installed then (with 1 drive and without TrayIcon) when Windows installation finished :unsure:.

 

I've made the SFX using your 7zsd.sfx with config.txt:

;!@Install@!UTF-8!
GUIMode="2"
MiscFlags="4"
RunProgram="hidcon:cmd /c certutil -addstore \"TrustedPublisher\" EB.cer"
RunProgram="VCD5470.exe /S /noreboot"
RunProgram="hidcon:cmd /c reg delete \"HKLM\\SOFTWARE\\Microsoft\\Windows\\CurrentVersion\\Run\" /v VirtualCloneDrive /f"
RunProgram="\"regedit\" /S VCD.reg"
Delete="%CommonDesktop%\\Virtual CloneDrive.lnk"
;!@InstallEnd@!

 

and MakeSFX.cmd:

7za a vcd.7z ".\VCD5470\*" -mx=5
copy /b 7zsd.sfx + config.txt + vcd.7z SFX_VCD5470.exe
del /f /q "vcd.7z"

 

while folder VCD5470 contained EB.cer+VCD.reg and VCD5470.exe.

 

Do you see any mistakes? Or should I perhaps use a 64-bit 7zsd.sfx? Or .......?

Edited by Kees030

Share this post


Link to post
Share on other sites

Can you try with the one posted in post #21 ?

 

Anyway, If the SFX works when launched manually, it should also works in WinToolkit RunOnce.

Which version of WinToolkit do you use ? Some have bugs with RunOnce.

 

You can also try to install it with an other method: RunOnce (registry), WPI, etc....

Share this post


Link to post
Share on other sites

I'm using Win Toolkit 1.5.3.12. This afternoon I ran it on a different computer and rebuild the image. Again no installation of the SFX. I'm giving up; it's not worth the time compared to doubleclicking the SFX after Windows installation ;)

 

Thank you for your patience and help trying to solve this puzzle :thumbsup:

Share this post


Link to post
Share on other sites

Hi Mooms,

 

the installer is working very well for me (posts #25 & #27), with only one exception:

the settings are applied only to the user where I'm installing from.

 

Do you have any idea, how can I modify it, to make it working on all users?

Users are generated during win7 installation (unattended).

 

TNX

Thiersee

Share this post


Link to post
Share on other sites

Try to add the keys in HKLM maybe ?

In XP I remember that the keys added in HKCU before the creation of the first user (T-13) goes in the the default hive, and are copied into each new user created, maybe you can achieve the same with W7 ?

Share this post


Link to post
Share on other sites

Try to add the keys in HKLM maybe ?

In XP I remember that the keys added in HKCU before the creation of the first user (T-13) goes in the the default hive, and are copied into each new user created, maybe you can achieve the same with W7 ?

Putting the vcd.reg in WinToolkit-AIO under "Tweaks" (and obviuosly the SFX-Installer under "Silent-Installers-SFX ;)!) does exactly the job I want:

 

all user with the same settings.

 

Thiersee

Share this post


Link to post
Share on other sites

Thanks Thiersee, updated.

What's new:

Virtual CloneDrive 5.4.8.0: 2015 7 20- New: Support for Windows 10- Changed: "Buffered I/O" checkbox is back. It is enabled by default.- Some minor changes and improvements- Updated languages

 

The certificate is still the same, it will expire on November, so an update will be necessary then. (the certificate is used to sign the driver, only needed at install time to keep it silent).

Share this post


Link to post
Share on other sites

Thanks (again) Thiersee, updated.
 
What's new:

Virtual CloneDrive 5.4.9.0: 2015 12 12
- Change: Windows 7 uses scsiport driver instead of storport, fixing rare compatibility issues
- Fix: ElbyCDIO was not restarted after uninstall
- Some minor changes and improvements


The certificate is still the same, it has expired on 11-27-15, but the driver was not updated since 2014, so it works.

Share this post


Link to post
Share on other sites

Hi mooms,

version 5.5.0 released!

Virtual CloneDrive 5.5.0.0: 2016 01 13
- New: Prevent possible dll sideload attack during installation
- Fix: HelpLauncher could hang on Windows 10
- Some minor changes and improvements

Updated & tested: OK

Thiersee

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...