Jump to content

Unattended Creator issues


Tjuh
 Share

Recommended Posts

1) Computer Name is not working, still asks me to enter a computername during installation.

 

2) Time Zone not working.

 

3) Selected AutoLogon with Administrator account, but during installation it still wants me to enter a username.

 

Everything else works as intended, altho I haven't tried the OEM and Misc. settings.

Link to comment
Share on other sites

Ok, here it is:

 

<?xml version="1.0" encoding="utf-8"?><!--Created by Win Toolkit v1.4.1.13--><unattend xmlns="urn:schemas-microsoft-com:unattend">    <settings pass="windowsPE">        <component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <UserData>                <AcceptEula>true</AcceptEula>                <ProductKey>                    <Key>RHPQ2-RMFJH-74XYM-BH4JX-XM76F</Key>                <WillShowUI>Always</WillShowUI>                </ProductKey>            </UserData>        </component>        <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <UserData>                <AcceptEula>true</AcceptEula>                <ProductKey>                    <Key>RHPQ2-RMFJH-74XYM-BH4JX-XM76F</Key>                <WillShowUI>Always</WillShowUI>                </ProductKey>            </UserData>        </component>    </settings>    <settings pass="specialize">        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <ProductKey>RHPQ2-RMFJH-74XYM-BH4JX-XM76F</ProductKey>            <ComputerName>PCTjuh</ComputerName>        </component>        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <ProductKey>RHPQ2-RMFJH-74XYM-BH4JX-XM76F</ProductKey>            <ComputerName>PCTjuh</ComputerName>        </component>        <component name="Microsoft-Windows-Security-SPP-UX" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <SkipAutoActivation>true</SkipAutoActivation>        </component>        <component name="Microsoft-Windows-Security-SPP-UX" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <SkipAutoActivation>true</SkipAutoActivation>        </component>    </settings>    <settings pass="oobeSystem">        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <Display>                <ColorDepth>32</ColorDepth>                <HorizontalResolution>1024</HorizontalResolution>                <VerticalResolution>768</VerticalResolution>                <RefreshRate>75</RefreshRate>            </Display>            <OOBE>                <HideEULAPage>true</HideEULAPage>                <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>                <NetworkLocation>Home</NetworkLocation>                <ProtectYourPC>3</ProtectYourPC>            </OOBE>            <RegisteredOwner>Tjuh</RegisteredOwner>            <UserAccounts>                <AdministratorPassword>                    <Value>tjuh</Value>                    <PlainText>true</PlainText>                </AdministratorPassword>            </UserAccounts>            <AutoLogon>                <Password>                <Value>tjuh</Value>                <PlainText>true</PlainText>                </Password>                <Enabled>true</Enabled>                <LogonCount>9999999</LogonCount>                <Username>Administrator</Username>            </AutoLogon>            <TimeZone>W. Europe Standard Time</TimeZone>        </component>        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <Display>                <ColorDepth>32</ColorDepth>                <HorizontalResolution>1024</HorizontalResolution>                <VerticalResolution>768</VerticalResolution>                <RefreshRate>75</RefreshRate>            </Display>            <OOBE>                <HideEULAPage>true</HideEULAPage>                <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>                <NetworkLocation>Home</NetworkLocation>                <ProtectYourPC>3</ProtectYourPC>            </OOBE>            <RegisteredOwner>Tjuh</RegisteredOwner>            <UserAccounts>                <AdministratorPassword>                    <Value>xxx</Value>                    <PlainText>true</PlainText>                </AdministratorPassword>            </UserAccounts>            <AutoLogon>                <Password>                <Value>xxx</Value>                <PlainText>true</PlainText>                </Password>                <Enabled>true</Enabled>                <LogonCount>9999999</LogonCount>                <Username>Administrator</Username>            </AutoLogon>            <TimeZone>W. Europe Standard Time</TimeZone>        </component>    </settings></unattend>
Link to comment
Share on other sites

As for timezone problem, try to move it from: <settings pass="oobeSystem"> to: <settings pass="specialize">
 

    <settings pass="specialize">        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">            <TimeZone>FLE Standard Time</TimeZone>            <DisableAutoDaylightTimeSet>false</DisableAutoDaylightTimeSet>            <RegisteredOrganization>DarkTech</RegisteredOrganization>            <RegisteredOwner>Etz</RegisteredOwner>            <ComputerName>Maximus</ComputerName>        </component>

"oobeSystem" is not wrong by documentation, but I personally never got it working in this pass...

Edited by Etz
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...