Jump to content
Fragbert

1.4.45.5 - Unable to mount any WIM

Recommended Posts

I am really baffled as to why I can no longer mount *any* WIM after upgrading to 1.4.45.5. I made sure AV is disabled, have plenty of free space available on C:\, and run Wintookit.exe as an administrator. Never had a single problem mounting before on a setup that has not changed in years. I even tried using an older version of wintoolkit, 1.4.37.20 to no avail. Is there something obvious I am overlooking? Rights to the temp space have never been altered. Any ideas?

 

Attached is a screenshot and a image link just in case this doesn't show up.

vuNPlLW.png

post-9632-0-88196700-1405973093_thumb.pn

Share this post


Link to post
Share on other sites

Are the WinToolkit temp folders empty when you start? Perhaps there are leftovers from a failed dismount that need to be manually deleted.

 

Clark.

Share this post


Link to post
Share on other sites

What other temp folders are used other than the one I observe created on C: ? (C:\Wintoolkit_mount)

I delete that manually and there is over 60GB of free space.

Share this post


Link to post
Share on other sites

Updated to 1.4.46.1, still the same results.

 

Also took note of the temp folders created in Windows\Temp - the 7z and Imagex files all have full access permissions, and are purged after I get the error and close out. A folder in Windows\Temp does remain after; C:\Windows\Temp\WinToolkit_ImagexTemp_1CBEF69C35AD52A116BD5E2CCEC0054D

 

But that folder is empty and I delete that manually just in case. Still no dice! What in the world happened? The only recent change I have made on the rig is installing the newer version of DISM that Wintoolkit prompted me to download on 1.4.45.5. I think the last time I was able to successfully mount a WIM was before installing that. I have since uninstalled DISM, but that did not fix anything. Baffling!

Share this post


Link to post
Share on other sites

I'm in the same situation, Getting very frustrated with it. I've removed the latest version of Wintoolkit, no difference then remove DISM which it updated the other day. Reinstalled WTK 1.4.46.1 to a new location & moved the wintoolkit temp folder. I thought it was maybe my most recent image that was causing it so used the original untouched Win7 ISO & didnt make any changes to it, just clicked start to redo it & it still says 'Win Toolkit was unable to mount an image!' I've tried clicking on save to clipboard & text file but it says wintoolkit has stopped responding & I have to end task.  It does go through the sequence of rebuilding the image but doesn't make any changes to it. Below is what it I copied & pasted from the error log. looks the same as the log file above.

 

Starting
Output: ImageX Tool for Windows
Output: Copyright © Microsoft Corp. All rights reserved.
Output: Version: 6.2.9200.16384
Output: ERROR: Unable to use specified log file.
Output: Mounting: [D:\Wintoolkit\May\sources\install.wim, 7] -> [C:\WinToolkit_Mount]...
Output: [   0% ] Mounting progress 
Output #1: [   0% ] Mounting progress 
Output #2: [   0% ] Mounting progress 
Output #3: [   0% ]
Output #4: 
Writing Status T: [   0% ] | PT: 
Done Status
Writing Taskbar
Done Taskbar
Output: Error mounting image.
Output: The system cannot find the path specified. 
Finished
Edited by techmobile

Share this post


Link to post
Share on other sites

I think the problem is DISM. It's the only variable, as everything else is constant.

 

To be precise, I think the extracted DISM that wincert.net hosts on their servers, and the one that WinToolkit references to for updates, is... botched, or corrupted in some way. For I too have these same problems, literally exactly the same; I have used WinToolkit in the past (1.4.44.4 (helluva version name lol)) and everything all worked, mostly anyways. No mounting issues like here. Just started using it again today, and the first thing I did after loading up WinToolkit was install the new version of DISM that it led me to. It's been the same story since then. 

 

I'll upload my 4 logs here, 2 from 1.4.44.4, 2 from 1.4.47.2. Differing versions of DISM were used, as well as the tool being either AIO/WIM-Manager. Hope it helps.

 

I also noticed something else when renaming the WinToolkit folder: it seemed to be in use by a (ghost?) process, and I was unable to rename it. I checked task manager; nothing out of the norm seemed to be there.

 

I might give it a try with a different version of DISM sometime later.

 

~Took

 

Edit: So I rebooted and the ghost process holding the WinToolkit folder was gone. WinToolkit is still unable to mount images though, and I've checked several temp locations too. Test version 1.5.0.15 worked though, producing an image that was corrupted and threw an error message during windows install (that said it was corrupted lol), and then failing to mount images thereafter, just like all the other builds. Have not tried a different version of DISM yet.

wintoolkit forum upload.rar

Edited by PeregrinTook

Share this post


Link to post
Share on other sites

Please let me know how another version of DISM works :)

 

Unable to use specified log file.

 

The system cannot find the path specified. 

 

That maybe be due to the temp folder not being available. I will add some more logging to help find the culprit.

 

EDIT: Try disabling Mount Logs in options

EDIT 2: Please try the latest test version (v1.5.0.16)

Share this post


Link to post
Share on other sites

I've fixed the issue with mount logs so you can enabled it again. Do you have anything like TeamViewer or something which allows me to watch what you are doing really? :)

Share this post


Link to post
Share on other sites

After several runs this started happening to me. Using latest version of win toolkit and DISM

Tried loading different presets, no presets, deleted folders, nothing is working. I guess you never tracked down this bug or gave up on it?

Edited by lovs2build

Share this post


Link to post
Share on other sites

HI Thanks for your reply.

I am using one from your link, 8.1. I hate to give on on this as I finally got the feel of it, building addons, getting everything working good. I made 4 other test builds that installed nicely. Was in process of adding my addons I made and couple other programs for slient install, not to mention the 11 hours to intergrate 400+ updates :( . really hope we can figure this out.

Thanks!

Share this post


Link to post
Share on other sites

Have you tried uninstalling the one provided via the link and use the one built in with Windows?

 

I should have some time tonight to get some testing on this done :)

Share this post


Link to post
Share on other sites

I went to remove it and I remembered that I installed Windows Assessment and Deployment Kit. I removed it along with DISM update and it works again. Don't know if maybe others that were having trouble might have that installed, maybe try removing it and seeing?

 

Anyways it is mounting again so I can finish my Windows 7 custome build using your great program!

Thanks again for relying and opening my eyes to other reasons why it might have stop working.

Edited by lovs2build

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...