Jump to content

XP/W2k3 x86 on Modern Hardware


George King
 Share

Recommended Posts

1 hour ago, SKOL said:

Hey guys!

Do any of you have a way to get the usb ports to work on the z170mocf? I can install xp easily, everything works except usb which wouldn't be a big problem, but I'd need at least one usb port to work so I can transfer screenshots for hwbot. :) 

Image builded by XP2ESD v1.6 should work without issues :)

Link to comment
Share on other sites

9 hours ago, George King said:

If there will be any issue please post it in that topic :) I hope it will work :)

Yes it did work finally. :D 

I made a macrium image for the os I made if anybody wants to run some superpi or wprime without messing around with drivers: Z170SPI32M :) 

Edited by SKOL
Link to comment
Share on other sites

Posted (edited)

@skulltrail XP2ESD v1.6 contains already working Generic SD/MMC driver ported from Windows 8.0 build 8056! I have added few blanks stubs into Extender and Mov AX, 0xDEAD added correct implemententaion for IoSynchronousCallDriver

 

Image-1.png

 

Here are latest sources for extender

https://msfn.org/board/topic/181615-ntoskrnl-emu_extender-for-windows-xp2003/?do=findComment&comment=1222267
Edited by George King
Link to comment
Share on other sites

15 hours ago, George King said:

@skulltrail XP2ESD v1.6 contains already working Generic SD/MMC driver ported from Windows 8.0 build 8056! I have added few blanks stubs into Extender and Mov AX, 0xDEAD added correct implemententaion for IoSynchronousCallDriver

 

Image-1.png

 

Here are latest sources for extender

https://msfn.org/board/topic/181615-ntoskrnl-emu_extender-for-windows-xp2003/?do=findComment&comment=1222267

Hello friend! Well, i need take a time to make a custom ntoskrnl_emu for One-Core-API, because the main not working. It's occours because ntoskrnl_emu use a method to get address from some internal functions on kernel and as one-core-api use a custom kernel, the address are different. And, i tried transplant ntoskrnl_emu functions to one-core-api kernel and drivers (like USB 3.0) not working. I need time to investigate.

Link to comment
Share on other sites

On 7/21/2022 at 7:12 AM, skulltrail said:

 

 

On 7/21/2022 at 7:12 AM, skulltrail said:

Hello friend! Well, i need take a time to make a custom ntoskrnl_emu

I am just beginning to analyze the requirements of the extender by Mov AX, 0xDEAD ...I don't know how openly we can discuss this here since some of it will require  discussion of reverse engineering. I was at win-raid when it was shut down for something similar..

I have a fair amount of experience with reversing and that's the main reason I can understand the extender from an OS point of view. Any way we can discuss this in more detail?

On another site, we got around that by not discussing specific software.

 

Edited by gordo999
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...