Jump to content

XPtsp GUI v3.0.0.26 - February 27, 2012


dougiefresh
 Share

  

46 members have voted

  1. 1. What language OS do you use XPtsp on?

    • English
      28
    • non-English
      12
    • Both English and non-English
      6

This poll is closed to new votes


Recommended Posts

They're all listed here: http://www.boooggy.org/slipstreamer/#hotfixes

Or do you want me to upload the whole batch of files?

I've tried to download the patches via the links on the website, but there are certain patches that I wasn't able to download. So uploading the whole batch of files would be appreciated. Thanks in advance and I apologize about the inconvenience that my request may cause.

EDIT: Did the new version fix the bootscreen issue?

Link to comment
Share on other sites

I'm starting my testing up to try to isolate the problem. Hopefully, I'll have an answer or two shortly....

EDIT (12 hours later): I've built a single XP Home install with the UpdatePack, IE8 add-on, and Booogey's WMP11 slipstreamer as specified by Mr_Smartepants. Made a copy and integrated the batch into one and the GUI with no add-ons into the other. Both source folders were installed in a VM with success. So I'm sure that the problem Mr_SmartePants found is an add-on related issue.

Link to comment
Share on other sites

Results So Far: I've used the GUI to integrate the resources into a XP Home Edition source with the "Program Resources" group checked without any other add-on included. This includes the repatcher, the OEM info generator and resources used in the XP source. The VistaPix and Fonts/Cursors addon is included via the Extra's group. The repatcher's INF didn't properly refer to one of the files in the CAB file, which may have broke the XP install.

But I've got more testing to do to confirm other add-ons aren't breaking the installation, so if anything else is broken, hopefully I'll find it quickly....

EDIT: It also occurs to me that I need to repack the CAD2009 add-on in order to replace the background that it uses. After all, if you are using a non-Green theme, does it really make sense to have a green background for the Vista-like Ctrl-Alt-Delete program?

Link to comment
Share on other sites

Testing: I've completed my testing with the OnePiece UpdatePack, OnePiece IE8 and Boogey's WMP11 Slipstreamer. With the exception of the repatcher INF error made in version 2.0.1.1, I cannot find an issue with any of the add-ons that might be breaking the script. WMPENC.EXE remains in every scenario that I've run, and I can confirm that the GUI does not modify the WMP INF file.

Other: Because the SFX will not pass the path to the script under Vista, I'm rewriting the Theme Selection page in order to be able to browse for themes. It will list both the online and any local themes it finds, as well as tell you whether the local theme is up to date or not. This modification will help me with the testing of the script, as I will be able to use my local copies instead of downloading the themes in order to use them. Once the modification is complete, I'll upload the new version.

I've had to move some pages around in the script in order to make room for new features as previously discussed. Page 7 will contain the code for downloading the Extra package. Page 9 will contain the code for downloading theme modifications, such as the different color AVIs for moving files.

In addition, the language file has been reorganized to match the script organization. Here is a quote of the current changes to the language file:

Moved all strings starting with "P_11" to "P_13", "P_10" to "P_12", "P_09" to "P_11", "P_08" to "P_10", and "P_07" to "P_08" to match actual page organization. Added strings "P_06m1" thru "P_06n".

I'm also working on modding the script in order to change the CAD2009 add-on so that it matches the current theme.

UPDATE: I figured out that if I right-click on the SFX and select "Run As Adminstrator", the SFX does pass the path to the script.

Link to comment
Share on other sites

OK, tested with an XP Pro source, with the UP, IE8 addon, WMP11 integrator. After integration, I copied the source to another folder and integrated Rick's MCE addon into this duplicate source.

The ONLY difference between the two sources was the addition of the MCE addon to one of the folders.

Integrated XPtsp 2.0.0.4 (downloaded fresh "green.7z") into both sources and built two .iso files.

Tested in VirtualBox

XP Pro worked perfectly. WMP11/IE8 worked/looked perfect.

XP Pro/MCE crashed with the following error at first user setup.

2hpm6fk.png

Hope this helps you a bit more.

*Edit

Rick just updated his MCE addon. I've retested using the updated addon and this issue still persists. Without using XPtsp GUI, this addon works without error.

What WMP addon do you use Mr_S?

It could be the quotes need fixin

Link to comment
Share on other sites

The command that seems to be the cause of the problem is contained in wmp.inf

[Run.PUI]

"%16422%\%MP2_FOLDER%\WMPEnc.exe /RegServer"

But I'm at a loss as to what's actually causing the problem. It seems to be referenced correctly. :?

Unless it needs a double-quote (because of the double string usage) like this line:

"""%16422%\%MP2_FOLDER%\WMPNetwk.exe"" install"

*Edit

Well that didn't work! :(

Adding the double quotes only changed the error text. The file is still not being found because it doesn't exist.

2ev6tew.png

16aqlpk.png

I imagine that the file-copy process for some wmp11 files is being broken along the way somewhere.

Edited by Mr_Smartepants
Link to comment
Share on other sites

Yup, the wmp11ext.inf is somehow being broken.

None of the files in the section WMPlayer.Copy are extracted from wmp11.cab to the correct destination.

INF clipped to relevant sections:


[SourceDisksNames.x86]
1 = "Windows Media Player Files",wmp11.cab,,I386

[DestinationDirs]
WMPlayer.Copy = 16422,%WMPFOLDER%

[WMPlayer.Copy]
wmdbexport.exe
wmlaunch.exe
wmpenc.exe
wmpnetwk.exe
wmpnscfg.exe
wmpnssci.dll
wmpshare.exe
wmsetsdk.exe
LegitLibM.dll
eula.txt

[Strings]
WMPFOLDER = "Windows Media Player"

*Edit

I just noticed you updated the GUI to 2.0.1.2. I'll download that and try it to see if it's fixed.

*Edit 2

Nope, 2.0.1.2 still has the problem. :(

Edited by Mr_Smartepants
Link to comment
Share on other sites

What's Changed in v2.0.1.2:

- Reorganized the Language file to match new page structure in script.

- Live Install is unavailable when running GUI on a x64 operating system.

- OS restriction relaxed so that XP Gold and SP1 can be patched using the GUI.

- Last folder browsed is remember for Source Selection and Theme Selection.

- Modified Theme Selection page so that local copies are compared to online themes.

- Modified Theme Selection page to allow user to browse to unlisted theme.

- Added check to Theme Selection page to verify theme has been extracted properly.

- Downloaded theme package have a theme extension instead of 7z.

- Modified download code so that file size is correctly shown.

- Modified repatcher INF so that all files are copied correctly.

Mr_Smartepants: Are you using the latest WMP11 Slipstreamer? Booogey's most current version as of this writing is 1.4.2.0. If the slipstreamer you have isn't the latest, I would make the recommendation to try the latest version because I can't reproduce the error.

Link to comment
Share on other sites

Yup, wmp11 slipstreamer is 1.4.2.0.

What I don't understand is why I'm having the failure with Home/MCE but Pro works fine. :|

I'll rebuild my source manually. Maybe AutoImage is introducing an error somewhere.

My AutoImage config file:

[Disc]

SourcePath=C:\Tools\XP\Projects\XPHO

DestinationPath=C:\Tools\XP\Projects\XPHO

ApplyServicePack=False

[Options]

Uppercase=True

[RyanVM]

RVMUPD=C:\Tools\XP\AutoImage\UpdatePack\XPSP3_QFE_UpdatePack_1.1.4_20091125-ReCabbed.zip

Optimize=True

Cached=True

WPI=Off

[WMP]

Installer=C:\Tools\XP\AutoImage\WMP11\wmp11-windowsxp-x86-enu.exe

Output=Normal

Icon=Boooggy

[nLite]

RunNlite=True

Config=C:\Tools\XP\AutoImage\Config\Last Session(Home).ini

[XPize]

RunXPize=False

RunOnceEx=False

[DriverPacks]

RunDPB=False

Config=

[iSO]

GenerateFile=True

Path=C:\Tools\XP\ISO

Filename=GRTMP_EN.iso

VolumeLabel=GRTMP_EN

Options=-J -untranslated-filenames -no-iso-translate -D -no-emul-boot -b boot.bin -hide boot.bin -hide boot.catalog -hide-joliet boot.bin -hide-joliet boot.catalog

EncodeDupOnce=False

[RVMAddons]

Kels_Runtimes_addon_v6.rar=C:\Tools\XP\AutoImage\RVM\Addons

PatchAddon_HIVESYS_v13c.cab=C:\Tools\XP\AutoImage\RVM\Addons

PatchAddon_SFC_OS_v14.7z=C:\Tools\XP\AutoImage\RVM\Addons

PatchAddon_SYSSETUP_InfSkip_v14.7z=C:\Tools\XP\AutoImage\RVM\Addons

PatchAddon_TCPIP_100_v14d.7z=C:\Tools\XP\AutoImage\RVM\Addons

PatchAddon_UXTHEME_v14a.7z=C:\Tools\XP\AutoImage\RVM\Addons

[WMPhotfixes]

windowsmedia11-kb928788-x86-intl.exe=C:\Tools\XP\AutoImage\WMP11

windowsmedia11-kb929399-v2-x86-intl.exe=C:\Tools\XP\AutoImage\WMP11

windowsmedia11-kb929773-x86-intl.exe=C:\Tools\XP\AutoImage\WMP11

windowsmedia11-kb932390-x86-intl.exe=C:\Tools\XP\AutoImage\WMP11

windowsmedia11-kb933547-x86-intl.exe=C:\Tools\XP\AutoImage\WMP11

windowsmedia11-kb935551-x86-intl.exe=C:\Tools\XP\AutoImage\WMP11

windowsmedia11-kb935552-x86-intl.exe=C:\Tools\XP\AutoImage\WMP11

windowsmedia11-kb939209-x86-intl.exe=C:\Tools\XP\AutoImage\WMP11

WindowsMedia11-KB939683-x86-ENU.exe=C:\Tools\XP\AutoImage\WMP11

windowsmedia11-KB941569-x86-ENU.EXE=C:\Tools\XP\AutoImage\WMP11

windowsmedia11-kb944882-x86-intl.exe=C:\Tools\XP\AutoImage\WMP11

windowsmedia11-KB952069-x86-ENU.exe=C:\Tools\XP\AutoImage\WMP11

windowsmedia11-kb954067-x86-intl.exe=C:\Tools\XP\AutoImage\WMP11

windowsmedia11-kb954069-x86-intl.exe=C:\Tools\XP\AutoImage\WMP11

windowsmedia11-KB954154-x86-ENU.exe=C:\Tools\XP\AutoImage\WMP11

WindowsMedia11-KB954155-x86-ENU.exe=C:\Tools\XP\AutoImage\WMP11

WindowsMedia11-KB968816-x86-ENU.exe=C:\Tools\XP\AutoImage\WMP11

windowsmedia11-kb973442-x86-intl.exe=C:\Tools\XP\AutoImage\WMP11

windowsmedia11-KB973540-x86-ENU.exe=C:\Tools\XP\AutoImage\WMP11

[installers]

dotnetfx.exe|-ai1=C:\Tools\XP\AutoImage\Installers

Edited by Mr_Smartepants
Link to comment
Share on other sites

I'm using CDIMAGE in order to build my ISO's for testing. I've attached the program and the XP.BIN file that I use in order to build the ISO.

Command line parameter:

CDIMAGE -bXP.BIN -h -n -o -m [ISO folder] [ISO name].iso

I hope this helps...

BAH HUMBUG! I messed up an INF and it's discovery led me to remove v2.0.1.2 from the server. I discovered it during a VM test.

Edited by dougiefresh
Added BAH HUMBUG message
Link to comment
Share on other sites

Ooh, is it at all related to my problem?

I had done some modification to the CAD2009 add-on in preparation for the background change I was planning on doing. I forgot that I had made that change and the GUI will break the XP install because of those bad changes. Once I added the file to the XP ISO, the install went fine and the XP Home Edition that had been modified using the GUI continued to install. Everything was usable after OOBE.

I am preparing to release v2.0.1.3, which has a few more modifications than v2.0.1.2. However, I still can't reproduce the issue that you found.

I do have a question for you: During the XP install, does the GUI setup prompt for the location of ANY files, and if so, what do you do about it? I ask because if you hit Cancel on any file, then that screws up the install for some dumb-ass reason. I need to know what file is being prompted for in order to solve the issue (if any and if possible).

Link to comment
Share on other sites

What's Changed in v2.0.1.3:

- Rewrote the large image preview code for Theme Selection.

- Reverted CAD2009.INF back to version 2.0.0.4 to undo editing that I did.

- Updated XPTSP.INI with new file locations for future file patching.

- Re-included latest DSI (v5.3.7.1), as last version was out-of-date.

Link to comment
Share on other sites

I do have a question for you: During the XP install, does the GUI setup prompt for the location of ANY files, and if so, what do you do about it?

Nope, I am never prompted for the location of that file. I only get the warning, then all subsequent .inf installs through GUIrunonce are broken.

Oh, btw, the download speed is fixed now. :)

*Edit,

Found a bug. Causes a "invalid parameter passed to xptsp.exe" error.

In XPtspCom.cab the addrunonceexe.bat has an extra trailing backslash.

REG ADD %KEY%\987 /V 1 /D "\"%PP%\XPtsp.exe\" LASTMIN:\"%1\"" /f

should be

REG ADD %KEY%\987 /V 1 /D "\"%PP%\XPtsp.exe" LASTMIN:\"%1\"" /f

Edited by Mr_Smartepants
Link to comment
Share on other sites

I'm running a test now with 2.0.1.3 on a bare Home SP3 using U_H updatepack, IE8 addon and WMP11 with no other addons and came across this error. :?

16gapf8.png

Other than the above error, the install completed without issue. So my problem must be caused by something else. :(

The bad news though is that the boot screen is unchanged from the original XP. :(

During integration though I am getting this error after driver.cab is repacked.

kbaelv.png

Edited by Mr_Smartepants
Link to comment
Share on other sites

Well I was wrong with my code adjustment above.

The original line causes a "invalid parameter passed to xptsp.exe" error.

REG ADD %KEY%\987 /V 1 /D "\"%PP%\XPtsp.exe\" LASTMIN:\"%1\"" /f

My adjusted line doesn't make a reg entry at all. :(

REG ADD %KEY%\987 /V 1 /D "\"%PP%\XPtsp.exe" LASTMIN:\"%1\"" /f

Link to comment
Share on other sites

This last week or so, I've been doing testing in my free time, trying to figure out why the bootscreen issue happens. It was quite baffling why the correct resources weren't applied (despite reorganizing the code in order to apply the steps in the right order) until Fixit notified me that he had uploaded a new red theme. He said that he fixed the bootscreen res files and that I should try it with the new theme package. So I did, and lo-and-behold, IT WORKS!! WOO-HOO!

So, I am in the process of fixing the other themes that are available on the server. I will also upload the new XPtsp GUI, as it has many changes that were inspired by both Fixit and Bober. It also addresses a few annoyances that I've encountered regarding ISO creation, as well as the theme package copying issue and the RunOnceEx issue that Mr_Smartepants found last month.

Thanks to everybody who has contributed ideas and assistance to this latest version!

BTW: Version 2.0.1.4 will be the last version that will contain the "Extra" folder in the SFX. I am working on the new page that will download an "Extra"s package from the server, as well as download the latest DSI silent installer and .NET framework SVCPACK executable. In addition, the updating code will be changed to download the GUI SFX upon program updates. The new XPtsp GUI SFX will be approximately 2mb in size and will be copied to the SVCPACK folder instead of the files being packed by the GUI.

EDIT: Oh, yeah! I almost forgot! New screenshots are being made for most of the theme packages, starting with the Red theme. Once completed, each theme will have 12 screenshots, similar to what the Green theme has right now.

EDIT2: I actually started working on the download page while I was waiting for the GUI tests in the VM to complete. But the one thing that is holding up me posting the new themes is that I must write a new "theme builder uploader" application. It will be responsible for compiling necessary information in order to post a COMPLETED theme on the server....

Edited by dougiefresh
Link to comment
Share on other sites

What's Changed in v2.0.1.4:

- Upgraded ResHacker to latest version, which includes 64-bit support.

- Modified packing script to include version info in the SFX.

- Integration: Last Source Folder used if i386 folder not found in SFX folder.

- Modified Source Page to allow user to copy to another folder and use that.

- When duplicating source, user is allowed to copy only i386 folder.

- Rewrote theme selection combo-box code on Theme Selection page.

- "Package Info" window shows month day, year instead of mm-dd-yyyy.

- Theme Selection page now records path to theme package for later user.

- Integration/Install code modified to use saved theme package path.

- Removed version 2.0.1.2 modifications to repatcher INF.

- Modified last-minute patching code to correct the bootscreen patching issue.

- Integration: Added Back button to Finished page.

Link to comment
Share on other sites

 Share

×
×
  • Create New...