Jump to content

Windows 7 Toolkit v1.0.2 FINAL


Legolash2o
 Share

Recommended Posts

I still have a problem when I put the "change the setup backround" installing sto erros. "Corrupt autorun" etc.

x:\Sources\SPWIZIMG.DLL is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact ......."

The file autorun.dll could not be loaded or is corrupt. Setup cannot continue. Error code is (0xE0000 100)

Tested Virtualbox.

Can you please upload a unmodified 'x:\Sources\SPWIZIMG.DLL' to an external site please.

I can't use Restorator as it's trial software. Also don't try the tweak with Windows 8 until it's working on Windows 7. The tweaks seem to be working for everyone else.

Edited by Legolash2o
Link to comment
Share on other sites

Go to W7T Options and uncheck Verify Images and Check Images. Then save.

Although disabling 'Check Images' should speed up rebuilding on its own :)

EDIT: Looks like i found a but when disabling 'Check Images', ill fix it now.

EDIT: Fixed, will be in v5 which i will release soon.

Edited by Legolash2o
Link to comment
Share on other sites

v1.0.2-5F released.

You should notice an improve on the startup speed on this version, some new Tools Manager icons, they have been re-arranged in alphabetical order. Also their is now an option for 'Quicker Merging' which radically speeds up the Create AIO Disk tool and 'Merge Image' in WIM Manager however the wim may be bigger because it does not rebuild the original wim before adding the new one.

*FIX: Could not disable 'Check Images' option

*Updated splash screen

*W7T now starts faster

*Improved speed on 'Checking for Updates'

*Items re-arranged in alphabetical order on Tools Manager

Edited by Legolash2o
Link to comment
Share on other sites

just want to know Lego , that's all . i was interested to know if the masstorage drivers goes into boot.wim ..that's all..

and the dispaly, audio, ethernet and all other drivers goes into install.wim ...correct?!

Edited by Sorin
Link to comment
Share on other sites

Thank you for answering... i've only asked because i created a setup to run after windows is installed .. the setup contains all the driverpacks .

Edited by Sorin
Link to comment
Share on other sites

ChiefZeke for some reason the packages program i use to show hidden packages does not like spaces in the mount path ie.

C:\W7T\Mount, seems to be ok

C:\W7T\Test Mount 1, seems to error.

EDIT: I have used the source code of that program to fix the issue, it should now support spaces on the next version. Hopefully :P

So, even though I had enclosed things in double quotes, ""**"", to comply with DOS rules about no spaces you're saying that is incorrect also - have yet to check new version as I'm in XP right now, but I thought I'd ask about the double quotes while here; for my own edification.

Your second example, above, I would think would work as: "C:\W7T\Test Mount 1" ?

Link to comment
Share on other sites

W7T automatically added quotes, but even if you had used them for the other program it would not work, luckily someone provided me the source code on another topic and i managed to modify it and fix a bunch of bugs.

Double quotes and normal quotes just did not work but it should work now. The external program open another command prompt tool and it did not add the quotes.

So is it all working properly now?

Edited by Legolash2o
Link to comment
Share on other sites

W7T automatically added quotes, but even if you had used them for the other program it would not work, luckily someone provided me the source code on another topic and i managed to modify it and fix a bunch of bugs.

Double quotes and normal quotes just did not work but it should work now. The external program open another command prompt tool and it did not add the quotes.

So is it all working properly now?

W7Toolkit 1.0.2.6?(10) and Win7 Ultimate 64-bit w/SP1

Component Removal > Win7 Ultimate > Select > Mount > 102 items were listed

Problem solved

Link to comment
Share on other sites

v1.0.2-7F, some very important fixes... Also there is a bunch of links added to the 'Download' menu on the main tool selection screen.

*FIX: Did not detect currently mounted images on non-English language

*FIX: Did not display 'unknown' packages properly in Component Remover)

*FIX: Capture Image did not work when drive root was selected

EDIT: Build 8 released with a fix to unattended creator, it now only shows current serial key when you edit the Serial Key instead of all inputboxes.

Edited by Legolash2o
Link to comment
Share on other sites

See the end of this message for details on invoking

just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************

System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.VisualBasic.PowerPacks.Vs, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

File name: 'Microsoft.VisualBasic.PowerPacks.Vs, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'

at W7T.frmOptions.InitializeComponent()

at W7T.frmOptions..ctor()

at W7T.frmToolsManager.mnuOptions_Click(Object sender, EventArgs e)

at System.Windows.Forms.ToolStripItem.RaiseEvent(Object key, EventArgs e)

at System.Windows.Forms.ToolStripMenuItem.OnClick(EventArgs e)

at System.Windows.Forms.ToolStripItem.HandleClick(EventArgs e)

at System.Windows.Forms.ToolStripItem.HandleMouseUp(MouseEventArgs e)

at System.Windows.Forms.ToolStrip.OnMouseUp(MouseEventArgs mea)

at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)

at System.Windows.Forms.Control.WndProc(Message& m)

at System.Windows.Forms.ToolStrip.WndProc(Message& m)

at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)

at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

WRN: Assembly binding logging is turned OFF.

To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.

Note: There is some performance penalty associated with assembly bind failure logging.

To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

************** Loaded Assemblies **************

mscorlib

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.5444 (Win7SP1GDR.050727-5400)

CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll

----------------------------------------

W7T

Assembly Version: 1.0.2.9

Win32 Version: 1.0.2.9

CodeBase: file:///C:/Users/A/Desktop/W7T102-9F/W7T.exe

----------------------------------------

System.Windows.Forms

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll

----------------------------------------

System

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.5660 (QFE.050727-5600)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll

----------------------------------------

System.Drawing

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll

----------------------------------------

System.Configuration

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll

----------------------------------------

System.Xml

Assembly Version: 2.0.0.0

Win32 Version: 2.0.50727.5420 (Win7SP1.050727-5400)

CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll

----------------------------------------

************** JIT Debugging **************

To enable just-in-time (JIT) debugging, the .config file for this

application or computer (machine.config) must have the

jitDebugging value set in the system.windows.forms section.

The application must also be compiled with debugging

enabled.

For example:

<configuration>

<system.windows.forms jitDebugging="true" />

</configuration>

When JIT debugging is enabled, any unhandled exception

will be sent to the JIT debugger registered on the computer

rather than be handled by this dialog box.

this happens when i click on the w7toptions

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...