Jump to content

[Solved] v1.4.0.1 Errors


George King
 Share

Recommended Posts

Windows XP Mode fail

WindowsXPMode_cs-CZ.exe - Downloaded 2 day ago and the exe working 100%

EDIT:

Can you add some code for grouping LocalPacks? Like you made it for Internet Explorer 9?

EDIT2:

Integrated LocalPacks aren't visible. For enable these themes in personalization we need to copy .theme from %WIM%\Windows\Globalization\MCT\MCT-XX to %WIM%\Windows\Resources\Themes

EDIT3:

I selected extracted DVD folder, then i removed Home Basic, Premium and Professional without rebuilding. Then i go into AIO tool, selected updates and W7T rebuilded the image with folowing error message:

Description: Windows 7 ULTIMATE (Error)
Status: Integrating Update: 395 of 395 (IE9-Windows7-x64-csy.exe)
Exception: InvalidArgument=Value of '4' is not valid for 'index'.
Parameter name: index

Legolas2o: Not sure if this is fixed, but i've improved its error logging.

EDIT4:

Small bug with button size

Edited by Legolash2o
Link to comment
Share on other sites

So far i've added the LocalPack grouping however i don't have any to test it with :(

EDIT: IE9 doesnt have it's own group, it just gets put in a 'Priority' group so it gets installed first.

Edited by Legolash2o
Link to comment
Share on other sites

OK I see that XPMode gets inserted on top of the list as priority update

VirtualPC and Windows6.1-KB2652034-v2-x64 will be added on the buttom.

Although, it seems not possible to correctly move items up or down in the list of hotfixes and additions :

e.g. If I add IE9 (IE9-Windows6.1-KB2647516-x64.cab + Windows6.1-KB982861-x64.cab) to the bunch of other hotfixes already in my list, they get added on the buttom and I cannot move them on top by using the green or blue arrow buttons.

Link to comment
Share on other sites

KB2647516 needs IE9 to be installed first, which is why IE9 is in the priority list, as this makes sure IE9 is installed BEFORE you install Windows6.1-KB2647516-x64 and so on..

Priority is for 'Prerequisites'

Edited by Legolash2o
Link to comment
Share on other sites

thanks lego, but maybe I didn't explain very well before.

I know that IE9 is a prerequisite for KB2647516, but what I actually meant is that I cannot change the integration order of these two files (move them on top of the list in order to have them integrated before regular hotfixes).

Also, IE9 won't be placed in the priority section, only XPMode is.

Link to comment
Share on other sites

1. I know that IE9 is a prerequisite for KB2647516, but what I actually meant is that I cannot change the integration order of these two files (move them on top of the list in order to have them integrated before regular hotfixes).

2. Also, IE9 won't be placed in the priority section, only XPMode is.

1. Well i've just fixed an issue where you could not re-order priority updates, but i think what your explaining works fine for me. You can't add KB2647516 to the priority list (thats done on purpose) because why would you want it installed before IE9???

If you really want that update it be installed first then move it to the top or the normal list.

2. I'm assuming you was using the *.cab IE9? That now gets added to the priority list. :)

Do the local packs and XP mode have to be installed/integrated in a particular order (before/after the hotfixes)?

Thanks

Sorry missed this earlier, im not entirely sure, im fairly confident they can be installed in any order. :)

Edited by Legolash2o
Link to comment
Share on other sites

Sorry, but you still didn't get me right. Imagine the following scenario :

I have added all SoLoR x64 hotfixes to my list

then I add XPMode which automatically gets placed into the priority section

after that VirtualPC which gets placed on the buttom of the normal updates list

Finally, I add Windows6.1-KB982861-x64.cab which gets placed in the priority section and IE9-Windows6.1-KB2647516-x64.cab which goes to the buttom of the normal updates list.

The problem is that I cannot move IE9-Windows6.1-KB2647516-x64.cab anywhere above SoLoR's regular hotfixes;

edited according to v1.4.0.4

post-17864-0-90623100-1333059371_thumb.g

Edited by ulysse
Link to comment
Share on other sites

Sorry, but you still didn't get me right. Imagine the following scenario :

I have added all SoLoR x64 hotfixes to my list

then I add XPMode which automatically gets placed into the priority section

after that VirtualPC which gets placed on the buttom of the normal updates list

Finally, I add Windows6.1-KB982861-x64.cab which gets placed in the priority section and IE9-Windows6.1-KB2647516-x64.cab which goes to the buttom of the normal updates list.

The problem is that I cannot move IE9-Windows6.1-KB2647516-x64.cab anywhere above SoLoR's regular hotfixes;

edited according to v1.4.0.4

XPMode in Priority, correct.

Windows6.1-KB982861-x64.cab in Priority is correct because it's IE9.

IE9-Windows6.1-KB2647516-x64.cab in normal list is correct because it's an update for IE9 so should be installed after.

VirtualPC is needed for XP mode, so should go in the priority list, so thats in the wrong place.

"Finally, I add Windows6.1-KB982861-x64.cab which gets placed in the priority section and IE9-Windows6.1-KB2647516-x64.cab which goes to the buttom of the normal updates list."

Just select that update and press the top green arrow on the left. It should get installed first.

EDIT: Is virtualPC Windows6.1-KB958559-x64-RefreshPkg.msu?

Edited by Legolash2o
Link to comment
Share on other sites

Thanks for your answers

XPMode in Priority, correct.

Windows6.1-KB982861-x64.cab in Priority is correct because it's IE9.

IE9-Windows6.1-KB2647516-x64.cab in normal list is correct because it's an update for IE9 so should be installed after.

VirtualPC is needed for XP mode, so should go in the priority list, so thats in the wrong place.

Yes, that's all ok

"Finally, I add Windows6.1-KB982861-x64.cab which gets placed in the priority section and IE9-Windows6.1-KB2647516-x64.cab which goes to the buttom of the normal updates list."

Just select that update and press the top green arrow on the left. It should get installed first.

That's exactly where the problem is. I cannot move it on top, the green arrow has no effect.

I can only move it a couple of lines up or down with the blue arrows, but not above SoLoR's hotfixes

EDIT: Is virtualPC Windows6.1-KB958559-x64-RefreshPkg.msu?

Yes, Windows6.1-KB958559-x64-RefreshPkg.msu is VirtualPC

Edited by ulysse
Link to comment
Share on other sites

IE9-Windows6.1-KB2647516-x64

When i add the update, for some strange reason it appears as ("default") but i can easily move it up or down or to the top/bottom.

It won't go into the 'prerequisites/Priority' group as its not been programmed to do that :)

Edited by Legolash2o
Link to comment
Share on other sites

Haven't you have been able to reproduce the issue?

I agree, IE9-Windows6.1-KB2647516-x64 shouldn't go into the Priority group while it should still be movable within the Updates group (which I'm still unable to do in v1.4.0.6)

All updates but Language Packs and KB999158 and KB999159 appear as default in the name column here.

Edited by ulysse
Link to comment
Share on other sites

I started over with an all new W7T folder-configuration-preset and the problem of not being able to move IE9-Windows6.1-KB2647516-x64 anywhere above SoLoR's hotfixes is still there :(

Edited by ulysse
Link to comment
Share on other sites

Thanks for the video, when you cant move that file, do the other files become un-movable as well?

EDIT 1:I've finally been able to reproduce this problem :D How strange that it only happens to this update...

EDIT 2: This is a huge complicated issue, and will take some time thinking to figure it out, in the mean time add anything which goes in the priorities last and you should be able to move it fine :(

Edited by Legolash2o
Link to comment
Share on other sites

Thanks for looking into this issue.

KB2652034 and Language Packs are unmovable as well (move down ok, but not up above SoLoR's KBs), but maybe that is a feature.

When trying to move these files in v1.4.0.9 I now get an error message :

InvalidArgument=Value of '0' is not valid for 'index'.

Parameter name: index

Edited by ulysse
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...