Jump to content
gillesg

Update pack Office 2010 x86

Recommended Posts

Re,

Question à propos de ton script pour créer son pack : j'ai mis le script, le fichier Office 2010 - KB dates.txt, et les deux mises à jour téléchargées via WUD dans le même dossier, j'ai lancé le script, mais rien ne se passe, j'ai dû faire l'extraction des fichiers .msp manuellement. Pourrais-tu s'il te plaît détailler la façon de procéder pour que cela fonctionne ? Merci en tout cas pour le boulot !

Share this post


Link to post
Share on other sites

Re,

Question à propos de ton script pour créer son pack : j'ai mis le script, le fichier Office 2010 - KB dates.txt, et les deux mises à jour téléchargées via WUD dans le même dossier, j'ai lancé le script, mais rien ne se passe, j'ai dû faire l'extraction des fichiers .msp manuellement. Pourrais-tu s'il te plaît détailler la façon de procéder pour que cela fonctionne ? Merci en tout cas pour le boulot !

 

Bonjour,

 

Le script que j'ai proposé fait l'extraction des KB autres que le Service Pack. Un répertoire UPDATES-extract est créé dans lequel se trouve tous les fichiers extraits et nécessaire à la constitution du pack.

Pour extraire les fichiers du Service Pack, il faut utiliser la commande donnée dans le premier post.

officesp2010-kb2687455-fullfile-x86-fr-fr.exe /extract:<Répertoire> /quiet

Une autre remarque, le script contient des "pause". Il te faut donc peut-être valider par "Enter" le déroulement du script.

 

J'espère que cela t'aidera.

 

A+

Share this post


Link to post
Share on other sites

C'est bon, j'ai trouvé, j'avais mal nommé le fichier .txt.

ça marche nickel, merci !

 

Test effectué sur la version beta de Windows 8.1 en MV : la MAJ KB 2553092 est de nouveau demandée, alors que je l'avais incluse dans le dossier Updates.

http://support.microsoft.com/kb/2553092/fr

A noter que pour mon test, j'ai juste mis le contenu du pack SP2 et les deux mises à jour supplémentaires (kb 2553092 et 982726) dans le dossier updates (SP2 étant cumulatif du SP1, je ne pense pas qu'il soit utile de mettre aussi le contenu du SP1, la taille du dossier d'installation d'Office 2010 dépassant déjà 1,5 Go). Après vérification sur Word une fois l'installation achevée, c'est bien la version SP2 d'Office qui est annoncée, la 14.0.7015.1000 (32 bits).

Pas testé sur XP ou 7, mes versions sont déjà à jour.

Edited by rhahgleuhargh

Share this post


Link to post
Share on other sites

Hello,

Merci pour la mise à jour ! fonctionne impeccablement.

Est-ce normal de trouver aussi dans le pack d'octobre certaines MAJ d'Office 64 bit (au moins 2) ?

Attention, une fois toutes les MAJ décompressées et placées dans le même dossier, les plus récentes écrasent les anciennes des mois précédents.

Edited by rhahgleuhargh

Share this post


Link to post
Share on other sites

Hello,

Merci pour la mise à jour ! fonctionne impeccablement.

Est-ce normal de trouver aussi dans le pack d'octobre certaines MAJ d'Office 64 bit (au moins 2) ?

Attention, une fois toutes les MAJ décompressées et placées dans le même dossier, les plus récentes écrasent les anciennes des mois précédents.

Bonne remarque, C'est une erreur. Upload refait. C'est corrigé.

Share this post


Link to post
Share on other sites

mise à jour de novembre - test encore en cours

 

Il y a une difficulté avec WU et des updates de début 2013. Est-ce que d'autres personnes rencontrent ce problème ?

Share this post


Link to post
Share on other sites

Hello,

 

dans WUD on constate deux lien SP2 et sur Microsoft, il indique les deux versions en 64 bits :D

 

Voici la version 32 bits (Service Pack 2 pour Microsoft Office 2010 (KB2687455) Édition 32 bits)

 

http://www.microsoft.com/fr-fr/download/details.aspx?id=39667

 

 

Le mieux est d'utiliser une VL ou RTM ? car j'ai une VL ^^

 

J'extrait l'iso, j'intègre la langue, le sp1, le sp2 puis les maj de aout a octobre (vue que novembre est en test) et je ne garde que les fichier xxxxxxx-fr-fr, les autres sont effacés.

 

Peut t'ont utiliser OCT et config.xml pour la personnalisation ? car certaines étapes ne peuvent être qu'exécuter à partir de Config.xml...

 

edit: j'ai repris de zéro....

 

extraction du SP2, extraction des maj (Aout, septembre, cotobre, novembre) que je copie par logique dans le SP2, au final, il me demande la KB2825640 du 27/8/2013, KB2598242 et le SP1 KB2510690....

 

Faut donc intégrer le SP1 avec ? je croyais qu'en intégrant le SP2, on pouvais s'en passer....

 

SP1 > Lang > SP2 et maj pour faire bien ?

Edited by Alpha_95

Share this post


Link to post
Share on other sites

Hello,

Je viens de refaire une installation propre de XP avec Office 2010 32 bit comme indiqué : extraction des SP1 et SP2, puis téléchargement à neuf de toutes les mises à jour de la liste (sauf SP2 que j'avais déjà), puis placé le tout dans le dossier "updates" (deux choses à signaler : une des mises à jour de la liste n'arrivait pas à se télécharger - novembre je crois-, une autre écrase 6 fichiers proof-xx-xx.msp du SP2) : le résultat final n'est pas probant, car MU retélécharge le SP2 pour en réparer l'installation. Des mises à jour ont été retéléchargées ensuite, mais je pense que c'est celles du mois en cours.

Il y a donc un couac quelque part. Est-ce dû à l'écrasement ?

Voici les MAJ téléchargées par ordre croissant : KB2850079, KB982726 (MAJ définitions de novembre manquante), KB2837593 (Word), KB2760631, KB2817670, KB2850016, puis le SP2 KB2687455.

Edited by rhahgleuhargh

Share this post


Link to post
Share on other sites

Bonsoir,

 

j'ai regardé sur mon PC (Win 7 Integrale x64) et j'ai 35 MAJ office 2010 donc en regardant avec le logiciel :

KB2827323, KB2767913 n'y figure pas.

 

La catégorie SP2 est toujours bug sur ton .ulz ou c'est crocrotte...

 

edit:

 

j'avais un Office 2010 SP1 avec Lang & SP2 inclus à jour jusqu'en novembre, je viens de l'installer pour voir les majs et la surprise :

 

 

Il redemande le SP1... donc je me demande si il y aurais pas une merde à quelques pars...

q9we.jpg

 

après un reboot :

kb2553270 et KB2687455...  y a comme qui dirait un problème... ^^

et la les MAJ que j'ai faite avec une installation manuel sur mon PC :

yjzl.jpg

Je le répète, l'iso fonctionnait très bien avant les MAJ de décembre ! Je n'avais aucune mise à jour demandée !!

Edited by Alpha_95

Share this post


Link to post
Share on other sites

Hello,

Je pense avoir trouvé la cause du problème !

Nouveau test en machine virtuelle ce jour : Office 2010 32 bits avec seulement le pack SP2 et les mises à jour d'août à novembre (pas de souci de téléchargement cette fois) extraits dans le dossier updates. J'ai par contre renommé les 6 fichiers proof-xx-xx.msp extraits des mises à jour de novembre (proof-ar-sa.msp, proof-de-de.msp, proof-en-us.msp, proof-es-es.msp, proof-fr-fr.msp et proof-nl-nl.msp) en proof-xx-xx_.msp (soit par ex proof-fr-fr_.msp) de manière à ce que le fichier de mise à jour soit installé juste après celui qui était dans le SP2.

Résultat : seules les trois mises à jour de décembre (KB2850016, KB2837593, KB2850079) sont demandées !

Conclusion :

- pas besoin des fichiers provenant du SP1 (j'avais déjà des doutes, le SP2 étant cumulatif)

- penser à renommer les 6 fichiers proof-xx-xx.msp de manière à ce qu'ils n'écrasent pas ceux du SP2 (sinon réparation du SP2 nécessaire).

Share this post


Link to post
Share on other sites

Bonjour Rhahgleuhargh,

 

Bravo pour cette constatation. Cela fait 2 semaines que je tourne sur ce sujet, sans résultat.

Suite à cela, j'ai mis à jour les éléments (page 1) pour le pack de décembre.

 

Merci pour ton travail.

 

Gilles

Share this post


Link to post
Share on other sites

Hello,

De rien, merci surtout à toi de te casser le tronc pour récupérer les mises à jour !

Il y a un souci avec le script d'extraction du mois de décembre : rien ne se passe lorsqu'on appuie sur une touche (j'ai vu que tu as fait des modifs pour renommer les fichiers proff-xx-xx.msp, je pense que le souci vient de là), le programme se ferme ensuite lorsqu'on appuie sur une touche sans créer le dossier Updates extract.

Je n'ai téléchargé pour mon test que les mises à jour de novembre et décembre. Par contre, les mises à jour s'extraient correctement si on utilise la version du script précédente avec le fichier Office 2010 - KB date.txt de décembre.

Share this post


Link to post
Share on other sites

Bonsoir,

 

Je suis surpris sur ce que tu me dis sur le script d'extraction. Je viens de refaire le test en téléchargeant via WUD, je n'ai pas de soucis.

Je suis sous Seven. C'est peut-être ca le problème. Je regarde et je reviens

 

Vérif faite aussi sous XP SP3, pas de problème à signaler.

 

Tu as une trace de l'exécution ?

Edited by gillesg

Share this post


Link to post
Share on other sites

Salut,

 

donc je télécharge X16-32253.exe que j'extrait, j'extrait le template AdminTemplates_32bit.exe puis je télécharge avec WUD et le fichier .ulz de décembre

 

Outils création du pack Office 2010
2013 - Aout
2013 - Decembre
2013 - Novembre
2013 - Octobre
2013 - Septembre

 

J'ai extrait le SP2 puis les maj de Aout à décembre (suppression des .xml)  et il réclame :

KB2589298, KB2598242,KB2760631 et KB2510690

Edited by Alpha_95

Share this post


Link to post
Share on other sites

En fait le script bloque après cet écran (pièce jointe) :

Dès que j'appuie sur une touche pour continuer, tout défile très vite (j'ai le temps de lire " le fichier spécifié est introuvable"), puis le script se ferme sans que le dossier d'extraction soit créé. Je pense que ça plante au moment du renommage des fichiers. Sur la version précédente de ton script, le renommage des fichiers extraits se fait, puis tout se met dans Update extract avant que le fichier de commande ne se ferme.

A noter que je n'ai pas mis le pack SP2, déjà extrait dans un autre dossier, mais seulement les mises à jour de novembre et décembre.

je travaille aussi sur Windows 7 64 bits, pas testé sur XP ; le script d'extraction est mis dans le même dossier que les mises à jour téléchargées et le fichier .txt.

EDIT : même problème sur XP ! RAS avec la version du script de novembre.

Edited by rhahgleuhargh

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...